Microsoft Excel

Herbers Excel/VBA-Archiv

Steuerelement - Kombinationsfeld nur Zahlen anzeig

Betrifft: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Arthur
Geschrieben am: 30.10.2012 09:31:56

Guten Morgen zusammen

Ich habe eine Array Formel die mir nicht nur Zahlen anzeigt, sondern auch #Zahl:

123123412 34 21 1
234321 12 21 122
12321 2212 41
#Zahl
#Zahl
#Zahl
#Zahl
#Zahl
#Zahl
#Zahl

Wie kann ich über Steuerelemente Kombinationsfeld nur die Einträge im Dropwodn anzeigen lassen, welche auch Zahleneinträge sind? Sprich ich will keine #Zahl Einträge im Dropdown.

Arrayformel:
=INDEX(Berechnung!$B$6:$B$500;KKLEINSTE(WENN(Berechnung!$F$6:$F$500>=Berechnung!$R$6:$R$500; WENN(Berechnung!$F$6:$F$500>0;$C$77:$C$503;"");"");$C77))

Ich habe das Problem gelöst mit einem Dropdown (mit Datenüberprüfung und einer Liste). Aber ich möchte das Ganze über ein Steuerelement lösen, denn nur dann zeigt mir Excel den Pfeil immer automatisch an.

Vielen Dank für eure Hilfe

Arthur

  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Beverly
Geschrieben am: 30.10.2012 10:27:25

Hi Arthur,

verwende einen dynamisch definierten Namen (bezogen auf eine Hilfsspalte) und weise ihn dem Steuerelement als Datenquelle zu.

Ich habe gerade kein Beispiel mit #Zahl als Fehlerausgabe, deshalb einfach mal mit #NV. Sollte aber auch mit #Zahl funktionieren.

Tabelle1

 AB
1123123412 34 21 11
2234321 12 21 1222
312321 2212 413
4#NV 
5#NV 
6#NV 
7#NV 
8#NV 
9#NV 
10#NV 

verwendete Formeln
Zelle Formel Bereich
A1 =WENN(G1="";#NV;G1) 
B1 =WENN(ISTFEHLER(A1);"";ZEILE(A1)) 
A2 =WENN(G2="";#NV;G2) 
B2 =WENN(ISTFEHLER(A2);"";ZEILE(A2)) 
A3 =WENN(G3="";#NV;G3) 
B3 =WENN(ISTFEHLER(A3);"";ZEILE(A3)) 
A4 =WENN(G4="";#NV;G4) 
B4 =WENN(ISTFEHLER(A4);"";ZEILE(A4)) 
A5 =WENN(G5="";#NV;G5) 
B5 =WENN(ISTFEHLER(A5);"";ZEILE(A5)) 
A6 =WENN(G6="";#NV;G6) 
B6 =WENN(ISTFEHLER(A6);"";ZEILE(A6)) 
A7 =WENN(G7="";#NV;G7) 
B7 =WENN(ISTFEHLER(A7);"";ZEILE(A7)) 
A8 =WENN(G8="";#NV;G8) 
B8 =WENN(ISTFEHLER(A8);"";ZEILE(A8)) 
A9 =WENN(G9="";#NV;G9) 
B9 =WENN(ISTFEHLER(A9);"";ZEILE(A9)) 
A10 =WENN(G10="";#NV;G10) 
B10 =WENN(ISTFEHLER(A10);"";ZEILE(A10)) 

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
Liste=BEREICH.VERSCHIEBEN(Tabelle1!$A$1;;;MAX(Tabelle1!$B:$B);1) =BEREICH.VERSCHIEBEN(Tabelle1!Z1S1;;;MAX(Tabelle1!S2);1)

Tabellendarstellung in Foren Version 5.49




GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Arthur
Geschrieben am: 30.10.2012 11:50:35

Hallo Beverly

Vielen Dank für deine Hilfe! Trotzdem kriege ich es nicht hin. Ich hab jetzt 2 Stunden rumgebastelt und getestet :-( Soo gut bin ich dann in Excel auch wieder nicht.

https://www.herber.de/bbs/user/82385.xlsm

In A33 siehst du mein Dropdown, welches schon funktioniert. Aber eben, es wird dieser blöde Pfeil nicht automatisch angezeigt. Deshalb benötige ich das Dropdown mit den Steuerelementen.

Unten ab A77 sind dann alle Daten.

jetzt soll mir das Steuerelemente Dropdown nur die Zahlen (ein Dropdown für Spalte A Zahlen und ein DD für Spalte B Daten) anzeigen und kein ZAHL mehr auch kein 0 oder eine leere Zelle. Kannst du mir bitte zeigen, wie ich es in meiner Tabelle erstellen kann?

Vielen Dank!

Arthur


  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Arthur
Geschrieben am: 30.10.2012 11:50:54

Hallo Beverly

Vielen Dank für deine Hilfe! Trotzdem kriege ich es nicht hin. Ich hab jetzt 2 Stunden rumgebastelt und getestet :-( Soo gut bin ich dann in Excel auch wieder nicht.

https://www.herber.de/bbs/user/82385.xlsm

In A33 siehst du mein Dropdown, welches schon funktioniert. Aber eben, es wird dieser blöde Pfeil nicht automatisch angezeigt. Deshalb benötige ich das Dropdown mit den Steuerelementen.

Unten ab A77 sind dann alle Daten.

jetzt soll mir das Steuerelemente Dropdown nur die Zahlen (ein Dropdown für Spalte A Zahlen und ein DD für Spalte B Daten) anzeigen und kein ZAHL mehr auch kein 0 oder eine leere Zelle. Kannst du mir bitte zeigen, wie ich es in meiner Tabelle erstellen kann?

Vielen Dank!

Arthur


  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Beverly
Geschrieben am: 30.10.2012 13:41:57

Hi Artur,

einen dynamischen Bereichsnamen hast du doch bereits "Rabatt".

Verwende z.B. eine ComboBox aus den ActiveX-Steuerelementen und und weise unter der Eigenschaft ListFillRange den Bereich Rabatt zu. Falls du den ausgewählten Wert weiter verwenden willst, kannst du der Eigenschaft LinkedCell eine Zelladresse zuweisen, sodass dieser dann in der Zelle angezeigt wird (im Beispiel A33).

https://www.herber.de/bbs/user/82387.xlsm


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Arthur
Geschrieben am: 30.10.2012 14:55:26

Hallo Karin

Och, ich stand irgendwie auf dem Schlauch. Vielen Dank, jetzt klappt alles einwandfrei!
Noch eine kleine designtechnische Frage, das dropdownfeld ist ziemlich hoch (ca. 1.5 cm) und die Zahl z.B. 00835 41011 steht jetzt im Dropdown ganz zuobers. Kann ich dies irgendwie zentrieren?

TextAlign - Left passt (waagerecht) aber wie zentriere ich es vertikal?


  

Betrifft: AW: Steuerelement - Kombinationsfeld nur Zahlen anzeig von: Beverly
Geschrieben am: 30.10.2012 16:36:05

Hi Arthur,

eine Vertikael Zetrierung gibt es nicht.


GrußformelBeverly's Excel - Inn


 

Beiträge aus den Excel-Beispielen zum Thema "Steuerelement - Kombinationsfeld nur Zahlen anzeig"