Microsoft Excel

Herbers Excel/VBA-Archiv

MIN und MAX, aber nur wenn ...

Betrifft: MIN und MAX, aber nur wenn ... von: Michael Mueller
Geschrieben am: 30.10.2012 09:34:42

Hallo.

Habe mal eine Beispiel-Detei hochgeladen.

https://www.herber.de/bbs/user/82379.xls

Was ich gerne hätte wäre eine Formel, welche mir den Max und den Min aus Spalte B liefert, aber nur für die Werte, bei denen in Spalte A "Apfel" steht.

Mittelwert krieg ich ja noch hin, Summewenn durch Zählenwenn:
=SUMMEWENN(A1:B7;"Apfel";B1:B7)/ZÄHLENWENN(A1:A7;"Apfel")

Aber wie schaut es mit Min und Max aus, kennt da jemand eine passende Formel?

Danke
Michi

  

Betrifft: AW: MIN und MAX, aber nur wenn ... von: Rudi Maintaire
Geschrieben am: 30.10.2012 09:43:22

Hallo,
schau dir mal die Funktionen DBMIN() und DBMAX() an.

Gruß
Rudi


  

Betrifft: MatrixFormel ... {MIN(Wenn())} von: Matthias L
Geschrieben am: 30.10.2012 10:19:39

Hallo Rudi

Ging das nicht so ?

Tabelle1

 ABDE
1BaumHöheApfelMatrixFormel
2Apfel18Min8
3Birne12Max18
4Kirsche13  
5Apfel14  
6Birne9  
7Apfel8  

Formeln der Tabelle
ZelleFormel
E2{=MIN(WENN(A2:A7=D1;B2:B7))}
E3{=MAX(WENN(A2:A7=D1;B2:B7))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: MatrixFormel ... {MIN(Wenn())} von: Rudi Maintaire
Geschrieben am: 30.10.2012 10:24:01

Hallo,
natürlich geht das auch mit Matrixformeln.
Aber warum, wenn's auch anders geht?

Am Ende kommt wieder raus, dass die Liste in Wahrheit 500.000 Zeilen hat ;-)

Gruß
Rudi