Microsoft Excel

Herbers Excel/VBA-Archiv

Elemente zählen abhängig von anderen Spalten

Betrifft: Elemente zählen abhängig von anderen Spalten von: mjk
Geschrieben am: 30.10.2012 22:41:48

Liebe Excel-Profis,
ich habe ein Problem, daß wahrscheinlich gar nicht so schwer zu lösen wäre, wenn man wüsste wie es geht... Ich denke an sverweis, aber wie geht das für die Abprüfung von 2 Spalten? Bin für jeden Hinweis dankbar!

Die Tabelle: https://www.herber.de/bbs/user/82400.xlsx

Das Problem:
In Spalte B stehen verschiedene Untersuchungsproben.
In Spalte C stehen die Vermessungstypen verschiedener zu der jeweiligen Probe gehörigen Objekte. In Spalte C stehen die Messwerte.

Jedesmal wenn in Spalte B ein Typ "1" steht, beginnt ein neues zu vermessendes Objekt.
Die Anzahl der Objekte möchte ich jetzt zählen und in einer extra Spalte so ausgeben, daß zu allen vermessenen Elementen des Objektes (also die Typen 2,3,4,5,6,7) die Nummer des aktuellen Objektes geschrieben wird. Ich habe das in Spalte E für die ersten Objekte der ersten Untersuchungsprobe händisch gemacht.

Ich hoffe sehr, daß sich auch hierfür eine geniale Excel-Formel finden läßt, die Tabelle hat im Original ca 10000 Zeilen...

DANKE!

  

Betrifft: äußerst banal von: WF
Geschrieben am: 30.10.2012 22:54:53

Hi,

in E2 folgende Formel:
=WENN(C2=1;G1+1;G1)
runterkopieren

WF


  

Betrifft: da ging was durcheinander von: WF
Geschrieben am: 30.10.2012 22:59:41

in E2:
=WENN(C2=1;SUMME(E1;1);E1)

WF


  

Betrifft: AW: da ging was durcheinander von: mjk
Geschrieben am: 30.10.2012 23:58:44

Oh Mann, Danke!
Ich traus mir kaum sagen, aber: ich hab zuerst nur den "Durcheinanderbeitrag" gesehen und habe es auch da nicht geschafft, die richtige Lösung draus zu machen.
Jetzt klappts ganz perfekt. Danke!


  

Betrifft: in E2: =N(E1)+(C2=1) (owT) von: Erich G.
Geschrieben am: 31.10.2012 12:35:08

(owT):=(ohne weiteren Text)


 

Beiträge aus den Excel-Beispielen zum Thema "Elemente zählen abhängig von anderen Spalten"