Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn



Excel-Version: 8.0 (Office 97)

Betrifft: Zählenwenn
von: Gregor
Geschrieben am: 24.06.2002 - 08:38:13

Guten Mortgen zusammen

Ich benutze folgende ZählenWenn Formel:
=ZÄHLENWENN(G2:IV2;C1)

Nun möcht ich in Zeile 2 nur einige bestimmte Zellen mit der Bedingung in Zelle C1 zählen. Ich habe es mit ";" und "," probiert, aber das geht nicht. Weiss jemand Rat?
Vielen Dank
Gregor

  

Re: Zählenwenn
von: MikeS
Geschrieben am: 24.06.2002 - 09:05:21

Hallo Gregor,

nur mal als Ansatz:

Tabelle: Tabelle1

 ABC
1HalloTestTest
2TestHalloHallo
3TestHallo 
4TestHallo 
5TestHallo 
6TestHallo 
7HalloTest 
8TestHallo 
9   
106  
11 {=SUMME(WENN(($A$1:$A$8=C1)*($B$1:$B$8=C2);1))}  
12geschweifte Klammern mit Strg+Shift+Eingabe-Taste  
13in A10 eingeben.  

Hilft Dir das?

Ciao MikeS

  

Re: Zählenwenn
von: Gregor
Geschrieben am: 24.06.2002 - 09:35:12

Hoi Mike
Danke für deine rasche Antwort. Ich komme mit deinem Vorschlag nicht weiter, nochmals mein Problem:

Ich möchte in einer Zeile ganz einfach nur einige Zellen überprüfen (nicht die ganze Zeile), und falls die Bedingung zutrifft zählen:
ZB: Wenn in Zelle B3, B7, B11, B15, B19 eine 16 steht, will ich diese Zählen.

Gruss Gregor



  

Re: Zählenwenn
von: MikeS
Geschrieben am: 24.06.2002 - 09:58:06

Hallo Gregor,

Dein Beispiel läßt sich mit folgender Formel lösen:

=ZÄHLENWENN(B1:B19;16)

Ciao MikeS

  

Re: Zählenwenn
von: Gregor
Geschrieben am: 24.06.2002 - 10:09:20

Mike
Besten Dank.
Soweit bin ich auch gekommen. Ich will aber nicht alle Zellen von B1 bis B19 überprüfen, sondern nur eine Auswahl davon. Und genau hier liegt mein Problem!

Gibt es dafür eine Formel?
Gregor


  

Re: Zählenwenn
von: MikeS
Geschrieben am: 24.06.2002 - 10:38:24

Warum willst Du denn nur eine Auswahl davon in die Formel einbeziehen???

Bitte Info

Ciao MikeS


  

Re: Zählenwenn
von: Gregor
Geschrieben am: 24.06.2002 - 13:10:18

Mike

In der Tabelle hat es Spalten mit gleichen Bedingungen in Form von Codes, die nicht addiert werden dürfen.
ZB.
Spaltenüberschriften Ereignis = code 1 bis 16
Spaltenüberschriften Ortsbezeichnung = code 1 bis 6

Alle Spalten können in einer Zeile 1 bis max 50 mal vorkommen. Ich möchte nun pro Zeile die Anzahl verschiedene Ereignisse auswerten, die natürlich mit den andern Code nicht vermischt werden dürfen. Die Code sind gegeben und können nicht angepasst werden.

Vielen Dank und Gruss
Gregor


  

mit Summenformel klappt`s
von: MikeS
Geschrieben am: 24.06.2002 - 15:38:40

Hallo Gregor,

wie wär`s denn hiermit:

Tabelle: ZählenWenn

 A
1 
216
3 
4 
516
6 
716
8 
93
10 
11"16" als Text formatieren
12 
13Formel in A9:
14 =SUMME((A2="16")+(A5="16")+(A7="16"))

War`s das???

Ciao MikeS

  

Re: mit Summenformel klappt`s
von: Gregor
Geschrieben am: 24.06.2002 - 17:25:03

Mike
Recht herzlichen Dank, genau dieses Ergebnis wollte ich erreichen.

Bei mir muss ich es nicht als Textformat ("16") eingeben sondern nur die (16). Somit kann ich auf eine Zelle Bezug nehmen.

Ich wünsche einen geruhsamen Abend
Gregor


  

Re: mit Summenformel klappt`s
von: MikeS
Geschrieben am: 24.06.2002 - 19:12:16

Hallo Gregor,

da hast Du natürlich Recht.

So klappt die Formel auch bei mir.

=SUMME((A2=16)+(A5=16)+(A7=16))

Hauptsache, Dein Problem ist gelöst.

Viel Spaß noch beim tüfteln.

Ciao MikeS