Formel kopieren



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Formel kopieren
von: Thomas H.
Geschrieben am: 13.07.2002 - 11:37:22

Hallo Leute,

ich habe ein kleines Problem mit einer Formel.
Diese Formel (=SVERWEIS(N9;Dichte!A1:B20;2;FALSCH) funktioniert ganz gut, dass Problem ist, wenn ich jetzt die Formel kopiere und dann eine Zelle darunter einfüge verändern sich immer diese Werte ( N und A:B ).
=SVERWEIS(N10;Dichte!A2:B21;2;FALSCH)
=SVERWEIS(N11;Dichte!A3:B22;2;FALSCH)
=SVERWEIS(N12;Dichte!A4:B23;2;FALSCH)
Diese Werte dürfen sich aber nicht ändern.
Da ich diese Formel aber von Zelle IV9 bis IV208 brauche ist es ganz schön zeitaufwändig diese Formel in jede Zelle einzeln einzugeben.
Wie kann ich es mit einen Makro schneller machen????

Thomas H.

nach oben   nach unten

Re: Formel kopieren
von: Hajo_Zi
Geschrieben am: 13.07.2002 - 11:40:22

Hallo Thomas

arbeite mit absolut bEzügen N$10 für Zeile $N10 für Spalte Und $n$10 für Zeile und Spalte

Gruß Hajo


nach oben   nach unten

Re: Formel kopieren
von: Thomas H
Geschrieben am: 13.07.2002 - 11:53:42

Hallo Hajo,

vielen Dank für Deine Hilfe.

Thomas.


nach oben   nach unten

Re: Formel kopieren
von: Heinz
Geschrieben am: 13.07.2002 - 12:13:08

Hallo Thomas,

ein anderer Weg mit kleinen Vorteilen:

=SVERWEIS(N10;Dichte!A2:B21;2;FALSCH)

vergib deinem Bereich A2:B21 im Tabellenblatt Dichte einen Namen.

Bereich markieren,
Einfügen Namen Definieren Z.B. Werte
Dann könnte deine Formel lauten:

=sverweis(N10;werte;2;Falsch) anstelle von Falsch reicht auch 0

Der Vorteil dieser Namen ist, dass wenn sich der Bereich A2:b21 ändern würde, nur der Bereich des Namens geändert werden muß. In allen Formeln wäre dann automatisch der neue Bereich vorhanden.

Gruß Heinz

PS:
Hallo Hajo, ich mische mich nicht gerne in abgeschlossene Dialoge ein, aber ich denke zwei Wege zur auswahl sind besser.

Gruß Heinz

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formel kopieren"