Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen

Dynamisches Diagramm

Betrifft: Dynamisches Diagramm von: Alex
Geschrieben am: 05.08.2014 13:44:48

Hallo zusammen,

ich habe versucht ein dynamisches Diagramm zu erstellen. Meine Bereiche habe ich folgendermaßen definiert:

=BEREICH.VERSCHIEBEN(WiBe!$C$27;;;;ANZAHL2(WiBe!$27:$27)-1)

jeweils für die X- und Y-Werte.

Der Bereich beinhaltet in der leeren Zellen jedoch die Bedingung: =WENN(A1="";"";A1). Jetzt habe ich das Problem, dass sich mein Diagramm wegen dem "" nicht verändert. Lösche ich das "" jeweils manuell raus verändert sich mein Diagramm auch. Ich hätte es jedoch gerne in den Zellen stehen

  

Betrifft: AW: Dynamisches Diagramm von: Alex
Geschrieben am: 05.08.2014 13:50:20

gibt es nicht eine Möglichkeit bspw. folgendes zu sagen: =WENN(A1="";lösche Funktion;A1)?


  

Betrifft: AW: Dynamisches Diagramm von: Daniel
Geschrieben am: 05.08.2014 14:05:40

hi
teste mal ANZAHL anstelle von ANZAHL2.
ANZAHL zählt nur Zahlen und damit keine "".
ANZAHL2 zählt alles, was keine echte Leerzelle ist.

Gruß Daniel


  

Betrifft: AW: Dynamisches Diagramm von: fcs
Geschrieben am: 05.08.2014 14:15:58

Hallo Alex,


verwende statt ANZAHL2 die Funktion SUMEENPRODUKT mit einem entsprechenden Kriterium.

SUMMENPRODUKT((WiBe!$27:$27<>"")*1)-1
Gruß
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "Dynamisches Diagramm"