Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung einer Zahl nach Buchstabe

Betrifft: Auswertung einer Zahl nach Buchstabe von: Muehli
Geschrieben am: 24.10.2014 07:19:44

Guten Morgen zusammen,

ich habe folgende Frage:

Eine Spalte ist wie folgt aufgebaut:

|Spalte C|
|Wort Wort Wort [beliebig viele Leerzeichen] 0.1 |
|Wort Wort Wort Wort [beliebig viele Leerzeichen] M0.3|
|Wort Wort [beliebig viele Leerzeichen] 0.2 |
|Wort Wort [beliebig viele Leerzeichen] 0.5 |
| usw. |

Wenn nun bei der Zahl ein "M" dabei steht, dann soll in der Spalte rechts daneben "MIT" stehen. Ist kein "M" dabei, soll "OHNE" erscheinen.

Bsp.:

|Spalte C______________________________|Spalte D|
|Wort Wort Wort [beliebig viele Leerzeichen] 0.1 |OHNE|
|Wort Wort Wort Wort [beliebig viele Leerzeichen] M0.3|MIT|
|Wort Wort [beliebig viele Leerzeichen] 0.2 |OHNE|
|Wort Wort [beliebig viele Leerzeichen] 0.5 |OHNE|
| usw. |

Die Anzahl der Wörter ist sehr unbeständig.

Weiss jemand, wie man das lösen könnte?

Freundliche Grüße,
Muehli

  

Betrifft: AW: Auswertung einer Zahl nach Buchstabe von: Uwe Küstner
Geschrieben am: 24.10.2014 07:30:37

Hallo,

wenn das M immer an der vorletzten Position ist, z.B. so:

=WENN(TEIL(C10;LÄNGE(C10)-1;1)="M";"MIT";"OHNE")

Gruß Uwe


  

Betrifft: AW: Auswertung einer Zahl nach Buchstabe von: Muehli
Geschrieben am: 24.10.2014 07:41:39

Hallo Uwe,

danke für die schnelle Antwort!

Wenn es folgendermaßen einfüge:

=WENN(TEIL(C2;LÄNGE(C2)-3;1)="M";"MIT";"OHNE")

Dann funktioniert das in folgendem Fall:

|Spalte C|
|Wort Wort Wort [beliebig viele Leerzeichen] 0.1 |OHNE|
|Wort Wort Wort Wort [beliebig viele Leerzeichen] M0.3|MIT|

Jedoch kommt es auch vor, dass zum Beispiel 10.5 oder M12.4 bzw. 100.3 oder M108.0 usw. dahinter steht. Dann funktioniert das Ganze leider nicht mehr.

Gruß
Muehli


  

Betrifft: mit VERWEIS() und WECHSELN() ... von: neopa C (paneo)
Geschrieben am: 24.10.2014 08:24:51

Hallo Muehli,

... sollte das gewünschte gehen:

=WENNFEHLER(WENN(RECHTS(WECHSELN(C1;WECHSELN(VERWEIS(9^9;0+RECHTS(WECHSELN(C1;".";",");SPALTE(1:1))); ",";".");"");1)="M";"Mit";9/0);"Ohne")

Gruß Werner
.. , - ...


  

Betrifft: AW: mit VERWEIS() und WECHSELN() ... von: Muehli
Geschrieben am: 24.10.2014 09:25:24

Hallo Werner,

danke für deine Antwort!

mit deiner Variante funktioniert es fast perfekt.
Einziges Problem ist, wenn eine Zelle so aussieht:

|Wort Wort Wort [beliebig viele Leerzeichen] M0.0 |

Dann erkennt er nicht, ob ein "M" davor steht.

Es geht nur ab 0.1 Aufwärts.

Gruß
Muehli


  

Betrifft: AW: Auswertung einer Zahl nach Buchstabe von: Uwe Küstner
Geschrieben am: 24.10.2014 08:29:50

Hallo,

so sollte es klappen:

=WENN(LINKS(TEIL(A1;VERWEIS(9^9;FINDEN(" ";A1;ZEILE(1:999)))+1;9^9);1)="M";"MIT";"OHNE")

Gruß Uwe


  

Betrifft: wenn das letzte "Wort" aber " mmm" ist ... von: neopa C (paneo)
Geschrieben am: 24.10.2014 08:58:50

Hallo Uwe,

... oder "Leerzeichen M", dann käme als Ergebnis auch "MIT". Aber vielleicht reicht aber ja Deine Formel trotzdem schon.

Schönen Tag Dir noch. Ich blende mich erst mal wieder aus, denn hier "brennt gerade mal wieder die Luft".


Gruß Werner
.. , - ...


  

Betrifft: AW: wenn das letzte "Wort" aber " mmm" ist ... von: Muehli
Geschrieben am: 24.10.2014 09:38:59

Hallo Uwe,

danke für deine Antwort!

Deine Variante funktioniert auch prima.

Das einzige Problem das ich nun habe ist, dass wenn ich die Formel kopiere, es ab Zeile 50 nicht mehr funktioniert.

Es wird dann lediglich #NV eingetragen.
Probleme macht: ZEILE(1:999), da es durch das kopieren automatisch erhöht wird ZEILE(50:1049).

Ich muss dann wieder 1:999 eintragen und es funktioniert wieder.
Kann ich irgendwie unterbinden, dass dieser Wert automatisch ehöht wird?

Gruß
Muehli


  

Betrifft: Jetzt aber !? von: Uwe Küstner
Geschrieben am: 24.10.2014 11:16:04

Hallo Muehli,

ja, die Zeilen müssen absolut (mit $) gesetzt werden.
Zudem habe ich Werners Vorschlag eingesetzt:

=WENN(ISTNV(TEIL(A1;VERWEIS(9^9;FINDEN(" M";A1;ZEILE($1:$999)))+1;9^9));"OHNE";"MIT")

Gruß Uwe


  

Betrifft: AW: Auswertung einer Zahl nach Buchstabe von: fcs
Geschrieben am: 24.10.2014 07:30:58

Hallo Muehli,

Formel in D2:

=WENN(LINKS(GLÄTTEN(TEIL(C2;SUCHEN("]";C2)+1;20));1)="M";"MIT";"OHNE")
Gruß
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "Auswertung einer Zahl nach Buchstabe"