Microsoft Excel

Herbers Excel/VBA-Archiv

Urlaubsberecnung

Betrifft: Urlaubsberecnung von: Lars
Geschrieben am: 24.10.2014 14:47:24

Hallo Leute
ich hab da ne Formel die mir den Urlaub zusammen zählt. Die Feiertage werden dabei nicht mitgezählt. Jetzt müsste die Formel erweitert werden das wenn ich frei habe und trotzdem Urlaub drinn steht der nicht mitgezählt wird. Kann mir da jemand helfen?

mfg Lars

Hier ein Beispiel:
https://www.herber.de/bbs/user/93341.xls

  

Betrifft: AW: Urlaubsberecnung von: Bernd
Geschrieben am: 24.10.2014 15:12:58

Hallo Lars,

vielleicht so, wobei "Leer = Freischicht" eigentlich 0=Freischicht ist.

=SUMMENPRODUKT((D6:AH6="U")*(WOCHENTAG(D3:AH3;2)<8)*(D5:AH5<>0)*ISTFEHLER(VERGLEICH(D3:AH3; Listen!$H$2:$H$17;))) *8/8

Viele Grüße
Bernd


  

Betrifft: AW: Urlaubsberecnung von: Lars
Geschrieben am: 24.10.2014 15:26:29

Hi Bernd
vielen dank für deine schnelle Antwort. Klappt super. Danke

mfg Lars


  

Betrifft: Urlaubsberec(h)nung von: Matthias L
Geschrieben am: 25.10.2014 04:22:13

Hallo Lars

Mir sind da 2 Dinge aufgefallen.

Urlaubszettel 453

 WXYZAAABACADAEAF
7DoFrSaSoMoDiMiDoFrSa
820212223242526272801
92223333   


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Hier wird schon der 1 März mit angezeigt(2014)




Hier (Jahreswahl=2008) wird der Muttertag nicht korrekt anezeigt.

Listen

 CD
901.01.2008Neujahr
1001.05.2008Christi Himmelfahrt
Vatertag  &   Erster Mai
1111.05.2014Muttertag
1215.08.2008Maria Himmelfahrt


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Das solltest Du überarbeiten.

Übrigens, wenn Muttertag auf Pfingsten fällt ist er eine Woche vor Pfingsten!
Dementsprechend müsstest Du Deine Formel noch anpassen.

Gruß Matthias