Summenprodukt stört sich an Text

Bild

Betrifft: Summenprodukt stört sich an Text
von: Thomas
Geschrieben am: 12.05.2015 08:30:31

Hallo zusammen.
Ich habe nun etliche Beispiele und Beiträge gelesen, komme jedoch bei mir auf keinen Nenner und langsam gehen mir die Ideen aus.
Folgendes Ergebnis soll erzielt werden:
Suchkriterium 1: A5 "Neuanstrich Fassade"
in Spalte G "Anteil Invest"
multipliziert mit dem Prozentsatz aus Spalte J "V1"
Problem: in Spalte G und J stehen auch Wörter.
Vielen Dank für Eure Bemühungen vorab.
grobe Kostenanalyse

 ABCDEFGHIJKLMR
4Gewerke energetischer Sanierung:Gesamt:Eigenleistung:InvestitionV1V2V3V4   
5Neuanstrich Fassade15.386,41 €0,00 €15.386,41 €#WERT!       
37              
38Fassade     Gesamt: inkl. MwStAnteil InvestAnteil Eigenlei. Ausführung VarianteZuordnung
39     81.806,19 €   Titel
40Anstricharbeiten Fassadex AnzahlEinheit15.386,41 €15.386,41 €0,00 € V1V2V3V4
41Gerüst  575qm0,00 €0,00 €0,00 €     Neuanstrich Fassade
42Abbruch/Vorarbeitenx 575,1qm1.231,86 €1.231,86 €0,00 € 50%   Neuanstrich Fassade
43Schlussanstrich Fassadex 575,1qm7.528,06 €7.528,06 €0,00 €     Neuanstrich Fassade
44Ausbesserungsarbeiten Giebelx 575,1qm5.474,95 €5.474,95 €0,00 €     Neuanstrich Fassade
45Anstrich Dachgesimsx 46,1qm1.151,54 €1.151,54 €0,00 €     Neuanstrich Fassade
49Dämmung/Sanierung Giebelseite linksx AnzahlEinheit5.647,91 €5.647,91 €0,00 €     
52Rückbau, Leibungen etc.x 30,5lfm326,44 €326,44 €0,00 €     Dämmung Fassade Giebel
53Fensterbank  Rückbaux 7,2lfm72,83 €72,83 €0,00 €     Dämmung Fassade Giebel

Formeln der Tabelle
ZelleFormel
A4=Eingabe!B50
A5=Eingabe!B93
B5=SUMMENPRODUKT(($R$38:$R$604=A5)*($F$38:$F$604<>0); $F$38:$F$604)
D5=SUMMENPRODUKT(($R$38:$R$604=A5)*($H$38:$H$604<>0); $H$38:$H$604)*-1
F5=SUMME(B5:E5)
G5=SUMMENPRODUKT(($R$38:$R$604=A5)*($G$38:$G$604<>0)*($J$38:$J$604>0);($G$38:$G$604*J38:J604))
F39=F40+F49+F64+F79+G90
F40=WENN(B40="x";(SUMME(F41:F48)); 0)
G40=WENN(B40="x";(SUMME(G41:G48)); 0)
H40=WENN(B40="x";(SUMME(H41:H48)); 0)
D41=Erfassungsbogen!O2+Erfassungsbogen!P2
F41=WENN(UND(B$40="x";B41="x");(Q41*D41*WENN(P41="";1;P41)*(1+AD$2)); 0)
G41=F41-H41
H41=WENN(ODER(O41="";O41=0); 0;F41*O41)
D42=D41
F42=WENN(UND(B$40="x";B42="x");(Q42*D42*WENN(P42="";1;P42)*(1+AD$2)); 0)
G42=F42-H42
H42=WENN(ODER(O42="";O42=0); 0;F42*O42)
D43=D41
F43=WENN(UND(B$40="x";B43="x");(Q43*D43*WENN(P43="";1;P43)*(1+AD$2)); 0)
G43=F43-H43
H43=WENN(ODER(O43="";O43=0); 0;F43*O43)
D44=Erfassungsbogen!O2
F44=WENN(UND(B$40="x";B44="x");(Q44*D44*WENN(P44="";1;P44)*(1+AD$2)); 0)
G44=F44-H44
H44=WENN(ODER(O44="";O44=0); 0;F44*O44)
D45=SUMME(Erfassungsbogen!Z28;Erfassungsbogen!Z36)
F45=WENN(UND(B$40="x";B45="x");(Q45*D45*WENN(P45="";1;P45)*(1+AD$2)); 0)
G45=F45-H45
H45=WENN(ODER(O45="";O45=0); 0;F45*O45)
F49=WENN(B49="x";(SUMME(F52:F63)); 0)
G49=WENN(B49="x";(SUMME(G52:G63)); 0)
H49=WENN(B49="x";(SUMME(H52:H63)); 0)
D52=Erfassungsbogen!V112
F52=WENN(UND(B$49="x";B52="x");(Q52*D52*WENN(P52="";1;P52)*(1+AD$2)); 0)
G52=F52-H52
H52=WENN(ODER(O52="";O52=0); 0;F52*O52)
D53=Erfassungsbogen!W112
F53=WENN(UND(B$49="x";B53="x");(Q53*D53*WENN(P53="";1;P53)*(1+AD$2)); 0)
G53=F53-H53
H53=WENN(ODER(O53="";O53=0); 0;F53*O53)

[url=http://www.excel-jeanie-html.de]Excel Tabellen im Web darstellen - Excel Jeanie Html 4[/url]

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: SF
Geschrieben am: 12.05.2015 08:44:53
Hola,

und langsam gehen mir die Ideen aus.
ist der Aufbau zwingend vorgegeben?
Gruß,
steve1da

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: Thomas
Geschrieben am: 12.05.2015 08:56:32
Im Prinzip ja, es ist eine Kalkulation, welche sehr dynamisch gehandhabt wird. Es kommen Gewerke dazu oder auch mal weg. So wie die Darstellung ist, ist es für die Kunden nachvollziehbar. Wieso frägst Du. Was oder wie sollte ich es ändern?

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: SF
Geschrieben am: 12.05.2015 09:03:06
Hola,
wenn du den Teil mit "Ausführung Variante" nach oben setzt, könntest du die Formeln ab Zeile 39 beginnen lassen.
Gruß,
steve1da

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: Thomas
Geschrieben am: 12.05.2015 09:08:43
Ja, das habe ich schon versucht. Das geht nicht, weil es eine fortlaufende Liste mit einer Vielzahl von "Gewerken" ist. Diese Vielzahl an Gewerken werden wiederum in einer Maßnahme zusammen gefasst. Somit beinhaltet eine Maßnahme auch Teile aus unterschiedlichen Gewerken. Sonst wäre der Fall für mich klar gewesen.
LG TH

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: SF
Geschrieben am: 12.05.2015 09:10:23
Hola,
ok, das kannst nur du beurteilen.
Gruß,
steve1da

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: Werner
Geschrieben am: 12.05.2015 09:10:59
Hallo Thomas,
ohne dass ich mich jetzt näher damit beschäftigt habe. Hast du schon mal versucht deine verbundenen Zellen im Bereich J/M 38/39 aufzulösen? Verbundene Zellen mag Excel ja nicht so.
Gruß Werner

Bild

Betrifft: AW: Summenprodukt stört sich an Text
von: Thomas
Geschrieben am: 12.05.2015 09:20:28
Hallo Werner,
habe das gemacht, kam keine Reaktion. Wenn ich mit ISTZAHL arbeite kommt ein Ergenis zustande, jedoch addiert er mir nur die Prozentzahlen....Da steige ich nicht mehr durch....

Bild

Betrifft: AW: SummeWenns/ZâhlenWenns
von: Daniel
Geschrieben am: 12.05.2015 09:42:29
Hi
Du kannst deine Summenprodukte durch SummeWenns ersetzen (SummeWenn für mehrere Bedingungen)
Das ist diesbezüglich etwas unkritischer als Summenprodukt. (Gibet es seit Version 2007)
Gruß Daniell

Bild

Betrifft: AW: SummeWenns/ZâhlenWenns
von: Thomas
Geschrieben am: 12.05.2015 15:10:32
ok, das mit der Summewenn funktioniert in der zu summierende Spalte. Wie bekomme ich aber nun die Formel so hin, dass es mir mit dem gegenüberliegenden Prozentsatz multipliziert? Ich check das mit der Matrix einfach nicht so richtig.

Bild

Betrifft: kommt drauf an ...
von: der neopa C
Geschrieben am: 12.05.2015 15:38:13
Hallo Thomas,
... wenn Du ab Zeile 41 in Spalte J nur noch Prozentzahlen und oder evtl. nochmal "V1" zu stehen hast, dann so:
=SUMMENPRODUKT(($R$41:$R$604=A5)*ISTZAHL($G$41:$G$604);$G$41:$G$604*(WECHSELN(WECHSELN($J$41:$J$604; "V1";"0")&"x";"x";0)))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: kommt drauf an ...
von: Thomas
Geschrieben am: 12.05.2015 16:26:01
Hallo Werner,
danke. Kommt wieder #Wert

Bild

Betrifft: AW: kommt drauf an ...
von: Thomas
Geschrieben am: 12.05.2015 16:32:32
Fehler gefunden, in G steht noch "Anteil Invest:", habe es raus gelöscht, dann klappt es. muss wohl wechsel bei G einfügen....

Bild

Betrifft: AW: kommt drauf an ...
von: Thomas
Geschrieben am: 12.05.2015 16:37:02
jetzt hats geklappt, Dankeschön!!!

Bild

Betrifft: AW: kommt drauf an ...
von: Thomas
Geschrieben am: 12.05.2015 18:09:32
HAllo noch mal, da stimmt was nicht. Die Formel multipliziert stellenweise mit 10 und stellenweise mit hundert, komm einfach nicht drauf, keine Logik dahinter...
grobe Kostenanalyse

 ABCDEFGHI
4Gewerke energetischer Sanierung:Gesamt:Eigenleistung:InvestitionV1V2
5Dämmung Dach mit Spenglerarbeiten57.849,23 €0,00 €57.849,23 €0,00 €11.870,25 €
6Dämmung oberste Geschossdecke27.281,49 €0,00 €27.281,49 €54.056,49 €0,00 €
7Dämmung Fassade Giebel11.295,83 €0,00 €11.295,83 €0,00 €0,00 €
8Dämmung Fassade Straßenseite16.018,29 €0,00 €16.018,29 €0,00 €0,00 €
9Dämmung Fassade Hauseingangsseite14.860,01 €0,00 €14.860,01 €0,00 €0,00 €

Formeln der Tabelle
ZelleFormel
A4=Eingabe!B50
A5=Eingabe!B53
B5=SUMMENPRODUKT(($R$38:$R$558=A5)*($F$38:$F$558<>0); $F$38:$F$558)
D5=SUMMENPRODUKT(($R$38:$R$558=A5)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F5=SUMME(B5:E5)
G5=WENN(Varianten!J6>"";SUMMENPRODUKT(($R$40:$R$558=A5)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))/10;0)
H5=WENN(Varianten!U6>"";SUMMENPRODUKT(($R$40:$R$558=A5)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))/10;0)
A6=Eingabe!B55
B6=SUMMENPRODUKT(($R$38:$R$558=A6)*($F$38:$F$558<>0); $F$38:$F$558)
D6=SUMMENPRODUKT(($R$38:$R$558=A6)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F6=SUMME(B6:E6)
G6=WENN(Varianten!J7>"";SUMMENPRODUKT(($R$40:$R$558=A6)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))/10;0)
H6=WENN(Varianten!U7>"";SUMMENPRODUKT(($R$40:$R$558=A6)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))/10;0)
A7=Eingabe!B57
B7=SUMMENPRODUKT(($R$38:$R$558=A7)*($F$38:$F$558<>0); $F$38:$F$558)
D7=SUMMENPRODUKT(($R$38:$R$558=A7)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F7=SUMME(B7:E7)
G7=WENN(Varianten!J8>"";SUMMENPRODUKT(($R$40:$R$558=A7)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))/10;0)
H7=WENN(Varianten!U8>"";SUMMENPRODUKT(($R$40:$R$558=A7)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))/10;0)
A8=Eingabe!B59
B8=SUMMENPRODUKT(($R$38:$R$558=A8)*($F$38:$F$558<>0); $F$38:$F$558)
D8=SUMMENPRODUKT(($R$38:$R$558=A8)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F8=SUMME(B8:E8)
G8=WENN(Varianten!J9>"";SUMMENPRODUKT(($R$40:$R$558=A8)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))/10;0)
H8=WENN(Varianten!U9>"";SUMMENPRODUKT(($R$40:$R$558=A8)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))/10;0)
A9=Eingabe!B61
B9=SUMMENPRODUKT(($R$38:$R$558=A9)*($F$38:$F$558<>0); $F$38:$F$558)
D9=SUMMENPRODUKT(($R$38:$R$558=A9)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F9=SUMME(B9:E9)
G9=WENN(Varianten!J10>"";SUMMENPRODUKT(($R$40:$R$558=A9)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))/10;0)
H9=WENN(Varianten!U10>"";SUMMENPRODUKT(($R$40:$R$558=A9)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))/10;0)

[url=http://www.excel-jeanie-html.de]Excel Tabellen im Web darstellen - Excel Jeanie Html 4[/url]

Bild

Betrifft: um welche Formel geht es denn jetzt
von: der neopa C
Geschrieben am: 12.05.2015 19:28:17
Hallo Thomas,
... Du hast hier alle Deine Formeln aufgezeigt. Am einfachsten wäre es, wenn Du mal einen relevanten Auszug aus Deiner Datei hier im Forum hochlädst.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: um welche Formel geht es denn jetzt
von: Thomas
Geschrieben am: 12.05.2015 20:40:15
Hallo Werner,
du hast recht, hätte ich schon früher machen sollen...
https://www.herber.de/bbs/user/97607.xlsx

Bild

Betrifft: Du hast nicht bedacht, ...
von: der neopa C
Geschrieben am: 13.05.2015 08:49:39
Hallo Thomas,
... dass Du in Deiner Datei Bezug nimmst auf eine andere und auch nicht erklärt wo genau jetzt Dein Problem besteht.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Du hast nicht bedacht, ...
von: Thomas
Geschrieben am: 13.05.2015 09:02:06
Hallo Werner,
ich habe die Datei noch einmal hochgeladen, in der Hoffnung die Bezüge soweit bereinigt zu haben. in den gelb markierten Spalten G/H/... steht deine Formel. Als Referenzergebnis kann das der Spalte F heran gezogen werden. In den Ergebnissen von G/H siehst Du gleich das Problem.
https://www.herber.de/bbs/user/97612.xlsx
grobe Kostenanalyse

 ABCDEFGHIJK
4Gewerke energetischer Sanierung:Gesamt:Eigenleistung:InvestitionV1V2V3V4
5Dämmung Dach mit Spenglerarbeiten57.849,23 €0,00 €57.849,23 €781.982,32 €265.572,30 €  
6Dämmung oberste Geschossdecke27.281,49 €0,00 €27.281,49 €540.564,94 €540.564,94 €  
7Dämmung Fassade Giebel11.295,83 €0,00 €11.295,83 €112.958,25 €112.958,25 €  
8Dämmung Fassade Straßenseite16.018,29 €0,00 €16.018,29 €160.182,93 €160.182,93 €  
9Dämmung Fassade Hauseingangsseite14.860,01 €0,00 €14.860,01 €148.600,06 €148.600,06 €  
10Nebengewerke energetischer Sanierung:       
11Neuanstrich Fassade19.834,81 €0,00 €19.834,81 €198.348,13 €   
12Hauseingangstür und restl. Treppenhausfenster8.972,60 €0,00 €8.972,60 €175.406,00 €   

Formeln der Tabelle
ZelleFormel
A4='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B50
A5='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B53
B5=SUMMENPRODUKT(($R$38:$R$558=A5)*($F$38:$F$558<>0); $F$38:$F$558)
D5=SUMMENPRODUKT(($R$38:$R$558=A5)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F5=SUMME(B5:E5)
G5=SUMMENPRODUKT(($R$40:$R$558=A5)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
H5=SUMMENPRODUKT(($R$40:$R$558=A5)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))
A6='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B55
B6=SUMMENPRODUKT(($R$38:$R$558=A6)*($F$38:$F$558<>0); $F$38:$F$558)
D6=SUMMENPRODUKT(($R$38:$R$558=A6)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F6=SUMME(B6:E6)
G6=SUMMENPRODUKT(($R$40:$R$558=A6)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
H6=SUMMENPRODUKT(($R$40:$R$558=A6)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))
A7='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B57
B7=SUMMENPRODUKT(($R$38:$R$558=A7)*($F$38:$F$558<>0); $F$38:$F$558)
D7=SUMMENPRODUKT(($R$38:$R$558=A7)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F7=SUMME(B7:E7)
G7=SUMMENPRODUKT(($R$40:$R$558=A7)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
H7=SUMMENPRODUKT(($R$40:$R$558=A7)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))
A8='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B59
B8=SUMMENPRODUKT(($R$38:$R$558=A8)*($F$38:$F$558<>0); $F$38:$F$558)
D8=SUMMENPRODUKT(($R$38:$R$558=A8)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F8=SUMME(B8:E8)
G8=SUMMENPRODUKT(($R$40:$R$558=A8)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
H8=SUMMENPRODUKT(($R$40:$R$558=A8)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))
A9='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B61
B9=SUMMENPRODUKT(($R$38:$R$558=A9)*($F$38:$F$558<>0); $F$38:$F$558)
D9=SUMMENPRODUKT(($R$38:$R$558=A9)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F9=SUMME(B9:E9)
G9=SUMMENPRODUKT(($R$40:$R$558=A9)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
H9=SUMMENPRODUKT(($R$40:$R$558=A9)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($K$40:$K$558;"V2";"0")&"x";"x";0))))
A11='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B93
B11=SUMMENPRODUKT(($R$38:$R$558=A11)*($F$38:$F$558<>0); $F$38:$F$558)
D11=SUMMENPRODUKT(($R$38:$R$558=A11)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F11=SUMME(B11:E11)
G11=SUMMENPRODUKT(($R$40:$R$558=A11)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))
A12='[Wirtschaftlichkeit Krauchenwieser Str 11-88512 Rulfingen 08_05_15.xlsx]Eingabe'!B94
B12=SUMMENPRODUKT(($R$38:$R$558=A12)*($F$38:$F$558<>0); $F$38:$F$558)
D12=SUMMENPRODUKT(($R$38:$R$558=A12)*($H$38:$H$558<>0); $H$38:$H$558)*-1
F12=SUMME(B12:E12)
G12=SUMMENPRODUKT(($R$40:$R$558=A12)*ISTZAHL($G$40:$G$558);(WECHSELN(WECHSELN($G$40:$G$558;"Anteil Invest";"0")&"x";"x";0)*(WECHSELN(WECHSELN($J$40:$J$558;"V1";"0")&"x";"x";0))))

[url=http://www.excel-jeanie-html.de]Excel Tabellen im Web darstellen - Excel Jeanie Html 4[/url]

Bild

Betrifft: dann eben ohne SUMMENPRODUKT() ...
von: der neopa C
Geschrieben am: 13.05.2015 14:08:24
Hallo Thomas,
... mir fehlt es momentan an Zeit genauer zu untersuchen, worin sich der Fehler in der SUMMENPRODUKT()Formel liegt.
Auf jeden Fall funktioniert nachfolgende MATRIX-Formel, die Du nach unten kopieren kannst und auch nach rechts (wenn Du dort die Zellverbindung aufhebst). Beachte auf jeden Fall den untenstehenden spez. Formeleingabeabschluss.

 G
557.849,23 €

Formeln der Tabelle
ZelleFormel
G5{=SUMME(WENN(($R$40:$R$558=$A5)*ISTZAHL(J$40:J$558); J$40:J$558*$G$40:$G$558))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!

Gruß Werner
.. , - ...


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht"