Frage Formel mit Oder

Bild

Betrifft: Frage Formel mit Oder
von: MDGGB
Geschrieben am: 20.08.2015 18:14:09

Hallo,
wie lautet bitte die korrekte Formel für E1:
Wenn A1 oder B1 oder C1 = 0, dann = 0; ansonsten (A1+B1)-C1
Danke!
https://www.herber.de/bbs/user/99740.xls

Bild

Betrifft: =WENN(A1*B1*C1=0;0;A1+B1-C1) ohne Oder
von: Michael
Geschrieben am: 20.08.2015 18:20:58


Bild

Betrifft: =(A1*B1*C1<>0)*(A1+B1-C1) und ohne WENN
von: WF
Geschrieben am: 20.08.2015 18:32:21
.

Bild

Betrifft: AW: Frage Formel mit Oder
von: Daniel
Geschrieben am: 20.08.2015 19:35:26
Hi
hier mal eine variante mit ODER:


=Wenn(Oder(A1=0;B1=0;C1=0);0;A1+B1-C1)
andere möglichkeit ohne Oder:
=Wenn(ZählenWenn(A1:C1;0)=1;0;A1+B1-C1)
Gruß Daniel

Bild

Betrifft: AW: Frage Formel mit Oder
von: Daniel
Geschrieben am: 20.08.2015 19:45:27
unter der berücksichtigung, dass man auch andere Vergleichswerte als 0 einsetzen will, auch dass:

=Wenn((A1=0)+(B1=0)+(C1=0)>0;0;A1+B1-C1)
hier gäbe es auch eine Variante ohne Wenn:

=((A1=0)+(B1=0)+(C1=0)=0)*(A1+B1-C1)
generell wird hier ausgenutzt, dass in einer Einzelberechnung mit +-*/ ein WAHR wie 1 und ein FALSCH wie 0 verwendet wird.
Das Funktioniert auch andersrum dh wenn man eine Zahl als Wahrheitswert verwendet, dann wird 0 wie FALSCH und alle anderen Zahlen wie WAHR gewertet.
somit kann man ein ODER mit einer Addtion simulieren und ein UND mit einer Multiplikation.
Gruß Daniel

Bild

Betrifft: AW: Frage Formel mit Oder
von: MDGGB
Geschrieben am: 21.08.2015 11:02:24
Vielen Dank für all die tollen Lösungen! Gruß

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Frage Formel mit Oder"