Zahlen untereinander in anderes Sheet schreiben

Bild

Betrifft: Zahlen untereinander in anderes Sheet schreiben
von: Christian R.
Geschrieben am: 21.10.2015 10:28:16

Hallo zusammen,
ich würde euch bitten mir bei meinem Problem zu helfen.
In angehängter Tabelle würde ich gerne alle Nullen entfernen und in ein anderes Sheet direkt untereinander kopieren. Leider stehe ich vollkommend auf dem Schlauch.
Das Ergebnis sollte so aussehen wie im angehängten Excel-File in 'Tabelle2'.
Vielen Dank im Voraus.
https://www.herber.de/bbs/user/100929.xlsx
Mit freundlichen Grüßen
Christian

Bild

Betrifft: AW: Zahlen untereinander in anderes Sheet schreiben
von: SF
Geschrieben am: 21.10.2015 10:31:38
Hola,
als Matrixformel (mit Strg-Shift-Enter abschließen!):

=WENNFEHLER(INDEX(Tabelle1!A$1:A$13;KKLEINSTE(WENN(Tabelle1!A$1:A$13>0;ZEILE($1:$13));ZEILE(A1)));"") 
Nach rechts und nach unten kopieren.
Gruß,
steve1da

Bild

Betrifft: AW: Zahlen untereinander in anderes Sheet schreiben
von: Christian R.
Geschrieben am: 21.10.2015 11:05:16
Funktioniert wunderbar.
Was ist, wenn ich das ganze um zwei Zeilen nach unten verschiebe und der Input ab Zeile 3 beginnt und der Output ab Zeile drei geschrieben werden soll? Komme nicht dahinter...
Vielen, vielen Dank für die schnelle Hilfe!

Bild

Betrifft: AW: Zahlen untereinander in anderes Sheet schreiben
von: SF
Geschrieben am: 21.10.2015 11:08:21
Hola,
dann:

=WENNFEHLER(INDEX(Tabelle1!A$3:A$15;KKLEINSTE(WENN(Tabelle1!A$3:A$15>0;ZEILE($1:$13));ZEILE(A1)));"") 
Gruß,
steve1da

Bild

Betrifft: AW: z.B. mit INDEX() und AGGREGAT() ...
von: ... neopa C
Geschrieben am: 21.10.2015 10:33:43
Hallo Christian,
... ganz ohne Matrixformelklammerung so:
=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(A$1:A$99)/(Tabelle1!A$1:A$99<>0);ZEILE(A1)));"")
und Formel nach rechts und unten ziehend kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit INDEX() und AGGREGAT() ...
von: Luschi
Geschrieben am: 21.10.2015 10:54:10
Hallo Werner,
sicher ist es nach Vorgabe eine richtige Lösung, aber sinnvoll kann das nicht sein.
Was soll diese neue Matrix den nun bringen. Keine der einzelnen Zellen hat irgend eine Beziehung zur neuen Nachbarzelle.
Gruß von Luschi
aus klein-Paris

Bild

Betrifft: AW: die Beziehung ist gegeben, ...
von: ... neopa C
Geschrieben am: 21.10.2015 12:44:50
Hallo Luschi,
... um das zu überprüfen, brauchst Du doch nur die Datenwerte in der Tabelle1 mal zu ändern. Das ist bei meiner Lösung das gleich, wie bei der Lösung mit der Matrixformel oder wenn Du das mit VBA lösen würdest.
Aber möglicherweise verstehe ich ja momentan Deine Feststellung nur nicht. Was meinst Du, wie es Deiner Meinung nach sein sollte.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Zahlen untereinander in anderes Sheet schreiben
von: Daniel
Geschrieben am: 21.10.2015 10:42:05
Hi
Variante a) Festwerte kopieren
1. kopiere alle Zellen in die neue Tabelle
2. ersetze in der neuen Tabelle 0 durch WAHR, setzte in den Optionen das Häkchen bei "gesamten Zellinhalt vergleichen"
3. selektieren alle Zellen und schränke die Selektion auf die Werte mit WAHR ein, klicke hierzu
START - BEARBEITEN - SUCHEN UND AUSWÄHLEN - INHALTE - KONSTANTEN - WAHRHEITSWERTE
4. lösche die selektierten Zellen mit der Option "nach oben verschieben"
Variante b) Formellösung
1. füge folgende Formel in Zelle A1 der Tabelle2 ein.

=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!A$1:A$99<>0;ZEILE(Tabelle1!A$1:A$99)); ZEILE(A1)));"") 

Schließe die Eingabe mit STRG+SHIFT+ENTER ab (matrixformel)
2. ziehe die Formel soweit nach rechts und nach unten wie benötigt
Gruss Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zahlen untereinander in anderes Sheet schreiben"