Microsoft Excel

Herbers Excel/VBA-Archiv

Kleinste

Betrifft: Kleinste von: Harald
Geschrieben am: 11.03.2016 18:55:45

Ich möchte eine Rangliste vollständig auswerten.
Ausgangsbedingungen: es gibt 10 Wettkämpfe im Jahr, davon werden nur die 5 besten Plätze innerhalb der einzelnen Wettkämpfe gewertet. Hieraus ergibt sich wieder eine Punkte Bewertung die in einer Rangliste endet.

Problem:
Es kommt vor, dass eine gleiche Punktzahl erreicht wird, die dann natürlich gleiche Ränge vergibt. Wenn dies zutrifft, werden dann die erreichten Ringzahlen mit hinzugezogen um doch noch eine Differenzierung zu erreichen. Ich habe soweit alles fertig, aber es gelingt mir nicht den passenden Wert (Ringzahl) zu den ermittelten 5 besten Plätzen zu berechnen.

Ich hänge die Tabelle an. Vielleicht kann einer von Euch die Nuss knacken. Es würde mich freuen.

https://www.herber.de/bbs/user/104280.xlsx

  

Betrifft: AW: Kleinste von: ransi
Geschrieben am: 11.03.2016 19:06:37

Hallo,

Versuch mal so:
KK Pistole

 ACAD
382
4103
5124
6125
781
8126
9277
10298

Formeln der Tabelle
ZelleFormel
AC3=WENN(W3<5;"";SUMME(X3:AB3)+SUMME(U3;S3;Q3;O3;M3;K3;I3;G3;E3;C3)%%%%)
AD3=RANG(AC3;$AC$3:$AC$10;1)

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
AD31. / Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Spalte AC einfach als Zahl ohne Nachkommastelle formatieren.

ransi


  

Betrifft: AW: Kleinste von: Harald
Geschrieben am: 11.03.2016 19:21:38

Hallo ransi,

danke, danke und nochmals danke. Aber zu meinem Verständnis, werden in der Formel AC3 die links neben dem Rang stehenden Ringzahlen ermittelt? Können diese dann auch wie in meiner Tabelle rechts einzeln aufgelistet werden, welches mein eigentliches Ziel war.

Das du aber gleich die Rangliste richtig aufgelöst hast, damit konnte ich nicht rechnen.

Harald


  

Betrifft: AW: Kleinste von: Harald
Geschrieben am: 11.03.2016 19:21:39

Hallo ransi,

danke, danke und nochmals danke. Aber zu meinem Verständnis, werden in der Formel AC3 die links neben dem Rang stehenden Ringzahlen ermittelt? Können diese dann auch wie in meiner Tabelle rechts einzeln aufgelistet werden, welches mein eigentliches Ziel war.

Das du aber gleich die Rangliste richtig aufgelöst hast, damit konnte ich nicht rechnen.

Harald


  

Betrifft: Ringe berücksichtigen von: WF
Geschrieben am: 11.03.2016 19:22:11

Hi,

schreib in X3:
=WENN($W3<5;"";KKLEINSTE(($D3:$V3);SPALTE(A1))+KGRÖSSTE($C3:$U3;SPALTE(A1))/10000)
bis AB3 kopieren und X3:AB3 runterkopieren

WF


  

Betrifft: es muss der Kehrwert von KGRÖSSTE sein von: WF
Geschrieben am: 11.03.2016 19:33:48

sonst sind KKLEINSTE und KGRÖSSTE ja gegenläufig
X3 also:
=WENN($W3<5;"";KKLEINSTE(($D3:$V3);SPALTE(A1))+1/KGRÖSSTE($C3:$U3;SPALTE(A1)))

WF


  

Betrifft: AW: Ringe berücksichtigen von: Harald
Geschrieben am: 11.03.2016 19:34:57

Ich meine die Werte AG bis AK. Bei deiner Formel in AC3 werden alle Ringe summiert, es dürfen aber nur die der fünf besten Platzierungen gewertet werden wie in den Spalten AG bis AK. Dort fehlt mir die Idee wie ich es umsetzen kann.

Harald


  

Betrifft: eben nicht von: WF
Geschrieben am: 11.03.2016 19:50:16

Hi,

es werden die 5 kleinsten addiert und da ist sicherlich keine Ringezahl dabei.
und
es werden die 5 größten addiert und da ist sicherlich keine Platzierung dabei.

in C3 steht dann:
8,055514234

die Vorkommazahl ist die Summe der Platzierungen und der Kehrwert der Nachkommazahlen
=5*1/REST(AC3;1)
der Durchschnitt der 5 besten Ringzahlen

WF


 

Beiträge aus den Excel-Beispielen zum Thema "Kleinste"