Microsoft Excel

Herbers Excel/VBA-Archiv

Baujahre splitten


Betrifft: Baujahre splitten von: David
Geschrieben am: 16.08.2018 10:21:15

Hallo zusammen,

ich bräuchte mal eure Hilfe, da ich absolut nicht mehr weiter komme :/

Ich habe folgenden Baujahre in den Zellen untereinander stehen:
zB.:
87-92
98-07
02-13

Ich bräuchte die Baujahre allerdings horizontal ausgeschrieben, also so:

87-92 1987 1988 1989 1990 1991 1992
98-07 1998 1999 2000 2001 2002 2003 2004 2005 2006 2007
02-18 2002 2003 2004 2005 2006 2007 2008 2009 2010 2011 2012 2013

Kann mir dort vielleicht einer Helfen wie ich das am geschicktesten löse?
LG
David

  

Betrifft: AW: Baujahre splitten von: Hajo_Zi
Geschrieben am: 16.08.2018 10:24:43

Hallo David,

die Frage die sich mir stellen würde, ab wann ist es 2000?

GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.


  

Betrifft: AW: Baujahre splitten von: David
Geschrieben am: 16.08.2018 10:34:18

Hi Hajo,

vielleicht ist es möglich das ganze irgendwie mit der Autovervollständigung von Excel zu lösen?

Meine Überlegung ist, dass man das irgendwie mit der Autovervollständigung lösen könnte.
Zunächst splittet man die Werte bei dem "Minus -" in zwei Spalten, dann hat man in der ersten Spalte den Anfangswert und dahinter den Endwert.

Werte aus den 70er 80er und 90er bekommen immer eine 19 vorrangestellt sowie Werte aus den 00er 10er bekommen immer eine 20 vorran gestellt.

Dazwischen soll dann vervollständigt werden. Aber wie genau ich Excel sage, dass es Anfang und Ende gibt, weiß ich nicht. :/

LG
David


  

Betrifft: AW: Baujahre splitten von: Hajo_Zi
Geschrieben am: 16.08.2018 10:44:53

Hallo David,


Tabelle2

 ABCDEFGHIJKLMN
2687-92198719881989199019911992       
2798-071998199920002001200220032004200520062007   
2802-13200220032004200520062007200820092010201120122013 

verwendete Formeln
Zelle Formel Bereich N/A
B26:B28=LINKS(A26;2)+1900+WENN(LINKS(A26;2)+1<70;100;0)  
C26:N28=WENN(B26="";"";WENN(B26+1<=RECHTS($A26;2)+1900+WENN(RECHTS($A26;2)+1<70;100;0);B26+1;""))  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Baujahre splitten von: Daniel
Geschrieben am: 16.08.2018 10:39:16

Hi

In Spalte B die Formel

=Wenn(Teil(A1;4;1)<"5";2000;1900)+rechts(A1;2)
In die Spalte C die Formel:
=Wenn(links(A1;1)<"5";2000;1900)+links(A1;2)
Ab Spalte D die Formel:
=Wenn(oder(C1="";C1=$B1);"";C1+1)
Die Formel in Spalte D ziehst du so weit nach rechts wie benötigt.
Die Daten stehen ab Spalte C.
Spalte B ist eine Hilfsspalte, damit die Formeln ab D nicht so komplex werden.

Gruß Daniel


  

Betrifft: AW: Baujahre splitten von: David
Geschrieben am: 16.08.2018 11:13:41

Danke euch beiden, hat super geklappt! :)


Beiträge aus dem Excel-Forum zum Thema "Baujahre splitten"