Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT


Betrifft: SUMMENPRODUKT von: erichm
Geschrieben am: 17.01.2019 09:45:17

Hallo,

ich habe folgende Formel für eine Auswertung, die nach rechts kopiert wird:
=SUMMENPRODUKT(N(ZÄHLENWENN($D2:$L2;AppFin!$C$2:$C$200)*AppFin!BF$2:BF$200=1))

In den Spalten ab AppFin!BF, ..BG, ..BH usw. befinden sich grundsätzlich immer Zahlen (0 bis 20). Es gibt ein paar Ausnahmen da steht dort statt einer Zahl ein JA.
In den Spalten mit JA erhalte ich als Ergebnis #WERT!, in allen anderen Spalten funktioniert die Formel tadellos.

Kann man die Formel ändern, dass bei JA keine Fehlermeldung sondern der richtige Wert erscheint?

Vielen Dank für eine Hilfe.

mfg

  

Betrifft: statt SUMMENPRODUKT nimm SUMME(WENN von: WF
Geschrieben am: 17.01.2019 10:05:49

Hi,

bei einer Multiplkation mit Text wird gemeckert.

Nachbauen tu ich das nicht - also Beispieltabelle.
WF


  

Betrifft: AW: SUMMENPRODUKT von: Luschi
Geschrieben am: 17.01.2019 10:17:47

Hallo Erich,

Du hast die N()-Funktion an die falsche Stelle gesetzt:
=SUMMENPRODUKT(ZÄHLENWENN($D2:$L2;AppFin!$C$2:$C$200)*N(AppFin!BF$2:BF$200=1))

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: SUMMENPRODUKT von: Daniel
Geschrieben am: 17.01.2019 10:25:39

Hi Luschi

an der stelle ist das N aber nicht notwendig, es reicht die Klammer.
das WAHR/FALSCH als Ergebnis der Klammer wird automatisch in 1 und 0 gewandelt.
das N() bräuchte man eigentlich nur, wenn die Werte aus dieser Spalte zuerst mit dem ZählenWenn-Ergebnis multipliziert werden und dann der Vergleich =1 mit dem Ergebnis dieser Multiplikation durchgeführt werden soll.

Gruß Daniel


  

Betrifft: AW: SUMMENPRODUKT von: Luschi
Geschrieben am: 17.01.2019 10:30:27

Hallo Daniel,

das hatte ich eigentlich auch gedacht, aber die Praxis (Testdatei erstellt, obwohl es gegen mein Prinzip verstößt!) und BUMMS... war der Fehler #WERT! da.

Gruß von Luschi
aus klein-Paris


  

Betrifft: Wenn du es getestet hast von: Daniel
Geschrieben am: 17.01.2019 11:43:48

dann wird's wohl auch so sein.
Gruß Daniel


  

Betrifft: AW: SUMMENPRODUKT von: Daniel
Geschrieben am: 17.01.2019 10:21:07

Hi

da ich nicht weiß, was du berechnen willst, würde ich mal vorschlagen:

N(AppFin!BF$2:BF$200)

mit der N-Funktion werden Texte in die Zahl 0 gewandelt und damit bekommst du dann in der Berechnung keinen Fehler mehr.

Gruß Daniel


  

Betrifft: DANKE Daniel, genau das wars - mfg o.w.T. von: erichm
Geschrieben am: 17.01.2019 10:56:27

.....


  

Betrifft: AW: DANKE Daniel, genau das wars - mfg o.w.T. von: Luschi
Geschrieben am: 17.01.2019 11:34:35

Hallo Erich,

schade, daß Du Dir nicht auch meine Lösung anschaust; ich bin mir sicher, jetzt hast Du 2 N()-Funktionen drin, wovon natürlich 1e überflüssig ist!

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: DANKE Daniel, genau das wars - mfg o.w.T. von: erichm
Geschrieben am: 17.01.2019 12:02:20

Hallo Luschi,

sorry dass ich nicht geantwortet hatte. Habe mit 1 x N umgesetzt - also auch genau so wie Du vorgeschlagen hast.

DANKE.

mfg


  

Betrifft: AW: es ist kein N() erforderlich, sondern ... von: neopa C
Geschrieben am: 17.01.2019 15:54:01

Hallo Erich,

... Deine Formel hat lediglich eine falsche Klammersetzung.

Folgende Formel sollte Dir auch ganz ohne N() keine Probleme bereiten:

=SUMMENPRODUKT((ZÄHLENWENN($D2:$L2;AppFin!$C$2:$C$200)*(AppFin!BF$2:BF$200=1))

Gruß Werner
.. , - ...


  

Betrifft: AW: noch eine Klammer zuviel ... von: neopa C
Geschrieben am: 17.01.2019 17:12:26

Hallo noch einmal,

... richtig ist so:

=SUMMENPRODUKT(ZÄHLENWENN($D2:$L2;AppFin!$C$2:$C$200)*(AppFin!BF$2:BF$200=1))


Gruß Werner
.. , - ...


  

Betrifft: DANKE - o.w.T. von: erichm
Geschrieben am: 17.01.2019 18:34:08

....