Microsoft Excel

Herbers Excel/VBA-Archiv

Summewennformel

Betrifft: Summewennformel von: Excelkub
Geschrieben am: 03.02.2020 17:56:28

Hallo miteinander,


ich suche eine Summewenn/Summewennsformel, die ihre Bezüge nur aus einer Spalte nimmt.


Ich hätte folgendes Beispiel:


Spalte A B C

Äpfel Birnen Bananen

10 4 4

Birnen Birnen Bananen

3 6 9

Äpfel Äpfel Bananen

34 1 7

Bananen Äpfel Birnen

12 7 2

Äpfel Birnen Birnen

13 3 1

Bananen Äpfel Äpfel

1 8 4

Birnen Bananen Birnen

5 5 1



Summe Äpfel

Summe Birnen

Summe Bananen

Die Darstellung ist etwas verrutscht. Es soll in der Spalte A 10 Äpfel, 4 Birnen und 4 Bananen usw. heißen.

Ich bräuchte eine Formel, die mir für Spalte A,B und C die Summe der Äpfel, Birnen und Bananen ausgibt. Ich habe schon an einer Summewenn und Summewennsformel gebastelt, komme aber leider nicht weiter.


Vielen dank schonmal für eure Hilfe.

Betrifft: AW: Summewennformel
von: Hajo_Zi
Geschrieben am: 03.02.2020 17:57:51

Die meisten bauen Deine Datei nicht nach. Die Zeit hat schon jemand investiert.

Ein Nachbau sieht meist anders aus als das Original. Darum sollte das Original verlinkt werden.
Die meisten möchten es am Original testen um den gleichen Fehler zu erhalten.

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
http://www.ms-office-forum.de/forum/showthread.php?t=322895
änderrn.

Das ist nur meine Meinung zu dem Thema.

Benutze hier im Forum die Funktion zum hochladen. Falls Du die nicht benutzen möchtest beachte, von unsicheren Servern wie z.B. www.file-upload.net lade ich keine Datei runter. (lt. Einschätzung meines Virenprogramms)

GrußformelHomepage

Betrifft: AW: Summewennformel
von: Excelkub
Geschrieben am: 03.02.2020 18:01:47

Ich kann von meinem MacBook die Datei nicht hochladen

Betrifft: AW: mit SUMMENPRODUKT() ...
von: neopa C
Geschrieben am: 03.02.2020 18:05:35

Hallo,,

... Formel E2 nach rechts kopieren:

Arbeitsblatt mit dem Namen 'Tabelle4'
 ABCDEFG
1ÄpfelBirnenBananen ÄpfelBirnenBananen
21044 772538
3BirnenBirnenBananen    
4369    
5ÄpfelÄpfelBananen    
63417    
7BananenÄpfelBirnen    
81272    
9ÄpfelBirnenBirnen    
101331    
11BananenÄpfelÄpfel    
12184    
13BirnenBananenBirnen    
14551    
15       

ZelleFormel
E2=SUMMENPRODUKT(($A1:$C98=E1)+0;$A2:$C99)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...

Betrifft: AW: mit SUMMENPRODUKT() ...
von: Excelkub
Geschrieben am: 03.02.2020 18:15:24

Danke für den Vorschlag,

aber ich will für jede Spalte eine Summe.
Also die Summe der Äpfel, Birnen und Bananen in Spalte A,B und C

Betrifft: AW: dann reicht SUMMEWENN() ...
von: neopa C
Geschrieben am: 03.02.2020 18:20:10

Hallo,

... z.B. für Spalte A in E2: =SUMMEWENN($A$1:$A98;E1;$A2:$A99) und nach rechts kopieren.

und analog für die anderen beiden Spalten.

Gruß Werner
.. , - ...

Betrifft: AW: dann reicht SUMMEWENN() ...
von: Excelkub
Geschrieben am: 03.02.2020 19:11:02

Danke nochmal für die Antwort.

Habe diese Formel schon selber ausprobiert. da kommt leider immer null raus.

Betrifft: AW: dann sieh mal ...
von: neopa C
Geschrieben am: 03.02.2020 19:16:00

Hallo,

... Formeln nach rechts kopieren:

Arbeitsblatt mit dem Namen 'MFF_200203_5'
 ABCDEFG
1ÄpfelBirnenBananen ÄpfelBirnenBananen
21044Spalte A57813
3BirnenBirnenBananenSpalte B16135
4369Spalte C4420
5ÄpfelÄpfelBananen    
63417    
7BananenÄpfelBirnen    
81272    
9ÄpfelBirnenBirnen    
101331    
11BananenÄpfelÄpfel    
12184    
13BirnenBananenBirnen    
14551    
15       

ZelleFormel
E2=SUMMEWENN($A$1:$A98;E1;$A2:$A99)
E3=SUMMEWENN($B$1:$B98;E1;$B2:$B99)
E4=SUMMEWENN($C$1:$C98;E1;$C2:$C99)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...

Betrifft: AW: dann reicht SUMMEWENN() ...
von: Excelkub
Geschrieben am: 03.02.2020 19:15:03

Vielen Dank nochmal für die Antwort.

Diese Funktion habe ich auch gefunden. Es kommt aber nur der Wert 0 raus.

Betrifft: AW: hast den Bereichsversatz nicht beachtet! owT
von: neopa C
Geschrieben am: 03.02.2020 19:19:46

Gruß Werner
.. , - ...

Betrifft: dann sind Deine "Zahlen" keine Zahlen
von: WF
Geschrieben am: 03.02.2020 22:05:56

{=SUMME(WENN($A$1:$A98=E1;$A2:$A99*1))}

WF

Betrifft: AW: da würde Deine Formel Fehlermeld. ergeben ...
von: neopa C
Geschrieben am: 04.02.2020 09:32:50

Hallo WF

... also da ein #WERT!, während meine SUMMEWENN()-Formel wenigstens die echten noch vorhandenen Zahlenwerte addiert. Wozu also eine {}-Formel.

Gruß Werner
.. , - ...

Betrifft: Ich sagte "Zahlen"
von: WF
Geschrieben am: 04.02.2020 10:05:22

also optisch schon Zahlen aber nicht tatsächlich.
Schreib mal '3
Bei SUMMEWENN wird diese ausgelassen - bei mir nicht.

WF

Betrifft: AW: derartige "Zahlen" werden in SUMMEWENN() ...
von: neopa C
Geschrieben am: 04.02.2020 10:33:40

Hallo WF,

... mE zu Recht nicht als echte Zahlen gewertet.

Eine "saubere" Datengrundlage sollte schon stets tvorliegen. Wenn derartige "Zahlen" wirklich beim TE vorliegen sollten und deswegen bei ihm das Ergebnis 0 sein sollte, rate ich dem TE dazu die "Zahlen" in echte Zahlenwerte zu wandeln. Dazu müsste er nur zuvor lediglich die 3 Spalten (nacheinander) mit der Funktion Text in Spalten "behandeln".

Gruß Werner
.. , - ...

Betrifft: mit WECHSELN
von: WF
Geschrieben am: 03.02.2020 18:25:12

Hi,

ich hatte Dich so verstanden, dass 10 Äpfel usw. in einer einzigen Zelle stehen.

folgende Arrayformel:
{=SUMME(WENN(NICHT(ISTFEHLER(WECHSELN(A1:C99;"Äpfel";)*1));WECHSELN(A1:C99;"Äpfel";)*1))}

WF

Betrifft: AW: mit WECHSELN
von: Excelkub
Geschrieben am: 03.02.2020 19:13:32

Hallo und Danke für die Antwort,

es ist leider echt schwierig, keine Bilder oder Dokumente hochzuladen.
Ich versuche es nochmal vereinfacht darzustellen.

Ich habe in einer Spalte folgende Werte und möchte die Summe der Äpfel, Birnen und Bananen aus der Spalte errechnen

Äpfel
10
Birnen
3
Äpfel
34
Bananen
12
Äpfel
13
Bananen
1
Birnen
5