Microsoft Excel

Herbers Excel/VBA-Archiv

Berechnungen

Betrifft: Berechnungen von: xtian
Geschrieben am: 17.09.2020 10:02:24

Guten Morgen zusammen,
hat eventuell von euch jemand eine Lösung (gerne VBA ansonsten Formel) für mein Problem? Ich stehe total
auf dem Schlauch und komme nicht weiter.

Befindet sich in Spalte A der Buchstabe K soll in der Spalte C das Ergebnis eingetragen werden. Es soll also
zuerst in Spalte A der Buchstabe K gesucht werden und dann mit den oberen U Werten mal genommen
werden.

SpalteA...SpalteB...SpalteC
….U...…….0,2
….U...…….1
….K...…….0,75...….0,15 (Berechnung Zelle C3= B1(0,2)*B2(1)*B3(0,75))
….U...…….1
….K...…….1...……….1 (Berechnung Zelle C5= (B4(1)*B5(1))
….K...…….1...……….1 (Berechnung Zelle C6= (B4(1)*B6(1))
….U...…….0,04
….K...…….1...……...0,04 (Berechnung Zelle C8= (B7*B8))

Vielen Dank und viele Grüße
Christian

Betrifft: AW: Berechnungen
von: Yal
Geschrieben am: 17.09.2020 10:18:01

Hallo xtian,

vermeide ein erneute Thread für ein bereit gestellte Frage zu öffnen oder verlinke zu dem Ursprünglichen:
https://www.herber.de/forum/messages/1782454.html

Darüber hinaus sollte man das Kastchen "Frage noch nicht beantwortet" aktivieren.

Ich habe einen Nachtrag zu deiner Frage für "Me" eingestellt. Siehe https://www.herber.de/forum/messages/1782547.html

VG Yal

Betrifft: nicht ganz korrekt, Yal
von: Matthias L
Geschrieben am: 17.09.2020 10:48:08

Hi,

Zitat:
Darüber hinaus sollte man das Kastchen "Frage noch nicht beantwortet" aktivieren.

Da liegst Du falsch.
Wenn man einen Beitrag neu einstellt ist Dieser automatisch offen.

Gruß Matthias

Betrifft: AW: nicht ganz korrekt, Yal
von: Yal
Geschrieben am: 17.09.2020 11:26:58

Ich meinte -sorry für meine Ungenauigkeit-, wenn ein Fragesteller eine Stellungnahme auf einer Antwort gibt, sollte er diese Kastchen anhacken, wenn -seiner Meinung nach- die Frage nocht nicht beantwortet ist.
Somit wird sichtbar, dass trotz Thread ein User noch Hilfe braucht.

VG Yal

Betrifft: AW: Berechnungen
von: xtian
Geschrieben am: 17.09.2020 11:02:02

Hallo Yal,
hatte deine Info zu .Me leider nicht gesehen. Werde das gleich einmal ausprobieren.
Vielen Dank dafür. Habe gedacht, dass eventuell mein Problem nicht richtig verstanden
wurde und es deswegen nochmal neu formuliert.

Gruß
Christian

Betrifft: AW: Berechnungen
von: Rudi Maintaire
Geschrieben am: 17.09.2020 10:30:49

siehe meine Lösung von gestern

Betrifft: aufeinanderfolgende Produkte
von: WF
Geschrieben am: 17.09.2020 10:48:04

Hi,

in C1 steht:
=WENN(A1="k";B1;"")

in C2 steht:
=WENN(A2="k";PRODUKT(B$1:B2)/WENN(PRODUKT(C$1:C1)=0;1;PRODUKT(C$1:C1));"")
runterkopieren

WF

Betrifft: AW: aufeinanderfolgende Produkte
von: xtian
Geschrieben am: 17.09.2020 11:12:29

Hallo WF,
das scheint erstmal sehr gut zu funktionieren. Vielen Dank für deine Hilfe.
Teste gleich noch weitere Varianten.

Gruß
Christian

Beiträge aus dem Excel-Forum zum Thema "Berechnungen"