Microsoft Excel

Herbers Excel/VBA-Archiv

Liste Kindergartengruppe

Betrifft: Liste Kindergartengruppe von: C H
Geschrieben am: 31.10.2020 07:01:54

Hallo,


ich möchte für meine Kindergartengruppe eine Gruppenliste erstellen. Da sich allerdings fast monatlich etwas darin ändert (ein neues Kind kommt dazu; im Sommer gehen Vorschulkinder), wollte ich hier um Hilfe bitten.

Die Excel-Datei, in der ich alle Daten der Kinder stark verändert habe, ist unter diesem Link zu finden:

https://www.herber.de/bbs/user/141199.xlsx


Ich möchte also monatlich eine aktuelle Liste erstellen (lassen, mit Hilfe von Excel). Dazu müssten die Daten von "Tabelle1" in die einzelnen Monatstabellen kopiert/synchronisiert/was auch immer ... werden. Dabei hätte ich gern, dass in "Tabelle 1" die Kinder nach "Eintritt" geordnet werden und in den Monatstabelle nach "Austritt / Schulanfang" und wenn der "Austrittstermin" verstrichen ist, z. B. Austritt 31.07.2021, dass das Kind in der Tabelle "8-2021" nicht mehr erscheint. Genauso wäre es schön, wenn Kinder aus der "Tabelle1" in den Monatstabellen erst erscheinen, wenn der "Eintrittstermin" da ist.


Ich hoffe, dass ich an alles gedacht habe und vielleicht kann mir jemand behilflich sein :)

Danke im Voraus!


C H

Betrifft: AW: Liste Kindergartengruppe
von: C H
Geschrieben am: 31.10.2020 07:16:49

... eine Sache habe ich doch noch vergessen: Es dürfen maximal 16 Kinder gleichzeitig angemeldet sein. (Wenn man die 16 vielleicht monatlich ändern kann, wäre das auch gut, aber momentan noch nicht notwendig)

Danke!

Betrifft: AW: Liste Kindergartengruppe
von: C H
Geschrieben am: 01.11.2020 19:50:11

Hallo,

ich muss mich doch nochmal melden. Heute habe ich bei einem Kind (in der Datei Günther Bauer genannt) den Austrittstermin verändert auf den gestrigen Tag, also 31.10.2020. Leider erscheint er aber trotzdem noch im Monat November. Ich muss dazusagen, ich habe die Tabelle um weitere Angaben ergänzt und vergrößert und mit meinem einigermaßen guten Sachverstand die Formel verändert, sodass er alle Daten in die Monate überträgt.
In der ersten Beispieldatei hat er das alles brav gemacht.
Ich versteh leider aber nicht alles in dieser tollen Formel, sodass es gut möglich ist, einen Fehler gemacht zu haben.

Ich wäre dankbar, wenn du oder jemand anderes noch einmal drüber schauen könnte:
https://www.herber.de/bbs/user/141237.xlsx

Vielen Dank und einen schönen Abend,

C H

Betrifft: AW: wäre mit nur einer Formel möglich ...
von: neopa C
Geschrieben am: 31.10.2020 09:13:42

Hallo C H,

... in B4 folgende Formel:

=WENNFEHLER(INDEX(Tabelle1!B:B;AGGREGAT(15;6;ZEILE(Tabelle1!B$2:B$999)/(Tabelle1!$E$2:$E$999<=($B$1&"-"&$C$1)+0)/(Tabelle1!$F$2:$F$999>=($B$1&"-"&$C$1)+0);ZEILE(A1)));"")

und diese nach rechts und weit genug unten ziehend kopieren.

Anstelle Deiner fest vorgegebenen Zählnummer in Spalte A, könntest Du in A4 auch folgende Formel: =WENN(B4="";""; ANZAHL(E$4:E4)) einschreiben und diese weit genug nach unten kopieren.


Gruß Werner
.. , - ...

Betrifft: AW: wäre mit nur einer Formel möglich ...
von: C H
Geschrieben am: 31.10.2020 14:12:57

Vielen Dank! Das geht wunderbar!

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 31.10.2020 20:21:48

Gruß Werner
.. , - ...

Betrifft: AW: bitteschön owT
von: C H
Geschrieben am: 02.11.2020 16:17:11

Hallo,

ich muss mich doch nochmal melden. Heute habe ich bei einem Kind (in der Datei Günther Bauer genannt) den Austrittstermin verändert auf den gestrigen Tag, also 31.10.2020. Leider erscheint er aber trotzdem noch im Monat November. Ich muss dazusagen, ich habe die Tabelle um weitere Angaben ergänzt und vergrößert und mit meinem einigermaßen guten Sachverstand die Formel verändert, sodass er alle Daten in die Monate überträgt.
In der ersten Beispieldatei hat er das alles brav gemacht.
Ich versteh leider aber nicht alles in dieser tollen Formel, sodass es gut möglich ist, einen Fehler gemacht zu haben.

Ich wäre dankbar, wenn du oder jemand anderes noch einmal drüber schauen könnte:
https://www.herber.de/bbs/user/141237.xlsx

Vielen Dank und einen schönen Abend,

C H

Betrifft: AW: dem ist so ...
von: neopa C
Geschrieben am: 02.11.2020 17:13:06

Hallo C H,

... in der Formel hast Du ... /(Tabelle1!$M$2:$M$999>=($F$1&"-"&$F$2)+0);ZEILE(...

zu stehen. Aber anstelle mit Daten der Spalte M muss natürlich mit Daten der Spalte F verglichen werden, also: ... /(Tabelle1!$F$2:$F$999>=($F$1&"-"&$F$2)+0);ZEILE(...

Dies gilt natürlich für alle Formeln. Kannst Du mit SUCHEN und ERSETZEN korrigieren.

Aber auch danach würde der Günther noch gelistet, denn Du hast ja hier nur das Tabellenblatt für August eingestellt. Im Novemberblatt wäre er dann nicht mehr gelistet.

Gruß Werner
.. , - ...