Microsoft Excel

Herbers Excel/VBA-Archiv

Fehler #DIV/0!

Betrifft: Fehler #DIV/0! von: Patrik Achermann
Geschrieben am: 02.11.2020 20:41:59

Hallo Miteinander

Ich habe eine Tabelle mit diversen Formeln und Berechnungen.

In der Zellen F8 - F38 steht folgende Formel:
=WENN(A5="LOSE";ABRUNDEN(B$5/B12;0);WENNFEHLER(WENN(I8="KartonBox 1";ABRUNDEN(B$3/B12;0); ABRUNDEN(B$4/B12;0));""))

Die Formel funktioniert einwandfrei. Leider ist ein Schönheitsfehler vorhanden.
Wenn in der Zelle A5 "LOSE" eingegeben wird und die Zeilen keinen Wert haben, kommt in der Spalte F der Fehler #DIV/0!.

Wie bringe ich diesen Fehler weg?

Gruss, Patrik

Betrifft: AW: Fehler #DIV/0!
von: Hajo_Zi
Geschrieben am: 02.11.2020 20:50:37

Halo Patrik,

=Wenn(Istfehler(DeineFormel);"";DeineFormel)

GrußformelHomepage

Betrifft: AW: Fehler #DIV/0!
von: Patrik Achermann
Geschrieben am: 02.11.2020 21:37:10

Hallo

recht herzlichen Dank

Gruss, Patrik

Betrifft: AW: Fehler #DIV/0!
von: Tino
Geschrieben am: 02.11.2020 20:51:11

Hallo,
schau dir mal die Funktion =WennFehler() an.

Gruß Tino

Betrifft: AW: Fehler #DIV/0!
von: Patrik Achermann
Geschrieben am: 02.11.2020 21:38:18

Hallo

Danke für den Tip

Gruss

Betrifft: AW: Fehler #DIV/0!
von: Daniel
Geschrieben am: 02.11.2020 20:57:11

hi
naja, den DIV/0-Fehler kann ja wohl nur eine 0 in B12 erzeugen.
also reicht die zusätzliche Abfrage: Wenn(B12<>0;Berechnung;Fehlerwert)
da sollte man aber eigentlich selber drauf kommen können, wenn man solche Formeln schreibt.
Gruß Daniel

Betrifft: AW: Fehler #DIV/0!
von: Patrik Achermann
Geschrieben am: 02.11.2020 21:39:38

Hallo

vielen Dank

Gruss, Patrik

Beiträge aus dem Excel-Forum zum Thema "Fehler #DIV/0!"