Microsoft Excel

Herbers Excel/VBA-Archiv

tabellenvergleich

    Betrifft: tabellenvergleich von: kwon
    Geschrieben am: 29.08.2003 10:37:54

    hi,

    ich habe folgendes problem:

    TABELLE 1:
    AB (spalten)
    1a
    3b
    4c
    5d
    6r
    7f

    TABELLE2:
    ABCD (spalten)
    1XVG
    4Y
    9Z
    8A

    ich würde gerne den ersten wert in spalte-A von der tabelle-1 in der spalte A von der tabelle 2 suchen. wenn diese vorhanden ist, soll der inhalt von den restlichen spalten in der tabelle 1 hinzugefügt werden:
    tabelle 1
    ABCDE
    1aXVG

    wenn der wert nicht vorhanden ist, soll der nächste wert von der tabelle-1 verglichen werden.

    kann mir da bitte jemand helfen.
    DANKE!!!!!!

      


    Betrifft: AW: tabellenvergleich von: sergiesam
    Geschrieben am: 29.08.2003 10:44:42

    Hi,

    sollen die werte in tabelle 1 ersetzt werden (nur mit Makro möglich) oder kann auch eine 2. Spalte in der 1. Tabelle den entsprechenden wert aus Tabelle2 anzeigen (SVerweis)

    Sam


      


    Betrifft: AW: tabellenvergleich von: kwon
    Geschrieben am: 29.08.2003 10:51:38

    es könnte auch eine 2 spalte den wert anzeigen.
    geht das dann ohne makro?


      


    Betrifft: AW: tabellenvergleich von: sergiesam
    Geschrieben am: 29.08.2003 11:14:11

    Hi,

    hier ein beispiel:
    https://www.herber.de/bbs/user/778.xls

    Um das Beispiel auf deine Mappe zu übertragen, brauchst du nur die formel von Tabelle 1 in Zelle C1 kopieren.

    =WENN(ISTFEHLER(SVERWEIS($A1;Tabelle2!$A$1:$D$4;ZELLE("spalte";C1)-1;FALSCH));"";WENN(SVERWEIS($A1;Tabelle2!$A$1:$D$4;ZELLE("Spalte";C1)-1;FALSCH)=0;"";SVERWEIS($A1;Tabelle2!$A$1:$D$4;ZELLE("Spalte";C1)-1;FALSCH)))

    Sieht kompliziert aus, ist es aber nicht:

    Sverweis sucht in der 1. Spalte der 2. Tabelle deinen Wert.
    Wenn nicht gefunden (=WENN(ISTFEHLER(...);"";Sverweis(...))
    dann soll nichts (alse "") eingetragen werden.

    SVERWEIS($A1;Tabelle2!$A$1:$D$4;ZELLE("Spalte";C1)-1;FALSCH bedeutet:
    $A1 ... suche diesen Wert
    Tabelle2!$a$1:$D$4 ... in dieser Tabelle
    Zelle("Spalte";c1)-1 ... wenn der wert gefunden wird, liefere die 2. Spalte >> statt Zelle("Spalte";c1)-2 kannst du auch in jeder Spalte den entsprechenden Wert 2,3,4... eintragen - so ist es etwas eleganter ;-)
    FALSCH ... wenn nicht gefunden, liefere Fehler (keine Bereichsuche)

    Sollte nichts in der Spalte der 2. Tabelle stehen (Wenn(Sverweis(...)=0;"";Sverweis(...)) dann schreibe nicht 0 rein, sondern "".

    Ich hoffe, es ist einigermaßen verständlich.
    Sam


      


    Betrifft: AW: tabellenvergleich von: kwon
    Geschrieben am: 29.08.2003 11:37:48

    super
    DANKEEEEEE!!!!!

    ist genau das was ich gebraucht habe. danke auch für deine erklärung, habe nicht gewußt, dass das ohne komplizierten makro lösbar ist.


     

    Beiträge aus den Excel-Beispielen zum Thema " tabellenvergleich"