Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis nochmal

    Betrifft: sverweis nochmal von: Jochen
    Geschrieben am: 02.09.2003 08:30:14

    0-8m Profilgr.
    1530 1
    1745 2
    1820 3
    1930 4
    2600 5
    hallo ,
    leider ist mir mit der Antwort nicht geholfen trotzdem vielen Dank. Oben nochmnal einen Tabelle die ich mit Sverweis duchsuchen möchte. Das Suchkriterium ist 1630 was Profilgruppe 2 entsprechen würde. Sollte das Suchkriterium 1760 betragen müsste der Wert 3 sein. Das zweite Problem ist. das die Werte in der Spalte 0-8m nicht immer gleich sind. ich als die Tabelle jeweils nach dem nächst größeren Wert durchsuchen möchte. Ich hoffe diese erkllärung verdeutlicht meine Problematik etwas besser als die erste. Vielen Dank für die Hilfe.

      


    Betrifft: AW: sverweis nochmal von: Harald Kapp
    Geschrieben am: 02.09.2003 08:39:49

    Hallo Jochen,
    da Du auf das nächstgrößere Element (bei 1760 -> 1820) referenzieren willst, geht Svwerweis nicht. Aber so:

    =INDEX(A1:B5;VERGLEICH(1760;A1:A5;1)+1;2)

    Vorausssetzung: Spalte A ist aufsteigend sortiert.

    Gruß Harald


      


    Betrifft: AW: sverweis nochmal von: Jochen
    Geschrieben am: 02.09.2003 09:03:40

    Danke für die Hilfe, ich hoffe jetzt bekomme ich es hin


      


    Betrifft: AW: sverweis nochmal von: jochen
    Geschrieben am: 02.09.2003 09:05:19

    Danke für die Tipps


      


    Betrifft: AW: sverweis nochmal von: Christian Baum
    Geschrieben am: 02.09.2003 08:40:55

    Hallo!
    Ich kann dir leider keine vorgekaute Lösung für dein problem liefern, da ich genau diesen Fall noich nicht ausprobiert habe. Aber die Funktion "Verweis" kommt mir in Excel immer sehr spanisch vor. Deshalb neige ich dazu eine Kombi aus den Funktionen "Index" und "Vergleich" zu bvenutzen.
    =INDEX(Suchmatrix;VERGLEICH(Vergleichskriterium; Suchmatrix; vergleichsart); Rückgabespalte))

    Wenn du dir den Syntax der Funktionen in der Excelhilfe anschaust, wirst du sehen, wie es funktioniert. ;) Wichtig für dein Problem ist die Vegleichsart. Hier wird entschieden, was für ein Wert zurückgegeben wird.

    Hoffe ich konnte helfen.
    Gruß
    Chris


      


    Betrifft: AW: sverweis nochmal von: Marcus Rose
    Geschrieben am: 02.09.2003 08:54:49

    Hallo Jochen,

    ich habe Dir gestern schon einmal beim SVERWEIS eine solche Tabelle geschickt. Bau Dir die Tabelle übersichtlich auf, damit Du genau sehen kannst wo die Werte liegen; Schau mal:

    Tabelle1
     ABCDE
    4015301  
    515311745217452
    6174618203  
    7182119304  
    8193126005  
    Formeln der Tabelle
    E5 : =SVERWEIS(D5;A4:C8;3;1)
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Wenn Du diesesmal das Beispiel auch genauso abschreibst, sollte Dein Problem gelöst sein.
    Gruß Marcus

    Die neue Excel-Homepage für Anfänger

     

    Beiträge aus den Excel-Beispielen zum Thema " sverweis nochmal"