Microsoft Excel

Herbers Excel/VBA-Archiv

Leichte Aufgabe für Profis...

    Betrifft: Leichte Aufgabe für Profis... von: Thomas
    Geschrieben am: 05.10.2003 02:04:50

    Moin Moin!

    Ich habe eine leichte Aufgabe für Profis, die mich als (Excel)-Laien leider etwas überfordert:
    Ich habe eine Tabelle mit Teilnehmern einer Sportveranstaltung1
    Spalte A = Startnummer
    Spalte B = Name
    Spalte C = Vorname etc...

    In einer zweiten Tabelle (im gleichen Dokument) stehen in Spalte A die Startnummern der Teilnehmer in der Reihenfolge, wie sie ins Ziel gekommen sind, z.B.
    56
    23
    44 etc...

    Jetzt brauche ich eine Formel, die automatisch jeweils in Spalte B den Namen des Teilnehmers, in Spalte C den Vornamen usw. schreibt.
    Die Formel muß also den Wert der Spalte A auslesen (z.B. "56") und dann aus der Tabelle mit den Teilnehmerdaten aus Zeile 56 die Daten für Name, Vorname etc. nehmen.

    Ist das mit einer einfachen Formel machbar?

    Danke im Voraus!

    Thomas H. aus O.

      


    Betrifft: AW: Leichte Aufgabe für Profis... von: Henning D
    Geschrieben am: 05.10.2003 02:19:43

    Hallo Thomas,
    ist mit der Sverweis Formel kein Problem!

    In der Zelle, in der Du das Ergebnis brauchst, musst Du folgende Formel eintragen:
    =SVerweis(Suchkriterium;Matrix;Spaltenindex)
    Dabei sind dies deine "Variablen"
    Suchkriterium ist deine Startnummer in der 2ten Tabelle. Also einfach die Zelle angeben, in welche die Startnummer steht
    Matrix ist deine Tabelle 1 von A1 bis zum letzten Teilnehmer, letzte Spalte mit Eintrag. Nehmen wir an, der letzte Teilnehmer steht in Zeile 105, dann bis ist die Matrix A1:C105
    Spaltenindex gibt nun an, welche Spalte du zurückgeben möchtest. möchtest Du also in deiner Tabelle den Namen zurückgeben ist es 2, beim vornamen 3, ...

    Hoffe ich konnte dir helfen!

    Gruß,
    Henning


      


    Betrifft: Sverweis (Istfehler(SVERWEIS)) von: Marcus Rose
    Geschrieben am: 05.10.2003 09:19:14

    Hallo Thomas,

    wie mein Vorschreiber schon schrieb, ist der SVERWEIS für Dein Problem die Hilfe. Ich möchte Dir hier nur Kurz zeigen, wie er aufgebaut wird und wie man die Fehlermeldung #NV bei einem Leeren Feld umgehen kann.

    Tabelle1
     ABC
    1Tabelle Anmeldung /Startnummer
    2StartnrNameVorname
    31Name1Vorname1
    42Name2Vorname2
    53Name3Vorname3
    64Name4Vorname4
    75Name5Vorname5
    86Name6Vorname6
    97Name7Vorname7
    108Name8Vorname8
    119Name9Vorname9
    1210Name10Vorname10
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
    Tabelle2
     ABC
    1Einlauf ins Ziel
    2   
    3StartnrNameVorname
    48Name8Vorname8
    5 #NV#NV
    6 #NV#NV
    7Um das #NV wegzubekommen
    85Name5Vorname5
    9   
    10   
    Formeln der Tabelle
    B4 : =SVERWEIS(A4;Tabelle1!$A$1:$C$12;2;0)
    C4 : =SVERWEIS(A4;Tabelle1!$A$1:$C$12;3;0)
    B5 : =SVERWEIS(A5;Tabelle1!$A$1:$C$12;2;0)
    C5 : =SVERWEIS(A5;Tabelle1!$A$1:$C$12;3;0)
    B6 : =SVERWEIS(A6;Tabelle1!$A$1:$C$12;2;0)
    C6 : =SVERWEIS(A6;Tabelle1!$A$1:$C$12;3;0)
    B8 : =WENN(ISTFEHLER(SVERWEIS(A8;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A8;Tabelle1!$A$1:$C$12;2;0))
    C8 : =WENN(ISTFEHLER(SVERWEIS(A8;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A8;Tabelle1!$A$1:$C$12;3;0))
    B9 : =WENN(ISTFEHLER(SVERWEIS(A9;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A9;Tabelle1!$A$1:$C$12;2;0))
    C9 : =WENN(ISTFEHLER(SVERWEIS(A9;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A9;Tabelle1!$A$1:$C$12;3;0))
    B10 : =WENN(ISTFEHLER(SVERWEIS(A10;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A10;Tabelle1!$A$1:$C$12;2;0))
    C10 : =WENN(ISTFEHLER(SVERWEIS(A10;Tabelle1!$A$1:$C$12;2;0));"";SVERWEIS(A10;Tabelle1!$A$1:$C$12;3;0))
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
    Gruß Marcus
    Das Forum lebt auch von den Rückmeldungen der Fragesteller


    Die neue Excel-Homepage für Anfänger

      


    Betrifft: Danke!!! von: Thomas
    Geschrieben am: 08.10.2003 22:52:07

    Hallo!

    Vielen Dank für die tolle Unterstützung!
    Das war genau das, was ich gesucht habe!

    Danke nochmal!!!


     

    Beiträge aus den Excel-Beispielen zum Thema " Leichte Aufgabe für Profis..."