Herbers Excel-Forum - das Archiv

Summewenn

Bild

Betrifft: Summewenn
von: sigi
Geschrieben am: 06.10.2003 13:08:29
Hallo,
warum funktioniert das Zählen nach Monaten nicht.
Oder wie kann ich die Formel umstellen, dass nur die Zahlen des jeweiligen
Monates gezhlt werden?
Danke!
Gruß
Sigi

Die Datei https://www.herber.de/bbs/user/1298.xls wurde aus Datenschutzgründen gelöscht

Bild

Betrifft: AW: Summewenn
von: Galenzo
Geschrieben am: 06.10.2003 13:34:37
Hallo,
die Array-Formel ist {=SUMME(WENN(B10:B31=D10;C10:C31;))}
Allerdings solltest du die Monate in Spalte B mit der Formel =MONAT(A1) berechnen.

Viel Erfolg.
Bild

Betrifft: AW: Summewenn - Beispielsmappe
von: Galenzo
Geschrieben am: 06.10.2003 13:45:15
Hallo,

schau's dir mal an...

Die Datei https://www.herber.de/bbs/user/1300.xls wurde aus Datenschutzgründen gelöscht

Bild

Betrifft: AW: Summewenn
von: MarcoW
Geschrieben am: 06.10.2003 13:38:16
Hallo,

Du hattest in der Spalte B nur das Zahlenformat auf MMMM gestellt, damit der Monat als Text angezeigt wird. Aber in der Zelle steht dennoch das jeweilige Datum.

Mein Vorschlag:

Zelle B10 = Monat(A10)

dann runterkopieren

Dann in Zelle D10 eine 1 als Suchkriterium eingeben und die Summe wird berechnet.

Nachteil ist aber, dass der Text nicht verwendet wird, aber über sverweis kannst Du ja die Monatsnamen noch dazugeben und dann nach Monatsnamen summieren.

Gruß MarcoW
Bild

Betrifft: SUMMEWENN nach Monaten
von: Boris
Geschrieben am: 06.10.2003 13:39:57
Hi Siggi,

für deinen bestehenden Tabellenaufbau geht folgende Formel:

=SUMMENPRODUKT((MONAT(B10:B31)=MONAT((1&D10)*1))*(B10:B31<>"")*C10:C31)

Allerdings ist es einfacher, in B10 den Monat wie folgt auszulesen (Formel dann runterkopieren):
=TEXT(A10;"MMMM")

Dann kannst du die normale SUMMEWEN-Funktion nutzen:
=SUMMEWENN(B:B;D10;C:C)

Du musst halt bedenken, dass bei Dir in Spalte B der Monatsname nur durch die Zellformatierung entsteht - dahinter steckt eigentlich das Datum. Daher geht´s bei dir nicht.

Grüße Boris
Bild

Betrifft: Danke an alle die mir geholfen haben o.T
von: sigi
Geschrieben am: 06.10.2003 15:24:51
`
 Bild
Excel-Beispiele zum Thema " Summewenn"
Beispiel für die Anwendung der SUMMEWENN-FORMEL SUMMEWENN-Funktion über mehrere Tabellenblätter
SummeWenn-Summierung über mehrere Blätter