Microsoft Excel

Herbers Excel/VBA-Archiv

Mehr als 7 Wenn

    Betrifft: Mehr als 7 Wenn von: Tom
    Geschrieben am: 07.10.2003 00:29:16

    Hi,

    ich würde gerne mehr als 7 Wenn verschachteln. Gibt es eine Möglichkeit?

    Servus, Tom

      


    Betrifft: AW: Mehr als 7 Wenn von: Franz W.
    Geschrieben am: 07.10.2003 00:39:39

    Hallo Tom,

    Du kannst mit "+" soviele WENN schreiben, wie Du willst:

    =WENN(A1=...;"1";WENN(A1=...;"2";WENN(A1=...;"3";WENN(A1=...;"4";WENN(A1=..."5";WENN(A1=...;"6";WENN(A1=...;"7";)))))))+WENN(A1=...;"8";WENN(A1=...;"9";WENN(A1=...;"10";WENN(A1=...11);"11";WENN(A1=...;"12";)))))

    Grüße
    Franz


      


    Betrifft: Zusatz: Mehr als 7 Wenn von: Jörg Gradert
    Geschrieben am: 07.10.2003 01:32:47

    Hallo Tom, Hallo Franz,
    wenn der Rückgabewert Text ist, muss mit & verknüpft werden.
    Also:
    =WENN(A1=1;"EINS";)&WENN(A1=2;"ZWEI";)
    sonst erhält man #WERT!, da Text sich nicht addieren lässt.
    siehe hier:

    http://www.excelformeln.de/formeln.html?welcher=128

    Franz,
    =WENN(A1=1;"1";)+WENN(A1=2;"1";)
    geht. Es wird aber auch als Zahl erkannt und in die Zelle eingetragen (rechtsbündig).
    Man kann aber dann ebensogut gleich
    =WENN(A1=1;1;)+WENN(A1=2;2;)
    ohne "" schreiben.

    Gruss Jörg


      


    Betrifft: AW: Zusatz: Mehr als 7 Wenn von: Franz W.
    Geschrieben am: 07.10.2003 01:45:29

    Hallo Jörg,

    vielen Dank, zwei wertvolle Zusatztipps! Ich habe diese Verschachtelung bisher nur mit Zahlen, darum bin ich über die Geschichte mit Text und & noch nicht gesolpert.

    Danke undGrüße
    Franz


      


    Betrifft: AW: Eine weitere Überlegung wäre SVERWEIS von: Marcus Rose
    Geschrieben am: 07.10.2003 04:33:20

    Hallo Tom

    Je nachdem was Du machen möchtest, könnte aber auch der SVERWEIS besser sein. Du hast Dich ja nicht so ganz genau darüber ausgelassen, wofür das Du die WENN miteinander verknüpfst. Das sähe dann so aus:
    Matrix
     BCDEFG
    32Marcus35 Jahre Von wem wollen Sie das Alter wissen?
    33Klaus34 Jahre Berndist35 Jahre
    34Bernd35 Jahre    
    35Rainer48 Jahre    
    Formeln der Tabelle
    G33 : =SVERWEIS(E33;B32:C35;2;0)
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
    Gruß Marcus
    Das Forum lebt auch von den Rückmeldungen der Fragesteller


    Die neue Excel-Homepage für Anfänger

      


    Betrifft: AW: Eine weitere Überlegung wäre SVERWEIS von: Rainer
    Geschrieben am: 08.10.2003 14:15:39

    Hallo an alle, die geantwortet haben,

    habe wieder eine Menge dazugelernt. Werde gleich alles ausprobieren. Das mit + und & habe ich auch noch nicht gewußt. Vielen Dank dafür.

    Gruß Tom


      


    Betrifft: Hallo Rainer oder Tom?? :-)) Viel Erfolg... o.T. von: Franz W.
    Geschrieben am: 08.10.2003 16:33:07