SUMMEWENN

Bild

Betrifft: SUMMEWENN
von: MikeS
Geschrieben am: 19.11.2003 11:35:12

Hallo Leute,

ich steh momentan voll auf'm Schlauch bei dieser doch recht simplen Formel.

Warum ist das Formelergebnis = "0" ???

Die Datumsreihe ist komplett als Datum TT.MMM'JJ formatiert.

Vielen Dank für Eure Hilfe.

Ciao MikeS

Formelproblem
 ABCDE
1TagAnrufe Anrufe kumuliert
201.Jan'044 Januar0
302.Jan'048 Februar 
403.Jan'0412 März 
504.Jan'0416 April 
605.Jan'0420 Mai 
706.Jan'0424 Juni 
807.Jan'0428 Juli 
908.Jan'0432 August 
1009.Jan'0436 September 
1110.Jan'0440 Oktober 
1211.Jan'0444 November 
1312.Jan'0448 Dezember 
1413.Jan'0452   
1514.Jan'0456   
1615.Jan'0460   
1716.Jan'0464   
1817.Jan'0468   
1918.Jan'0472   
2019.Jan'0476   
2120.Jan'0480   
2221.Jan'0484   
2322.Jan'0488   
2423.Jan'0492   
2524.Jan'0496   
2625.Jan'04100   
2726.Jan'04104   
2827.Jan'04108   
2928.Jan'04112   
3029.Jan'04116   
3130.Jan'04120   
3231.Jan'04124   
Formeln der Tabelle
E2 : =SUMMEWENN(A2:A32;MONAT(A2);B2:B32)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Bild


Betrifft: 01.01.2004 ist eben nicht 4...
von: Boris
Geschrieben am: 19.11.2003 11:41:45

Hi Mike,

...daher gibt´s ne glatte Null. ;-)

=SUMMENPRODUKT((MONAT($A$2:$A$32)=MONAT(A2))*$B$2:$B$32)

Grüße Boris


Bild


Betrifft: Sollte heissen: 01.01.2004 ist eben nicht 1...oT
von: Boris
Geschrieben am: 19.11.2003 11:42:42




Bild


Betrifft: AW: Sollte heissen: 01.01.2004 ist eben nicht 1...oT
von: MikeS
Geschrieben am: 19.11.2003 11:50:57

Aber wenn in A1 z.B. "01.01.04" steht, müßte ich doch als Ergebnis
mit der Formel "=MONAT(A1)" den Wert "1" erhalten.


Bild


Betrifft: Natürlich ergibt =MONAT(A1) dann 1 - allerdings...
von: Boris
Geschrieben am: 19.11.2003 11:58:12

Hi Mike,

...hast du bei deinem SUMMEWENN-Versuch den Monat (1) mit dem Eintrag in A1 (01.01.2004) vergleichen - und dieser Vergleich ist nunmal FALSCH, denn 01.01.2004 = 1 stimmt halt nicht. Und daher gibt´s im Endergebnis auch ne Null.

Grüße Boris


Bild


Betrifft: AW: Natürlich ergibt =MONAT(A1) dann 1 - allerdings...
von: MikeS
Geschrieben am: 19.11.2003 12:00:20

Danke Dir.

Ciao MikeS


Bild


Betrifft: AW: 01.01.2004 ist eben nicht 4...
von: MikeS
Geschrieben am: 19.11.2003 11:44:48

Hi Boris,

vielen Dank, klappt bestens.

Ciao MikeS


Bild

Beiträge aus den Excel-Beispielen zum Thema " SUMMEWENN"