Nummerierung ohne leere Zellen

Bild

Betrifft: Nummerierung ohne leere Zellen von: Domi
Geschrieben am: 05.02.2005 21:55:38

Tschau miteinander,

Folgendes Problemchen:

Wenn ich in der Spalte "Namen" einen Wert reinschreibe, sollte in der Spalte "Nummern" eine fortlaufende Nummerierung erscheinen.

Leere Zellen sollten übersprungen werden und die Nummerierung weitergeführt werden. Und als Letztes: Beim Löschen von Namen sollte die Nummerierung natürlich wieder angepasst werden.

Ein möglicher Ansatz habe ich schon mal gefunden, aber irgendwie komme ich nicht zum Ergebniss.

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
x=2
y=2
Do While Range ("Namen").Cells(x,1) <>0
If Range("Name").Cells(x,1) <> 0 Then Range ("Nummer").Cells(x,1)=y
If Range("Name").Cells(x,1) ="" Then Range ("Nummer").Cells(x,1)=""
x=x+1
y=y+1
Loop
End Sub


Vieleicht hätte Jemand eine Lösung, wie der VBA Code aussehen müsste ?

Besten Dank und freundliche Grüsse.

Domi
Bild


Betrifft: AW: Nummerierung ohne leere Zellen von: Josef Ehrensberger
Geschrieben am: 05.02.2005 22:22:27

Hallo Domi!

Muss es unbedingt VBA sein?
Tabelle1
 AB
1NummernNamen
21Name
3  
4  
5  
62Name
7  
8  
9  
103Name
114Name
12  
135Name
14  
15  
16  
17  
18  
19  
20  
216Name
Formeln der Tabelle
A2 : =WENN(B2<>"";ANZAHL2($B$2:$B2);"")
A3 : =WENN(B3<>"";ANZAHL2($B$2:$B3);"")
A4 : =WENN(B4<>"";ANZAHL2($B$2:$B4);"")
A5 : =WENN(B5<>"";ANZAHL2($B$2:$B5);"")
A6 : =WENN(B6<>"";ANZAHL2($B$2:$B6);"")
A7 : =WENN(B7<>"";ANZAHL2($B$2:$B7);"")
A8 : =WENN(B8<>"";ANZAHL2($B$2:$B8);"")
A9 : =WENN(B9<>"";ANZAHL2($B$2:$B9);"")
A10 : =WENN(B10<>"";ANZAHL2($B$2:$B10);"")
A11 : =WENN(B11<>"";ANZAHL2($B$2:$B11);"")
A12 : =WENN(B12<>"";ANZAHL2($B$2:$B12);"")
A13 : =WENN(B13<>"";ANZAHL2($B$2:$B13);"")
A14 : =WENN(B14<>"";ANZAHL2($B$2:$B14);"")
A15 : =WENN(B15<>"";ANZAHL2($B$2:$B15);"")
A16 : =WENN(B16<>"";ANZAHL2($B$2:$B16);"")
A17 : =WENN(B17<>"";ANZAHL2($B$2:$B17);"")
A18 : =WENN(B18<>"";ANZAHL2($B$2:$B18);"")
A19 : =WENN(B19<>"";ANZAHL2($B$2:$B19);"")
A20 : =WENN(B20<>"";ANZAHL2($B$2:$B20);"")
A21 : =WENN(B21<>"";ANZAHL2($B$2:$B21);"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Nummerierung ohne leere Zellen von: Nepumuk
Geschrieben am: 05.02.2005 22:30:36

Hallo Sepp,

schon mal versehentlich ein Makro beim eintippen von Daten gelöscht? Ich noch nicht, aber dafür schon jede Menge Formeln :-)


Private Sub Worksheet_Change(ByVal Target As Range)
    Dim lngRow As Long, lngCounter As Long
    If Not Application.Intersect(Target, Range("Namen")) Is Nothing Then
        Application.ScreenUpdating = False
        For lngRow = 1 To Range("Name").Cells.Count
            If Trim$(Range("Name").Cells(lngRow, 1).Text) <> "" Then
                lngCounter = lngCounter + 1
                Range("Nummer").Cells(lngRow, 1).Value = lngCounter
            Else
                Range("Nummer").Cells(lngRow, 1).Value = ""
            End If
        Next
        Application.ScreenUpdating = True
    End If
End Sub


Gruß
Nepumuk


Bild


Betrifft: Danke! von: Domi
Geschrieben am: 05.02.2005 22:38:03

Nochmals Grüezi Nepumuk und Sepp,

ich bin zu langsam beim Antworten.

Vielen Dank an Beide. Genau das habe ich gesucht!

mit freundlichen Grüssen

domi


Bild


Betrifft: @Nepumuk! Das du...... von: Josef Ehrensberger
Geschrieben am: 05.02.2005 22:42:59

.... aus versehen was löscht, kann ich mir nicht vorstellen ;-)))


Gruß Sepp


Bild


Betrifft: AW: @Sepp von: Nepumuk
Geschrieben am: 05.02.2005 23:05:53

Hallo Sepp,

dafür habe ich mir extra eine Krücke gebastelt (siehe Mustemappe B1:B10), welche es mir anzeigt, wenn ich eine Formel überschrieben habe.

https://www.herber.de/bbs/user/17531.xls

Gruß
Nepumuk


Bild


Betrifft: klevere Lösung! o.T. von: Josef Ehrensberger
Geschrieben am: 05.02.2005 23:36:17

Gruß Sepp


Bild


Betrifft: AW: @Sepp und Nepumuk von: th.heinrich
Geschrieben am: 05.02.2005 23:55:47

hallo an Euch,

sorry, wenn ich mich einmische, aber was spricht dagegen die zellen mit Formeln zu sperren und das blatt zu schützen?

https://www.herber.de/bbs/user/17533.xls

gruss thomas


Bild


Betrifft: AW: @Sepp und Nepumuk von: Josef Ehrensberger
Geschrieben am: 06.02.2005 08:45:40

Hallo Thomas!

Natürlich nichts!

Es ist mehr als Spielerei zu sehen.


Gruß Sepp


Bild


Betrifft: AW: Nummerierung ohne leere Zellen von: Domi
Geschrieben am: 05.02.2005 22:34:18

Salü Sepp,

vielen Dank für deine Bemühungen.

Ja ich möchte es mit VBA machen!

Ist eine Tabelle auf die versch. Personen zugreifen. Und zur Zeit kann ich den Blattschutz nicht aktivieren, um so die Formeln zu schützen. Ist noch in der "Entwicklungsphase".

mit freundlichen Grüssen

domi


Bild


Betrifft: TEILERGEBNIS: Nummerierung ohne leere Zellen mit T von: Beate Schmitz
Geschrieben am: 05.02.2005 23:47:48

Hallo Domi,

ich habe mitgekriegt, dass du es mit VBA machen möchtest, habe aber auch noch eine interessante Formellösung:

 
 AB
1Nr.Name
21Al Kadi
3  
42Armborst
53Bacalanovic
64Barak
7  
85Borsch
9  
106Bosch
117Braun
Formeln der Tabelle
A2 : =WENN(B2="";"";TEILERGEBNIS(3;B$2:B2)*1)
A3 : =WENN(B3="";"";TEILERGEBNIS(3;B$2:B3)*1)
A4 : =WENN(B4="";"";TEILERGEBNIS(3;B$2:B4)*1)
A5 : =WENN(B5="";"";TEILERGEBNIS(3;B$2:B5)*1)
A6 : =WENN(B6="";"";TEILERGEBNIS(3;B$2:B6)*1)
A7 : =WENN(B7="";"";TEILERGEBNIS(3;B$2:B7)*1)
A8 : =WENN(B8="";"";TEILERGEBNIS(3;B$2:B8)*1)
A9 : =WENN(B9="";"";TEILERGEBNIS(3;B$2:B9)*1)
A10 : =WENN(B10="";"";TEILERGEBNIS(3;B$2:B10)*1)
A11 : =WENN(B11="";"";TEILERGEBNIS(3;B$2:B11)*1)
 
Gruß, Beate


Bild


Betrifft: Nachtrag von: Beate Schmitz
Geschrieben am: 06.02.2005 00:26:25

Ich vergaß zu erwähnen: Diese Formel ist im Gegensatz zu Josef's Formel gut, wenn man den Autofilter einsetzen will und die Nummerierung im gefilterten Zustand fortlaufend haben möchte. Ich habe das z.B. mal realisiert bei einer Schülerliste für eine ganze Schule. Jede Klasse wurde dann aber passend durchnummeriert, wenn man sie ausfilterte; das mal als Beispiel, wo der Vorteil liegt.

Gruß,
Beate


Bild


Betrifft: AW: Nachtrag von: Rentner Walter
Geschrieben am: 06.02.2005 04:22:10

Auto-Nummerierung:
1. Formel in A1
2. Formel in A2
3. Formel von A2 nach unten kopieren

1) WENN(ISTLEER(B4);"";1)
2) WENN(NICHT(ODER(ISTLEER(A4);ISTLEER(B5)));$A$4+ANZAHL($A$4:A4);"")

Gruß Walter


Bild


Betrifft: AW: Nummerierung ohne leere Zellen von: Rentner Walter
Geschrieben am: 06.02.2005 04:33:09

Hallo Domi,
Nummerierung ohne Makro
1. Formel in Zelle A4
2. Formel in Zelle A5
Dann Formel aus Zelle A5 nach unten kopieren


1) WENN(ISTLEER(B4);"";1)
2) WENN(NICHT(ODER(ISTLEER(A4);ISTLEER(B5)));$A$4+ANZAHL($A$4:A4);"")
Gruß Walter



Bild


Betrifft: Merci von: Domi
Geschrieben am: 06.02.2005 09:24:01

Guten Morgen miteinander,
vielen herzlichen Dank nochmals an alle, die sich meinem Problem angenommen haben.
Der Tip mit den Formeln ist auch Super.

mit freundlichen Grüssen Domi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Nummerierung ohne leere Zellen"