Problem mit Verknüpfung mehrerer excel dateien

Bild

Betrifft: Problem mit Verknüpfung mehrerer excel dateien von: Ivan
Geschrieben am: 10.02.2005 10:52:26

hallo

habe ein etwas komplizierten fall, vieleicht kann mir jemand weiter helfen.
folgendes. ich habe 2 excel dateien. nun habe ich diese beiden verknüpft
allerdings möchte ich in der pfadangabe der verknüpfung auf eine zelle bezug nehmen. (Meine Excel Version ist nicht 2003 sondern 2002)

im moment sieht meine formel so aus:
=WENN(ISTFEHLER('C:\wkd\[KW01_1111_BP.xls]DA'!$C23);"-";'C:\wkd\[KW01_1111_BP.xls]DA'!$C23)

das funktioniert soweit auch. nur möchte ich jetzt die nr. 1111 und KW01 durch
z.B. B4 und E2 ersetzen. Wie krieg ich das hier rein?
dachte erst vieleicht mit folgendem:

=WENN(ISTFEHLER('C:\wkd\[(B4)_(E2)_BP.xls]DA'!$C23);"-";'C:\wkd\[(B4)_(E2)_BP.xls]DA'!$C23)

aber das geht nicht.

kann mir jemand weiterhelfen?

danke im vorraus ;-)

Bild


Betrifft: AW: Problem mit Verknüpfung mehrerer excel dateien von: KlausF
Geschrieben am: 10.02.2005 11:40:51

Hallo, Ivan!

Habe ähnliches Problem der variablen Adressierung mit INDIREKT gelöst.
Bei mir stand in D3 der Dateiname, in D4 der Blattname, in D5 die Spalte (Buchstabe!) und in D5 die Zeile

in einer Tabellenzelle stand die Formel
=INDIREKT("["&D3&"]"&D4&"!"&D5&D6)
und Excel holte sich die Daten von dem so zusammengesetzten, variablen Bezug.
Klappt aber nur mit geöffneter Quelldatei, sonst erscheint #BEZUG!

Versuch's mal in diese Richtung!
Gruß
Klaus


Bild


Betrifft: AW: Problem mit Verknüpfung mehrerer excel dateien von: Ivan
Geschrieben am: 10.02.2005 12:05:13

hallo KlausF

Super Du hast mich schon einen ganzen schritt weiter gebracht. besten dank.
jetzt ist lediglich noch ein problem.

=WENN(ISTFEHLER("'C:\wkd\["&E1&"_"&B4&"_BP.xls]DA'!$C23");"-";'C:\wkd\[KW01_1111_BP.xls]DA'!$C23)

Beim zweiten Teil der WENN Funktion kann ich das "&E1&" und "&B4&" (anstelle von KW01 und 1111) nicht mehr anwenden und das brauch ich natürlich.

hast du da ev. noch eine idee?

grüsse

ivan


Bild


Betrifft: AW: Problem mit Verknüpfung mehrerer excel dateien von: Günther Oppold
Geschrieben am: 10.02.2005 12:25:14

Hallo Ivan

nimm doch Indirekt, wie Klaus vorgeschlagen hatte:


=WENN(ISTFEHLER(indirekt("'C:\wkd\["&E1&"_"&B4&"_BP.xls]DA'!$C23"));"-";indirekt("'C:\wkd\["&E1&"_"&B4&"_BP.xls]DA'!$C23"))

Beachte jedoch, dass die Bezugsdatei geöffnet sein muss, sonst funktioniert Indirekt nicht!



Günther


Bild


Betrifft: AW: Problem mit Verknüpfung mehrerer excel dateien von: Ivan
Geschrieben am: 10.02.2005 13:26:18

Das Problem ist, dass ich die bezugsdatei nicht geöffnet haben kann.
da es dann zu viele dateien wären, das verkraftet mein netzwerk nicht *g*
Es muss irgendwie ohne diesen INDIREKT gehen


Bild


Betrifft: AW: Problem mit Verknüpfung mehrerer excel dateien von: Ivan
Geschrieben am: 10.02.2005 14:00:15

=WENN(ISTFEHLER('C:\wkd\[KW01_1111_BP.xls]DA'!$C23);"-";'C:\wkd\[KW01_1111_BP.xls]DA'!$C23)

funktioniert ja eigentlich auch ohne INDIREKT.
Mein problem liegt ja eigentlich nicht darin aus einer anderen xls. datei einen wert zu übernehmen.

Beispiel zum das ganze etwas zu erläutern:

xls 1
---------------------------------

E2 = KW01 E3 = KW02 E4 = KW05 usw.......
----------------------------------------------------------------------------------------
B4 = 1111
----------------------------------------------------------------------------------------
B5 = 1112
----------------------------------------------------------------------------------------
B6 = 1113
usw.
.
.
.
.
.

=WENN(ISTFEHLER('C:\wkd\[KW01_1111_BP.xls]DA'!$C23);"-";'C:\wkd\[KW01_1111_BP.xls]DA'!$C23)



KW01_1111_BP.xls
---------------------------------
C23 = 120



Grundsätzlich geht das jetzt ja, wenn die datei KW01_1111_BP.xls existiert
='C:\wkd\[KW01_1111_BP.xls]DA'!$C23
wenn aber z.B. KW05_1112_BP.xls nicht exisitert gibts einen #BEZUG! Fehler
Darum hab ich diese WENN und ISTFEHLER eingebaut.
Jetzt gehts eigentlich nur noch darum, dass ich diese zwei bestandteile nicht in allen (beinahme 2500 Zellen)
umschreiben muss. also dass ich den Pfad mithilfe der Zellen E2,B4 E2,B5 E2,B6 usw. zusammenstellen kann.
diese zellen sind ja aber im gleichen xls file.
wieso geht das nicht ganz einfach? ;-(


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Problem mit Verknüpfung mehrerer excel dateien"