Doppelte Einträge in Zelle verhindern

Bild

Betrifft: Doppelte Einträge in Zelle verhindern von: Samilito
Geschrieben am: 11.02.2005 11:54:06

Hallo zusammen,

habe ein exel-Problem und bin beim Suchen nach Hilfe zufällig auf diese Seite gestossen.

Folgendes Problem:

Ich führe eine Tabelle mit mehreren Zeilen und Spalten fortlaufend fort. Die Werte in der ersten Spalte sind einmalig, d.h. dürfen nicht doppelt vergeben werden. Nun kommt es vor, dass Werte in dieser Spalte doppelt eingegeben werden. Kann Exel dies sofort erkennen und verhindern?

Danke.

Samy

Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: werner h.
Geschrieben am: 11.02.2005 12:07:54

hallo Samy,

geht über Daten-Gültigkeit - benutzerdefiniert und folgende Formel:(für Spalte A)
=ZÄHLENWENN(A:A;A1)=1

über Services- Recherche findest du übrigens zu dem Thema jede Menge Antworten

Grüße
Werner


Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: Luc
Geschrieben am: 11.02.2005 12:18:35

Hallo Samy,
gefällt dir wohl im Forum, obwohl dir noch keiner geantwortet hat!?
Die Antwort auf deine Frage hängt davon ab, welche Mittel du einsetzen willst:
1. nur eine ZellFormel: das wäre dann mit 2 Einzelformeln mit Funktion SVERWEIS() - können evtl auch zu einer Formel verschachtelt wdn - und einer geeigneten Formel/Methode für die Markierung der Doppelteingabezelle (z.B. über bedFormat auf der gesamten Spalte) möglich.
2. VBA-Prozedur: Sollte i.d.R. eine Ereignisprozedur sein, damit Doppel sofort angezeigt wird - z.B. mittels Worksheet_Change. Da müsste das jeweilige Target (d.h.aktuelle Zelle) mit den vorherigen vgl wdn, wenn es sich um eine Zelle der bewussten Spalte handelt.
Falls du noch Fragen hast - ich bin evtl heute abend noch mal im Netz.
Ciao Luc


Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: Samilito
Geschrieben am: 11.02.2005 13:06:22

Danke werner, danke luc!

@werner: die formel funktioniert nur, wenn man die werte eintippt! problem ist, dass ich mit copy/paste doppelte eintragungen machen kann :-(

@luc: meine exel-kenntnisse sind zu gering, um deine ausführungen ohne weiteres zu verstehen.

gruss

samy


Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: Bernhard
Geschrieben am: 11.02.2005 13:36:49

Zieh die Formel runter, dann funktioniert es bestens


Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: werner h.
Geschrieben am: 11.02.2005 14:03:01

Hallo Samy,

du hast du allerdings recht - habe die Frage wieder auf offen gestellt.

mfg
w.


Bild


Betrifft: AW: Doppelte Einträge in Zelle verhindern von: Luc
Geschrieben am: 11.02.2005 18:48:12

Hallo Samy,
ich meinte, willst du eine normale auf den Excel-Arbeitsblatt-Funktionen (1.) basierende Lösung oder eine mit VBA programmierte (2.)? Im 1.Fall solltest du mal auf einer Zelle den Funktionsassistenten (fx) aufrufen und dir die Matrixfunktionen (sie beinhalten Navigationsmöglichkeiten innerhalb einer Zellbezugsmatrix = Datenfeld = ein Teil einer Tabelle) ansehen. Ein ganz heißer Kandidat zur Lösung deines Problems wäre da die Funktion SVERWEIS()! Kommt auch sicher xmal im Archiv vor!
Ciao Luc


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Doppelte Einträge in Zelle verhindern"