Datumsdifferenz ermitteln und ausgeben

Bild

Betrifft: Datumsdifferenz ermitteln und ausgeben von: diso_de
Geschrieben am: 11.02.2005 16:58:23

Guten Tag zusammen,

ich bin Einsteiger (blutiger Anfänger) und habe das nachstehende Problem über ein Makro zu lösen versucht, komme aber hierbei auf keinen grünen Zweig.

Es wäre nett, wenn mir jemand helfen und aufzeigen könnte, wie das ganze auszusehen hat, so das es auch funktioniert.

Vielen herzlichen Dank
Dieter


Hier die Ausgangssituation:

Datengrundlage ist ein Excel-File (zsdr0035) mit derzeit 3821 Datenzeilen. Es enthält u.a. die Spalte AG (= Letzter Abruf am - (Format = Datum)), die Spalte O (= Gültig von Datum - (Format = Datum)) und die Spalte AN (= Keine Aktivität seit X-Tagen - (Format = Zahl)).

Hierüber möchte ein Makro erstellen, das mir in den 3821 Datenzeilen unter folgenden Bedingungen den Differenzwert in Tagen liefert:

Wenn die Spalte AG nicht leer ist, und den Wert (z.B. 01.10.2004) enthält, soll das heutige Datum (11.02.2005) davon abgezogen werden und nur der Differnzwert in Tagen in die Spalte AN (z.B. 134) ausgegeben werden der größer als 90 Tage ist.

Oder wenn die Spalte AG leer ist, dann soll vom Wert der Spalte O (ist immer gefüllt) das heutige Datum (11.02.2005) abgezogen werden und nur der Differenzwert in Tagen in die Spalte AN (z.B. 103) ausgegeben werden, der größer als 90 Tage ist.

Bild


Betrifft: AW: Datumsdifferenz ermitteln und ausgeben von: Heiko
Geschrieben am: 11.02.2005 17:11:19

Hallo!
Das geht aber auch mit "konventioneller" Technik - ohne VBA, sogar sehr gut.
Gibt es einen besonderen Grund, weshalb in VBA, oder wäre auch die "normale" Lösung ok?
Gruss, Heiko


Bild


Betrifft: AW: Datumsdifferenz ermitteln und ausgeben von: diso_de
Geschrieben am: 11.02.2005 17:37:21

Hallo Heiko,

von meiner Seite aus spricht nichts gegen die konventionelle Methode. In VBA, das war nur mal ein erster Versuch meinerseits diesem Problem zu Leibe zu rücken.

Gruß
Dieter


Bild


Betrifft: AW: Datumsdifferenz ermitteln und ausgeben von: MarkusL
Geschrieben am: 11.02.2005 19:18:49

Hallo Dieter

probiers doch einmal so:
A2 = Spalte AG
B2 = Spalte O

=WENN(A2="";DATEDIF(B2;HEUTE();"d");DATEDIF(A2;HEUTE();"d"))-90

Ich hoffe es funktz auf diese Weise

Gruss
Markus


Bild


Betrifft: AW: Datumsdifferenz ermitteln und ausgeben von: diso_de
Geschrieben am: 11.02.2005 21:10:07

Hallo Markus,

vielen Dank für Deinen Vorschlag, aber es funzt nicht ganz richtig. Es werden ziemlich Abstruse Zahlen zurückgegeben. Habe das mal bildlich verdeutlicht.

Userbild


In Zeile 2 ist die Zelle B2 leer - das ist i.O.
In Zeile 2 hat die Zelle A2 den Inhalt 24.11.2004 - das würde glaube ich 80 Tage geben. Es dürfen aber keine 80 Tage geschrieben werden, sonder nur 0, da die Differenz nicht größer als 90 ist.

Ich habe die Ausgangswerte, die herangezogen werden müßen, grau hinterlegt.

Gruß
Dieter


Bild


Betrifft: AW: Datumsdifferenz ermitteln und ausgeben von: Josef B
Geschrieben am: 11.02.2005 22:35:01

Hallo Dieter

So so sollte es funktionieren:
=(HEUTE()-MAX(A2:B2)>89)*(HEUTE()-WENN(B2="";A2;B2)+1)

Gruss Josef


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datumsdifferenz ermitteln und ausgeben"