Formel falsch? Ich doof?

Bild

Betrifft: Formel falsch? Ich doof? von: Max
Geschrieben am: 14.02.2005 10:45:17

Hallo und guten Morgen!!

Habe ein Problem mit einer Formel:

Die Formel soll die Summe der Spalte B berechnen, wenn in Spalte M Februar steht.

meine Formel sieht so aus:

=SUMMEWENN(Tabelle1!$M:$M;"Februar";Tabelle1!B:B) Aber sie funzt net


Die Spalte M ist gleich der Spalte A, nur im Format MMMM, damit der Monat ausgeschrieben ist. Wenn es ohne diesen Umweg über Spalte M ginge wäre ich auch sehr froh darüber. Kann mir jemand helfen?Vielen Dank,

Max

Bild


Betrifft: AW: Formel falsch? Ich doof? von: u_
Geschrieben am: 14.02.2005 10:49:49

Hallo,
so sollte es gehen:
=SUMMENPRODUKT((TEXT($A$1:$A$1000;"MMMM")="Februar")*($B$1:$B$1000))


Bild


Betrifft: AW: Formel falsch? Ich doof? von: Max
Geschrieben am: 14.02.2005 11:01:06

Hallo u_,

scheint nicht zu funzen. Kannst du mir die Formel kurz auf mich zurecht schneiden? was hat es mit dem "Text" auf sich?

Spalte A: Datum

Spalte B: die zu addierenden Werte, wenn Spalte M =Januar ist

Spalte M: =Spalte A aber Benutzerdefinierte Formatierung:MMMM

Danke


Bild


Betrifft: AW: Formel falsch? Ich doof? von: u_
Geschrieben am: 14.02.2005 11:08:39

Hallo,
die Formatierung bringt dir garnix. Da steht immer noch ein Datum in der Zelle.
zu 'Text': schau mal in die Hilfe.
Ansonsten sollte das Funktionieren. Die Formel bringt dir die Summe aus B wenn das Datum in A im Februar liegt.

Gruß


Bild


Betrifft: AW: Formel falsch? Ich doof? von: Thomas
Geschrieben am: 14.02.2005 10:57:12

Hallo,
Füge in Spalte M die Funktion =Monat(Spalte A) ein.
In Spalte M steht dann das Monat als Zahl 1=Jan 2=feb usw.

und
=SUMMEWENN(Tabelle1!$M:$M;2;Tabelle1!B:B)

Thomas


Bild


Betrifft: danke Thomas, funzt. o.T. von: Max
Geschrieben am: 14.02.2005 11:05:27




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel falsch? Ich doof?"