Herbers Excel-Forum - das Archiv

Ersatz ? für SVERWEIS

Bild

Betrifft: Ersatz ? für SVERWEIS
von: Thorsten

Geschrieben am: 15.02.2005 09:54:32
Hallo,
brauche wieder mal Hilfe.
In Tabelle 'Import' steht in Spalte A ein Name und z,B, in Spalte B
eine zugehörige Nummer.
So klappt`s nicht richtig!
'=SVERWEIS(J6;Import!$A$1:$H$1000;VERGLEICH($I$2;Import!$A$1:$H$1;0))
Problem:
Gebe ich bei "J6" den richtigen Namen ein - funktioniert es.
Gebe ich z.B. einen noch nicht enthalten Namen ein - dürfte
soll keine Nummer erscheinen.
Excel macht dies aber trotzdem indem es die erste Nummer des
mit gleichen Anfangsbuchstaben bestehenden Wert vergibt.
Wer kann helfen?
Die Nummer aus 'Import!SpalteB' darf nur vergeben werden, wenn der Name vollständig übereinstimmt.
Gruß Thorsten
Bild

Betrifft: AW: Ersatz ? für SVERWEIS
von: Hübi

Geschrieben am: 15.02.2005 10:21:59
Hi Thorsten,
=SVERWEIS(J6;Import!$A$1:$H$1000;VERGLEICH($I$2;Import!$A$1:$H$1;0);FALSCH)
Der Parameter FALSCH oder 0 sucht nach genauer Übereinstimmung. Wird diese nicht gefunden, gibt es #NV (musst du mit =wenn(ISTNV(SVERWEIS(J6;Import!$A$1:$H$1000;VERGLEICH($I$2;Import!$A$1:$H$1;0);FALSCH));"";SVERWEIS(J6;Import!$A$1:$H$1000;VERGLEICH($I$2;Import!$A$1:$H$1;0);FALSCH)) ausblenden)
Gruß Hübi
Bild

Betrifft: AW: Ersatz ? für SVERWEIS
von: o.T. - Besten Dank - funktioniert
Geschrieben am: 15.02.2005 10:28:09
o.T.
Bild

Betrifft: Danke für die Antwort - erledigt o.T.
von: Hübi
Geschrieben am: 15.02.2005 16:37:58
 Bild
Excel-Beispiele zum Thema "Ersatz ? für SVERWEIS"
SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Arbeitszeittabelle und SVERWEIS-Formel Zugriff über SVERWEIS() auf eine Artikelliste
SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen
Hyperlinks zu SVERWEIS-Bezugstabellen anlegen SVERWEIS als Ereignisprozedur