Array Formel Platzhalter

Bild

Betrifft: Array Formel Platzhalter von: Hartmut_M
Geschrieben am: 16.02.2005 17:40:24

Hallo, gibt es eine Möglichkeit in einer Array Formel einen Platzhalter zu benutzen.

Ich möchte z. B. Müller zählen, aber auch Müllerei.
Also würde ich angeben Müller*. Aber * geht nicht in Array.

Freue mich über jeden Tipp.

Gruß Hartmut

Bild


Betrifft: nur zählen ? von: ransi
Geschrieben am: 16.02.2005 18:04:33

hallo hartmut

wenn du nur zählen willst, gehts auch ohne array
 
 AB
1Müller7
2Müllerei 
3Müllera 
4müllerb 
5müllerc 
6müllerd 
7müllere 
Formeln der Tabelle
B1 : =ZÄHLENWENN(A1:A100;"müller*")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


Bild


Betrifft: Nicht nur zählen von: HArtmut_M
Geschrieben am: 16.02.2005 18:07:34

Hallo, ich möchte nicht nur eine Spalte zählen. Das zählen geht über mehrere Spalten mit unterschiedlichen Inhalten. Dweshalb die Array.
Gibt es da eine Lösung?
Hartmut


Bild


Betrifft: AW: Nicht nur zählen von: ransi
Geschrieben am: 16.02.2005 18:12:48

hallo hartmut

Ich bin nicht sicher ob ich dich richtig verstanden habe, aber zählenwenn()
kann auch mehrere spalten.

=ZÄHLENWENN(A:D;"müller*")
wenn es auch das nicht ist, kann ich dir ohne beispiel nicht weiterhelfen.

ransi


Bild


Betrifft: Wer kann helfen? von: Hartmut_M
Geschrieben am: 16.02.2005 18:19:59

Hallo ransi, ich brauche tatsächlich die Array Formel, da mehrere Spalten miteinander verglichen werden müssen.

Kann mir evtl. doch noch jemand weiterhelfen? Gibt es eine Möglichkeit in einer Array Formel einen Platzhalter zu setzen?

Danke im Voraus.
Hartmut


Bild


Betrifft: AW: Array Formel Platzhalter von: HermannZ
Geschrieben am: 16.02.2005 18:31:20

Hallo Hartmut,

meinst du so etwas???
Beispiel;

A1
 ABCDE
341   ges. NameErgebniss
342MüllerMülleimerEin MüllerMüller13
343MüllereiEin MüllerMüller  
344MüllermeisterMüllerMüllerei  
345MülleimerMüllereiMülleimer  
346Ein MüllerMüllermeisterMüllermeister  
347einermeinerMüllereinermeinermüller   
348     
Formeln der Tabelle
E342 : {=SUMME(WENN(ISTFEHLER((FINDEN(D342;A342:C347)>=1)*1);0;1))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


die Formel unterscheidet auch gross und kleinschreibung.

Gruß Hermann


Bild


Betrifft: AW: Array Formel Platzhalter von: Hartmut_M
Geschrieben am: 16.02.2005 18:58:22

Hallo Hermann, danke für den Hinweis. Habe auch schon in der Recherche die Sache mit dem "istfehler" gefunden. Scheint dann wohl die einzige Möglichkeit zu sein.
Schönen Abend noch.
Gruß Hartmut


Bild


Betrifft: AW: falsch ! von: FP
Geschrieben am: 16.02.2005 22:00:49

Hi Hermann,

Tabelle3
 ABCDE
1   ges. NameErgebnis
2MüllerMülleimerEin MüllerMüller14
3MüllereiEin MüllerMüller  
4MüllermeisterMüllerMüllerei  
5MülleimerMüllereiMülleimer  
6Ein MüllerMüllermeisterMüllermeister  
7einermeinerMüllereinermeinermüller   
Formeln der Tabelle
E2 : =ZÄHLENWENN(A2:C7;"*"&D2&"*")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: falsch ! von: HermannZ
Geschrieben am: 17.02.2005 11:52:20

Hallo FP,

kann ich nicht nachvollziehen, ich habe daraufhingewiesen das gross und keinschreibung unterschieden wird und dann ist das ergebniss 13 und nicht wie bei dir 14.

Gruß hermann


Bild


Betrifft: AW: richtig von: FP
Geschrieben am: 17.02.2005 20:35:27

Hi Hermann,

habe Deinen Nachsatz überlesen ;-)

Ob er das allerdings so will, muss der Fragesteller entscheiden.

Servus aus dem Salzkammergut
Franz


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Array Formel Platzhalter"