Tabellen vergleichen

Bild

Betrifft: Tabellen vergleichen
von: Eddi40
Geschrieben am: 22.02.2005 16:34:16
Hab nun ein echtes Problem da ich mich in Excel recht wenig auskenne. Aufgabenstellung: Tabelle A enthält Daten welche ich mit Tabelle B abgleichen soll. Spalte A enthält Auftragsnummern. Anhand dieser soll ich nun feststellen welche Nummern identisch sind und diese dann in Tabelle C darstellen.
Kann mir jemand helfen ? Bräuchte dies dringend. Danke im voraus

Bild

Betrifft: AW: in der Recherche stehts
von: Recherche
Geschrieben am: 22.02.2005 16:36:55
Hi Eddi
bemühe mal die Recherche, Dutzende Beispiele!
gruss
Bild

Betrifft: AW: Tabellen vergleichen
von: Anton
Geschrieben am: 22.02.2005 17:38:23
Hallo Eddi40
versuch's mal damit....
Bei mir vergleicht das tool Dateien, die ich vorher aus zwei verschiedenen Verzeichnissen hole.
Ich hoffe Du blickst da durch.
Servus,
Anton

Sub Dateien vergleichen()
 
 'Vorbereiten des Vergleichs-Blatt
 'Setzen der Überschriften
 Sheets("Tabelle3").Select
 Range("C1").Select
 ActiveCell.FormulaR1C1 = "hier wird nach Dateien Gesucht"
 Range("A1").Select
 ActiveCell.FormulaR1C1 = "nach diesen Dateien wird gesucht"
 Range("B1").Select
 ActiveCell.FormulaR1C1 = "OK?"
 Range("E1").Select
 ActiveCell.FormulaR1C1 = "Fundstücke"
 Rows("1:1").Select
 Selection.Font.Bold = True
 
 'Holen der gefundenen Server-Dateien von Tabelle1
 Sheets("Tabelle1").Select
 Range("B1:B10000").Select
 Selection.Copy
 Sheets("Tabelle3").Select
 Range("C2").Select
 ActiveSheet.Paste
 
 'Holen der der gebookmarkten Dateien von Tabelle2
 Sheets("Tabelle2").Select
 Range("B1:B10000").Select
 Selection.Copy
 Sheets("Tabelle3").Select
 Range("A2").Select
 ActiveSheet.Paste
 
 'einfügen der Vergleichs-Formel
 '=SVERWEIS(A2;C:C;1;FALSCH)
    Range("E2").Select
    ActiveCell.FormulaR1C1 = "=VLOOKUP(RC[-4],C[-2],1,FALSE)"
    Range("E2").Select
    Selection.AutoFill Destination:=Range("E2:E10000"), Type:=xlFillDefault
    Range("E2:E10000").Select
 
 'einfügen der Gefunden-Formel
 '=WENN(ISTLEER(A2);" ";WENN(ISTFEHLER(E2);"<= nix da";"<= gefunden"))
    Range("B2").Select
    ActiveCell.FormulaR1C1 = _
        "=IF(ISBLANK(RC[-1]),"" "",IF(ISERROR(RC[3]),""<= nix da"",""<= gefunden""))"
    Range("B2").Select
    Selection.AutoFill Destination:=Range("B2:B10000"), Type:=xlFillDefault
    Range("B2:B10000").Select
    
   
End Sub

Bild

Betrifft: AW: Tabellen vergleichen
von: Eddi40
Geschrieben am: 22.02.2005 17:59:21
Hallo Anton, Du bist ein Ass ;-) das ist schon fast genau das was ich brauche.
Die Auftragsnummern stehen im A1. Jetzt hab ich nur noch ein Problem. Ich müsste die Daten die Dein Script findet (also in meinem Fall die Daten aus Tabelle2) komplett
in ein Excelblatt kopieren. Wie kann ich das bewerkstelligen ? Also mit allen Spalten aus dieser Tabelle2. Wenn Du mir hier noch weiterhelfen könntest wäre das echt Super.
Bild

Betrifft: AW: Tabellen vergleichen
von: Anton
Geschrieben am: 23.02.2005 09:14:59
Hallo Eddi40,
Hab' gestern nicht mehr reingeschaut...
Möchtest Dein Ergebnis auch gleich speichern,
dann probier das hier mal.
Servus,
Anton

Sub Seite_speichern()
  Sheets("Tabelle3").Select   'erstmal zur Ergebnis-Seite
    Cells.Select              'alle Zellen markieren
    Selection.Copy            'Markierung kopieren
    Workbooks.Add             'neue Excel-Datei
    ActiveSheet.Paste         'Kopie einsetzen
    Application.CutCopyMode = False 'Klemmbrett löschen
    Application.Dialogs(xlDialogSaveAs).Show    'Speichern-Unter-Dialog anzeigen
    
End Sub

Bild

Betrifft: AW: Tabellen vergleichen
von: Eddi40
Geschrieben am: 23.02.2005 09:48:38
Hallo Anton...danke danke danke...das funzt...finde es klasse das es diese Foren und Leute wie Dich gibt die einem weiterhelfen.
Viele Grüße
Bild

Betrifft: AW: Tabellen vergleichen
von: Anton
Geschrieben am: 23.02.2005 10:08:46
Hallo Eddi40,
ich bin nur ein kleines Licht.
Wenn Du Dich hier ein wenig umschaust, findest Du gute Sachen der Vollprofies.
Rainer Ramses oder Udo Richter oder Marcus Willms haben tolle Sachen auf ihren Hompages.
Auch Werner Oertli ist ein guter Mann den Du überall findest.
Servus,
Anton
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabellen vergleichen"