Lieferanten zählen?

Bild

Betrifft: Lieferanten zählen? von: Roman
Geschrieben am: 25.02.2005 14:47:56

Hallo,

habe in der Spalte A Liefernatennamen stehen. Diese wiederholen sich zum Teil bis fünfmal "hintereinander". Suche eine Formel um zu zählen wieviele Liefenrante dort stehen?

Gruß
Roman

Bild


Betrifft: AW: Lieferanten zählen? von: Ulf
Geschrieben am: 25.02.2005 14:52:42

Sieh dir ZÄHLENWENN() an.

Ulf


Bild


Betrifft: AW: Lieferanten zählen? von: HermannZ
Geschrieben am: 25.02.2005 14:53:05

Hallo Roman,

suchst du so was ????

Beispiel;

A1
 ABCDEF
100      
101Wie oft kommt ein Name vor?     
102      
103Name ohne DoppelteErgebnissnur doppelteErgebniss
104Thomas Thomas2Thomas2
105Reiner Reiner3Reiner3
106Klaus Klaus2Klaus2
107Thomas Werner1  
108Reiner     
109Werner     
110Klaus     
111Reiner     
112  Formel jeweils nach unter kopieren   
113      
Formeln der Tabelle
C104 : {=WENN(SUMME(WENN(A$104:A$111="";0;1/ZÄHLENWENN(A$104:A$111;A$104:A$111))) < ZEILE(A1);"";INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$104;;;ZEILE($1:$8));A$104:A$111)=1;ZEILE($104:$111));ZEILE(A1))))}
D104 : =WENN(C104="";"";ZÄHLENWENN($A$104:A111;C104))
E104 : {=WENN(SUMME(WENN(A$104:A$111="";0;1/ZÄHLENWENN(A$104:A$111;A$104:A$111))) > ZEILE(A1);INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$104;;;ZEILE($1:$8));A$104:A$111)=1;ZEILE($104:$111));ZEILE(A1)));"")}
F104 : =WENN(E104="";"";ZÄHLENWENN($A$104:A111;E104))

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: Lieferanten zählen? von: Roman
Geschrieben am: 25.02.2005 14:56:13

nee, ist eigentlich einfacher,

Lieferant1
Lieferant1
Lieferant1
Lieferant4
Lieferant4
Lieferant5
Lieferant5
usw.

ich möchte gerne, das Ergebniss 3 Er soll Liefernate 1 nur einmal und die anderen auch nur einmal zählen. Keine Wiederholungen.

Gruß
Roman


Bild


Betrifft: http://www.excelformeln.de/formeln.html?welcher=42 von: Martin Beck
Geschrieben am: 25.02.2005 15:02:47




Bild


Betrifft: AW: http://www.excelformeln.de/formeln.html?welcher=42 von: Roman
Geschrieben am: 25.02.2005 15:08:44

super herzlichen Dank,

ging einwandfrei!!!

Gruß
Roman


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Lieferanten zählen?"