Funktion gesucht !!!

Bild

Betrifft: Funktion gesucht !!! von: Opitz
Geschrieben am: 08.03.2005 19:04:48

Hy!


Ich habe in Zelle A1 bis A31 die Tage im Format "TT" und in Zelle B1 bis B31 kann man über Datengültigkeit als dropdown zwischen "y" oder "a" wählen.


Ich möchte nun Zelle D1 bis D31 die Tage aus A1 bis A31 sortiert ohne Leerzeilen auflisten welchein B1 bis B31 "y" enthalten.


Mir qualmt der Schädel !!!


Mfg

Kay

Bild


Betrifft: AW: Funktion gesucht !!! von: serge
Geschrieben am: 08.03.2005 19:16:54

hi kay
siehe mein vorschlag an
serge
https://www.herber.de/bbs/user/19371.xls


Bild


Betrifft: AW: Funktion gesucht !!! von: HermannZ
Geschrieben am: 08.03.2005 19:22:09

Hallo Kay,

meinst du das so??

Beispiel;

TestAlt
 ABCD
149    
150  ges. Kennung 
15101.01.2005xy02.01.2005
15202.01.2005y 04.01.2005
15303.01.2005x 05.01.2005
15404.01.2005y 07.01.2005
15505.01.2005y 08.01.2005
15606.01.2005x 10.01.2005
15707.01.2005y  
15808.01.2005y  
15909.01.2005x  
16010.01.2005y  
161    
Formeln der Tabelle
D151 : {=WENN(ZEILE(B1:B1)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B1)))}
D152 : {=WENN(ZEILE(B2:B2)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B2)))}
D153 : {=WENN(ZEILE(B3:B3)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B3)))}
D154 : {=WENN(ZEILE(B4:B4)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B4)))}
C155 : {=WENN(ZEILE(A5:A5)>ZÄHLENWENN($B$151:B164;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A5)))}
D155 : {=WENN(ZEILE(B5:B5)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B5)))}
C156 : {=WENN(ZEILE(A6:A6)>ZÄHLENWENN($B$151:B165;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A6)))}
D156 : {=WENN(ZEILE(B6:B6)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B6)))}
C157 : {=WENN(ZEILE(A7:A7)>ZÄHLENWENN($B$151:B166;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A7)))}
D157 : {=WENN(ZEILE(B7:B7)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B7)))}
C158 : {=WENN(ZEILE(A8:A8)>ZÄHLENWENN($B$151:B167;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A8)))}
D158 : {=WENN(ZEILE(B8:B8)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B8)))}
C159 : {=WENN(ZEILE(A9:A9)>ZÄHLENWENN($B$151:B168;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A9)))}
D159 : {=WENN(ZEILE(B9:B9)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B9)))}
C160 : {=WENN(ZEILE(A10:A10)>ZÄHLENWENN($B$151:B169;"x");"";KKLEINSTE(WENN($B$151:$B$160="x";$A$151:$A$160);ZEILE(A10)))}
D160 : {=WENN(ZEILE(B10:B10)>ZÄHLENWENN($B$151:$C$160;$C$151)-1;"";KKLEINSTE(WENN($B$151:$B$160=$C$151;$A$151:$A$160);ZEILE(B10)))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Funktion gesucht !!!"