Datenbank

Bild

Betrifft: Datenbank
von: Jens Bubba
Geschrieben am: 18.03.2005 10:12:34
Hallo,
ich versuche gerade eine ganz simple Datenbankfunktion zu erstellen, nämlich über DBAUSZUG. Ich will aus einem Datensatz:
Name Zahl
A 1
B 2
C 3
...
den jeweiligen Eintrage des Fehldes "Zahl" erhalten
Name Zahl
C ??
A ??
Für C ist das kein Problem, aber sobald ich mich auf mehr als einen Namenwert beziehe kommt der Fehler #Zahl (vgl. EXCEL-SHEET).

Vielen Dank für die Hilfe.

Bild

Betrifft: AW: Datenbank
von: Jens Bubba
Geschrieben am: 18.03.2005 10:13:53
Das hier ist das Sheet
https://www.herber.de/bbs/user/19824.xls
Bild

Betrifft: AW: Datenbank
von: Heinz Ulm
Geschrieben am: 18.03.2005 10:42:36
Hallo Jens,
dein Ansatz scheint falsch zu sein, schau mal hier:
Tabelle3
 ABCD
1KSTBereich  
2110  
3211  
4312  
5413  
6514  
7    
8KSTBereich  
9514<- Hier will ich die Werte 
10    
11KSTBereich  
12413<- Hier will ich die Werte 
13    
14KSTBereich  
15312<- Hier will ich die Werte 
16    
17KSTBereich  
18211<- Hier will ich die Werte 
19    
20KSTBereich  
21110<- Hier will ich die Werte 
22    
Formeln der Tabelle
B9 : =DBAUSZUG($A$1:$B$6;"bereich";$A$8:A9)
B12 : =DBAUSZUG($A$1:$B$6;"bereich";$A$11:A12)
B15 : =DBAUSZUG($A$1:$B$6;"bereich";$A$14:A15)
B18 : =DBAUSZUG($A$1:$B$6;"bereich";$A$17:A18)
B21 : =DBAUSZUG($A$1:$B$6;"bereich";$A$20:A21)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Aus der Hilfe:
Hinweise
Stimmt kein Datensatz mit den Suchkriterien überein, gibt DBAUSZUG den Fehlerwert #WERT! zurück.
Stimmt mehr als ein Datensatz mit den Suchkriterien überein, gibt DBAUSZUG den Fehlerwert #ZAHL! zurück.
Das war bei deinem Ansatz ja so, es stimmten mehrere Datensätze mit dem Suchkriterium überein.
Gruß Heinz
Bild

Betrifft: AW: Datenbank
von: Jens Bubba
Geschrieben am: 18.03.2005 10:57:23
Genau hier liegt das Problem, ich hatte es auch schon so wie Du gemacht, aber ich finde es einfach umständlich jedes mal KST über den jeweiligen Wert zu schreiben.
Ist die Abfrage auch möglich, ohne die Überschrift KST jedes mal zu setzen ??
Bild

Betrifft: AW: Datenbank
von: Heinz Ulm
Geschrieben am: 18.03.2005 11:13:30
Hallo Jens,
aus diesem Grund mag ich die DB-Funktionen nicht.
Ich lasse mir viel lieber die Werte per Sverweis auslesen, so etwa:
Tabelle3
 AB
1KSTBereich
2110
3211
4312
5413
6514
7  
8  
9  
10KSTBereich
11514
12413
13312
14211
15110
Formeln der Tabelle
B11 : =SVERWEIS(A11;$A$2:$B$6;2;0)
B12 : =SVERWEIS(A12;$A$2:$B$6;2;0)
B13 : =SVERWEIS(A13;$A$2:$B$6;2;0)
B14 : =SVERWEIS(A14;$A$2:$B$6;2;0)
B15 : =SVERWEIS(A15;$A$2:$B$6;2;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
Bild

Betrifft: AW: Datenbank
von: Jens Bubba
Geschrieben am: 18.03.2005 12:51:18
Eigentlich schade, muss dann halt wohl doch SVERWEIS verwenden.
Trotzdem danke !!
Bild

Betrifft: AW: Datenbank
von: Heinz Ulm
Geschrieben am: 18.03.2005 23:02:37
Hallo Jens,
schau die mal das an,
vielleicht ist Summenprodukt auch eine Lösung.
Tabelle1
 ABCDE
1KSTBereich   
2110   
3211   
4312   
5413   
6114   
7     
8KSTBereich   
950<- Hier will ich die Werte  
10413<- Hier will ich die Werte  
11312<- Hier will ich die Werte  
12211<- Hier will ich die Werte  
13124<- Hier will ich die Werte  
Formeln der Tabelle
B9 : =SUMMENPRODUKT(($A$2:$A$6=A9)*($B$2:$B$6))
B10 : =SUMMENPRODUKT(($A$2:$A$6=A10)*($B$2:$B$6))
B11 : =SUMMENPRODUKT(($A$2:$A$6=A11)*($B$2:$B$6))
B12 : =SUMMENPRODUKT(($A$2:$A$6=A12)*($B$2:$B$6))
B13 : =SUMMENPRODUKT(($A$2:$A$6=A13)*($B$2:$B$6))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datenbank"