zuordnung auf aktuelle zelle ???

Bild

Betrifft: zuordnung auf aktuelle zelle ???
von: wolfgang
Geschrieben am: 20.03.2005 19:22:49
´hätte da eine frage an alle excel-profis :
ich habe in einer buchhaltungs-excel-liste die zuordnung von codes in einer spalte, (erzwungene auswahl erfolgt über /gültigkeit/auswahl aus liste...),
in einer anderen zelle soll die einblendung von zugeordneten erklärungs-text zu diesen codes erfolgen - habe ich gelöst mit /sverweis - und funktioniert,wenn ich auf eine zelle bezug nehme -
wie schaffe ich es aber, daß dabei immer nur die aktuelle zelle (wo der cursor steht bzw. wo die letzte eingabe erfolgt ist ! ) angezeigt wird ??

z.b. / derzeit :
=SVERWEIS(H12;R!B4:C58;2;1)

... statt H12 soll immer die "aktuelle" zelle der spalte H angezeigt werden...

vielleicht hastata einer eine antwort -
danke im voraus -

lg aus österreich

wolfgang

Bild

Betrifft: AW: zuordnung auf aktuelle zelle ???
von: Jörg Gradert
Geschrieben am: 20.03.2005 21:06:17
Hallo Wolfgang,
Rechsklick auf den Tabellenblattnamen, Code anzeigen...
Folgenden Code einfügen

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Range("A1").Value = ActiveCell.Row
End Sub

VBA Editor schliessen.
Formel ändern in
=SVERWEIS(INDEX(H:H;A1);R!B4:C58;2;1)
A1 steht stellvertretend für eine beliebige leere Zelle in deiner Tabelle.
Der Code und die Formel muß diesbezüglich an deine Bedürfnisse angepaßt werden.
Gruß Jörg
Bild

Betrifft: AW: zuordnung auf aktuelle zelle ???
von: wolfgang
Geschrieben am: 21.03.2005 08:16:05
danke - probier´s gleich aus.....
 Bild

Beiträge aus den Excel-Beispielen zum Thema "zuordnung auf aktuelle zelle ???"