#WERT bei SUMMENPRODUKT vermeiden

Bild

Betrifft: #WERT bei SUMMENPRODUKT vermeiden
von: Micha.hal
Geschrieben am: 23.03.2005 15:30:10
Hallo Excelperten,
ich habe mit´s Forums Hilfe (nochmal Danke Ingo) eine Formel (SUMMENPRODUKT)erstellen lassen, die mir die letzten 3 Werte einer Zeile addiert.
https://www.herber.de/bbs/user/20088.xls
Nun tritt aber das #WERT Problem auf. Wenn ich mir die Werte über eine WENN-Formel aus einer anderen Tabelle =wenn(zelle="";"";zelle) hole. Sobald eine Quellzelle leer ist und dadurch die Zielzelle, die ich mit meiner SUMMENPRODUKT-Formel abfrage, ebenfalls "leer", erhalte ich den #WERT-Fehler.
Ich könnte das Problem umgehen, indem ich die WENN-Formel so ändere: =wenn(zelle="";0;zelle). Dann ändert sich aber das Ergebnis der SUMMENPRODUKT-Formel.
Wie kann ich das umgehen?
Danke.
Micha

Bild

Betrifft: AW: #WERT bei SUMMENPRODUKT vermeiden
von: c0bRa
Geschrieben am: 23.03.2005 15:32:02
hallo...
=wenn(istfehler(deineformel);"";deineformel)
haut dir alle fehler raus...

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: #WERT bei SUMMENPRODUKT vermeiden
von: Micha.hal
Geschrieben am: 24.03.2005 08:34:06
Leider nicht. Denn wenn die "Leerzellen" nicht wären, würde ja ein Ergebnis ausgegeben werden (siehe dazu die Tabelle https://www.herber.de/bbs/user/20088.xls )
Ich kann also nicht die ganze Formel (SUMMENPRODUKT) mit ISTFEHLER abfangen.
Bild

Betrifft: AW: #WERT bei SUMMENPRODUKT vermeiden
von: c0bRa
Geschrieben am: 24.03.2005 08:54:49
nach anfangsschwierigkeiten hab ich deine formel angepasst ;)
{=SUMMENPRODUKT(WENN($B8:$K8="";0;$B8:$K8)*(SPALTE($B8:$K8)>=KGRÖSSTE(SPALTE($B8:$K8)*($B8:$K8<>"");3)))}
siehe auch: https://www.herber.de/bbs/user/20111.xls
Achtung Matrixformel!!! Umrandende {} nicht mit eingeben, sondern mit Strg+Shift+Enter abschliessen!

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: #WERT bei SUMMENPRODUKT vermeiden
von: Micha.hal
Geschrieben am: 24.03.2005 15:28:42
Genial. Jetzt ist es perfekt.
Danke und ein schönes Osterfest wünsche ich.
Micha
 Bild

Beiträge aus den Excel-Beispielen zum Thema "problem mit sverweis"