SVERWEIS?

Bild

Betrifft: SVERWEIS?
von: Erich M.
Geschrieben am: 25.03.2005 09:43:07
Hallo EXCEL-Freunde,
wie kann ich Sortierung erreichen:

Kurzübersicht (2)
 ABCDEFGHIJK
1KombiArtCDE SORTIERT    
22012Test1Test1AntonHuber12012 2009Test5#NV#NV#NV#NV
32013Test2Test2BertaHuber22013 2011Test3Test3CäsarHuber32011
42011Test3Test3CäsarHuber32011 2012Test1Test5EmilHuber52009
52015Test4Test4DavidHuber42015 2013Test2Test5EmilHuber52009
62009Test5Test5EmilHuber52009 2015Test4Test5EmilHuber52009
Formeln der Tabelle
A2 : =+E2&B2
G2 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A2));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H2 : =SVERWEIS($G2;$A:$F;2)
I2 : =SVERWEIS($G2;$A:$F;3)
J2 : =SVERWEIS($G2;$A:$F;4)
K2 : =SVERWEIS($G2;$A:$F;5)
A3 : =+E3&B3
G3 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A3));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H3 : =SVERWEIS($G3;$A:$F;2)
I3 : =SVERWEIS($G3;$A:$F;3)
J3 : =SVERWEIS($G3;$A:$F;4)
K3 : =SVERWEIS($G3;$A:$F;5)
A4 : =+E4&B4
G4 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A4));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H4 : =SVERWEIS($G4;$A:$F;2)
I4 : =SVERWEIS($G4;$A:$F;3)
J4 : =SVERWEIS($G4;$A:$F;4)
K4 : =SVERWEIS($G4;$A:$F;5)
A5 : =+E5&B5
G5 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A5));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H5 : =SVERWEIS($G5;$A:$F;2)
I5 : =SVERWEIS($G5;$A:$F;3)
J5 : =SVERWEIS($G5;$A:$F;4)
K5 : =SVERWEIS($G5;$A:$F;5)
A6 : =+E6&B6
G6 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A6));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H6 : =SVERWEIS($G6;$A:$F;2)
I6 : =SVERWEIS($G6;$A:$F;3)
J6 : =SVERWEIS($G6;$A:$F;4)
K6 : =SVERWEIS($G6;$A:$F;5)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Die Spalten A bis E sind die Ausgangsdaten.
Da sich die Daten immer wieder ändern können, suche ich Formeln, die
in separaten Spalten die Sortierung automatisch bei Änderungen vornehemn.
Die Spalte E enthält die Jahre, die über die Hilfsspalte G aufsteigend
sortiert werden.
Jetzt soll über SVERWEIS (oder...?) in den Spalten H bis K die dazugehörige
Übertragung aus den spalten B bis E vorgenommen werden.
Wie könnte das funktionieren?
Besten Dank für eine Hilfe!
mfg
Erich
http://www.toolex.de
Bild

Betrifft: AW: SVERWEIS?
von: Martin Beck
Geschrieben am: 25.03.2005 11:23:11
Hallo Erich,
nicht ganz klar. Willst Du in G nach Spalte A oder E sortieren? So sollte es funktionieren:
In G2 folgende Formel und nach unten kopieren:
=KKLEINSTE($A$2:$A$6;ZEILE()-1)
Wenn Du nach Spalte A sortierst, kannst Du SVERWEIS für H:K verwenden, wenn Du nach Spalte E sortierst, suche mal auf www.excelformeln.de nach "Sverweis nach links".
Gruß
Martin Beck
Bild

Betrifft: AW: SVERWEIS?
von: Erich M.
Geschrieben am: 25.03.2005 11:35:15
Hallo Martin,
danke zunächst; war vielleicht missverständlich.
Deine Formel funktioniert für Sortierung der Spalte A nicht, weil Buchstaben dabei
sind und nicht nur Zahlen; deshalb meine Formel in Spalte G.
Ab Spalte H - K sollen jetzt in abhängigkeit von Spalte G die zur gleichen Zeile
gehörenden Daten aus B - E übertragen werden.
Die Zeile 2 müsste so aussehen:
Kurzübersicht (2)
 GHIJK
1SORTIERT    
22009Test5Test5EmilHuber52009
Formeln der Tabelle
G2 : {=INDEX($A$2:$A$6;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);ZEILEN(A$2:A2));ZÄHLENWENN(A$2:A$6;"<"&A$2:A$6);0))}
H2 : =+B6
I2 : =+C6
J2 : =+D6
K2 : =+E6
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Besten Dank nochmal!
mfg
Erich
http://www.toolex.de
Bild

Betrifft: AW: SVERWEIS?
von: HermannZ
Geschrieben am: 25.03.2005 11:32:07
Hallo Erich,
ein Beispiel;
TestNeu
 ABCDEFGHIJ
114     Sortiert    
1152012Test1Test1AntonHuber120122009Test5Test5EmilHuber52009
1162013Test2Test2BertaHuber220132011Test3Test3CäsarHuber32011
1172011Test3Test3CäsarHuber320112012Test1Test1AntonHuber12012
1182015Test4Test4DavidHuber420152013Test2Test2BertaHuber22013
1192009Test5Test5EmilHuber520092015Test4Test4DavidHuber42015
120          
121     Formel nach rechts und nach unten kopieren    
Formeln der Tabelle
F115 : =INDEX(A$115:A$119;VERGLEICH(KKLEINSTE($E$115:$E$119;ZEILE(A1));$E$115:$E$119;0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruß hermann
Bild

Betrifft: Danke Hermann - das wars!!
von: Erich M.
Geschrieben am: 25.03.2005 11:37:45
mfg
Erich
http://www.toolex.de
Bild

Betrifft: AW: Danke für die Rückantwort oT.
von: HermannZ
Geschrieben am: 25.03.2005 11:39:23
.
Bild

Betrifft: zu früh gefreut........
von: Erich M.
Geschrieben am: 25.03.2005 11:56:03
Hallo Herrmann,
war zu schnell. Die Formel reicht doch noch nicht. Wenn in Spalte E zweimal das gleiche Jahr
vorkommt gibts Probleme; deswegen die KombiSpalte A wegen genauer Identifizierung der
Zeile.
Insofern muss ich auf meine Antwort an Martin zurückkommen und bitte nochmals um Prüfung.
Besten Dank!
mfg
Erich
http://www.toolex.de
Bild

Betrifft: AW: zu früh gefreut........
von: Martin Beck
Geschrieben am: 25.03.2005 12:11:03
Hallo Erich,
hilft das:
http://www.excelformeln.de/formeln.html?welcher=14
Gruß
Martin Beck
Bild

Betrifft: AW: zu früh gefreut........
von: Erich M.
Geschrieben am: 25.03.2005 14:54:09
Hallo Martin,
leider auch nicht.
mfg
Erich
http://www.toolex.de
Bild

Betrifft: doch noch gelöst:
von: Erich M.
Geschrieben am: 25.03.2005 15:07:51
Spalte H2:
=SVERWEIS(G2;A2:E6;2;0)
Die genaue Definition der Matrix wars!!
mfg
Erich
http://www.toolex.de
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS?"