Herbers Excel-Forum - das Archiv

Rechnen mit Filtern

Bild

Betrifft: Rechnen mit Filtern
von: Jona

Geschrieben am: 29.03.2005 19:33:08
Hallo
Ich habe eine Tabelle (30x200 Zellen). Nun möchte ich gerne einen Faktor berechenen.
Anzahl Einträge mit dem Wert "Name" in der Spalte A / Anzahl Einträge mit dem Wert "Ort" in der Spalte B. In beiden Spalten gibt es auch andere Einträge.
Wie kann ich dies elegant machen (ohne jeweils mit Autofilter nach den Einträgen zu filtern und dann zu berechnen)?
Lieber Gruss & Danke
Jonas
Bild

Betrifft: AW: Rechnen mit Filtern
von: Hajo_Zi

Geschrieben am: 29.03.2005 19:37:17
Hallo Jonas,
benutze mal die Recherche nach Summenprodukt

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: ZÄHLENWENN
von: th.heinrich

Geschrieben am: 29.03.2005 20:24:49
hallo Jonas,
Tabelle1
 ABC
1ab 
2nameort0,5
3kein nameort 
Formeln der Tabelle
C2 : =ZÄHLENWENN(A1:A3;"name")/ZÄHLENWENN(B1:B3;"ort")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
 Bild
Excel-Beispiele zum Thema "Rechnen mit Filtern"
Quersumme berechnen Arbeitsmappe alle 5 Minuten neu berechnen
Wert aus 2. UserForm-ComboBox-Spalte berechnen Mit TextBox-Werten in UserForm rechnen
Portokosten aus einer Gewichts-/Gebietsmatrix errechnen Aktuelle Zeit über UserForm eintragen und Rennzeit berechnen
Verbleibende Nettoarbeitstage des Monats berechnen Zeitdifferenz in Schulstunden (45 Minuten) errechnen
Schulnote anhand einer Punktetabelle errechnen Modalwert einer gefilterten Reihe berechnen