Herbers Excel-Forum - das Archiv

Suchen innerhalb eines Intervalls

Bild

Betrifft: Suchen innerhalb eines Intervalls
von: Alexander

Geschrieben am: 30.03.2005 10:12:52
hallo zusammen,
ich habe folgendes problem:
ich habe ein 20stufiges intervall und brauche für jede beliebige zahl innerhalb dieser intervallstufen die ausgabe der nummer des intervalls.
beispiel:
1 100 bis 200
2 201 bis 300
3 301 bis 400 usw.
kann mir da jemand helfen?
danke
alex
Bild

Betrifft: wie wärs mit sverweis?
von: c0bRa
Geschrieben am: 30.03.2005 10:21:03
hallo...
sverweis(a1;hilfsmatrix;2;1)
und als hilfsmatrix legste dir sowas an:
100 1
201 2
301 3
401 4
.
.
.

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: Suchen innerhalb eines Intervalls
von: ANdreas
Geschrieben am: 30.03.2005 10:25:17
Hallo Alex,
wenn Du solche Intervalle hast, die gleich groß sind bzw. mathematisch einfach berechenbar sind, kannst Du es auch mit einer Formel lösen:
=WENN(A1>=100;MAX(1;KÜRZEN((A1-1)/100));"")
Hoffe das hilft weiter,
Andreas
Bild

Betrifft: AW: Suchen innerhalb eines Intervalls
von: alexander
Geschrieben am: 30.03.2005 10:38:36
danke für die schnelle antwort-leider sind die intervalle nicht gleich gross!
alex
Bild

Betrifft: AW: Suchen innerhalb eines Intervalls
von: ANdreas
Geschrieben am: 30.03.2005 10:56:15
Hallo Alex,
schau Dir die Lösung mit Hilfe SVERWEIS von cobra an, diese ist so flexibel und erlaubt die Abfrage nach frei definierten Intervallen.
Gruß
Andreas
 Bild
Excel-Beispiele zum Thema "Suchen innerhalb eines Intervalls"
Zellinhalt suchen und Zelle auswählen Suchbegriff über mehrere Tabellenblätter suchen.
Suchen und weitersuchen Zahl +/- 1 suchen
Ein Zeichen in einer Formel suchen Datum suchen und Wert eintragen
Wert in Tabelle suchen und in UserForm ausgeben Letzte Zelle mit Inhalt suchen
Textdatei nach Begriff durchsuchen und Fundzeile importieren Wert in Array suchen, ohne jedes Datenfeld abzufragen