Matrixformeln

Bild

Betrifft: Matrixformeln
von: Kalim
Geschrieben am: 21.04.2005 14:56:59
Hi Leute,
versuche eine sog. Bewegungsbilanz zu erstellen. Eine kleine Bsp.Datei habe ich beigefügt. Schon die Summenformel in tab3 habe ich leider nicht hinbekommen. Dazwischen müsste jeweils die Anz der Zeilen, die sich geändert haben. Neu ist Nr. 118 und weggefallen 114. Kann man das irgendwie mit 'ner Matrixformel hinbekommen?
https://www.herber.de/bbs/user/21494.xls
VG, Kalim

Bild

Betrifft: AW: Matrixformeln
von: HermannZ
Geschrieben am: 21.04.2005 20:21:22
Hallo Kalim,
so richtig schlau bin ich daraus nicht geworden,schau dir einmal die Tabelle an vieleicht kannst du ja was damit anfangen.
https://www.herber.de/bbs/user/21525.xls
Gruß Hermann
Bild

Betrifft: AW: Matrixformeln
von: Kalim
Geschrieben am: 22.04.2005 10:18:32
Krasse Formel. Funktioniert aber gut, vielen Dank. Kleines Problem noch: In einem Fall habe ich keine Veränderung in Sp. A zwischen "Ausw1" und "Ausw2". Dann wird die Überschrift aus Sp.A "Ausw1", also Zelle A1, ausgewiesen, obwohl ich doch nur die Bereiche A2:A150 vergleiche. Kann ich das irgendfwie verhindern und dann vielleicht eine "0" ausweisen?
{=""&INDEX(Ausw1!A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(Ausw1!A2:A150;Ausw2!A2:A150;0));ZEILE(2:150);0)>0;ZEILE(2:150)));1})
Auf jeden Fall nochmals herzlichen Dank! Gruß, Kalim
Bild

Betrifft: AW: Matrixformeln
von: Kalim
Geschrieben am: 22.04.2005 10:22:07
Weitere Frage: Wenn sich zwei oder mehr Werte geändert haben, wie kann ich diese ausweisen? Gruß, Kalim
Bild

Betrifft: AW: Matrixformeln
von: HermannZ
Geschrieben am: 22.04.2005 10:38:48
Hallo Kalim,
zu dem Problem wenn keine Änderung vorhanden, kannst du die Formel wie folgt ändern.
=WENN(INDEX(A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(A4:A15;Tabelle2!A4:A15;0));ZEILE(4:15);0)>0;ZEILE(4:15)));1)=0;"Liste Identisch";"Nr.: "&INDEX(A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(A4:A15;Tabelle2!A4:A15;0));ZEILE(4:15);0)>0;ZEILE(4:15)));1))
wenn keine veränderung wir der Text " Liste Identisch" ausgegeben, kannst aber auch an
dieser stelle zum Beispiel eine Null eingeben.
zu dem anderen muss ich erst einmal nachsehen und mir deine Vorlage noch mal zur Brust
nehmen.Melde mich wieder.
Gruß hermann
Bild

Betrifft: AW: Matrixformeln
von: HermannZ
Geschrieben am: 22.04.2005 11:00:39
Hallo Kalim,
ein Versuch wie wäre es damit???
https://www.herber.de/bbs/user/21554.xls

gruß hermann
Bild

Betrifft: AW: Matrixformeln
von: Kalim
Geschrieben am: 22.04.2005 13:21:57
Hallo Herrmann,
erstmal vielen Dank, das Du Dir so viel Mühe gibtst, mir zu helfen. Mußte gerade zum Chef - Formeln daher erst jetzt bearbeitet.
{=WENN(INDEX(Ausw1!A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(Ausw1!$A$2:$A$150;Ausw2!$A$2:$A$150;0));ZEILE(2:150);0)>0;ZEILE(2:150)));1)>0;WENN(INDEX(Ausw1!A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(Ausw1!$A$2:$A$150;Ausw2!$A2:$A150;0));ZEILE(2:150);0)>0;ZEILE(2:150)));1)=0;"Liste indentisch";"Nr:"&INDEX(Ausw1!A:A;MIN(WENN(WENN(ISTFEHLER(VERGLEICH(Ausw1!$A$2:$A$150;Ausw2!$A$2:$A$150;0));ZEILE(2:150);0)>0;ZEILE(2:150)));1));"Nr:")}
Leider läuft es nicht. Bekomme die Anzeige "#ZAHL!". In Ausw1SpA sind solche Formeln hinterlegt: =Tab15!A68. Könnte es daran liegen? Gruß, Kalim
Bild

Betrifft: AW: Matrixformeln
von: andre
Geschrieben am: 23.04.2005 19:07:01
Hallo Kalim,
teste mal die einzelnen Bestandteile der Formel, da kommst Du sicher zum Fehler. Was sagt denn vom Detektiv die Spur zum Fehler?
Grüße, Andre
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrixformeln"