Martix Formeln (anzahl2)

Bild

Betrifft: Martix Formeln (anzahl2)
von: chris b
Geschrieben am: 25.04.2005 11:53:26
Hallo ExcelProfis,
ich habe mal wieder eine frage zu Matrixformeln.
da ihr mir hier bis jetzt schon immer super geholfen habt versuch ich es einfach einmal.
Ich bin gerade am Experimentieren mit Matrixformeln und wollte eine formel erstellen das habe ich auch gemacht.
{=ANZAHL2(WENN((A1:A10=2);C1:C10))}
In der Tabelle habe ich folgende Daten.
Spalte A
2
2
4
2
3
3
3
4
4
2
4
5
5
und spalte B Parallel dazu irgendein text
fsgdfg
sdfg
sd
fg
sdf
g
sdf
gsdf
g
sdf
sdf
g
sdf
Was ich mit dieses Matrix formel erreichen wollte war eine Anzahl der texte wo in Spalte 1 2 steht.
in dem Beispiel z.b 4
Das ich das ganze auch ganz einfach anders lösen könnte ist klar aber wie geht das mi Matrix ?
Und zum zweiten noch ...
wenn ich z.b in Spalte A nicht zahlen stehen habe sondern datums z.b
2.4.2004
2.3.2004
2.4.2005
2.4.2005
2.4.2003
2.3.2004
2.4.2005

Wie müsste ich da die Formel umbauen das ich z.b auch mit Summe wenn nur die summe erreiche der Werte die in Spalte A vom Monat Februar sind.

Vielen dank schon einmal für eure Hilfe !! besten grüße und schönen Tag Christian

Bild

Betrifft: ANZAHL2 ist hier fehl am Platze...
von: Boris
Geschrieben am: 25.04.2005 12:05:50
Hi Chris,
bezogen auf dein Beispiel entsteht mit der Formel
{=ANZAHL2(WENN(A1:A9=2;C1:C9))}
folgende Matrix:
=ANZAHL2({"fsgdfg";"sdfg";FALSCH;"fg";FALSCH;FALSCH;FALSCH;FALSCH;FALSCH})
In der Hilfe zu ANZAHL2 steht:
Berechnet, wie viele Werte eine Liste von Argumenten enthält. Verwenden Sie ANZAHL2, wenn Sie wissen möchten, wie viele zu einem Bereich oder einer Matrix gehörende Zellen Daten enthalten.
Na ja - und zu Daten zählen auch Wahrheitswerte - wie hier FALSCH.
Richtigerweise nimmst du hier SUMME:
{=SUMME((A1:A13=2)*ISTTEXT(C1:C13))}
oder auch (ohne die { } ): =SUMMENPRODUKT((A1:A13=2)*ISTTEXT(C1:C13))
Zu Frage 2:
{=SUMME((MONAT(A1:A13)=2)*ISTTEXT(C1:C13))}
Grüße Boris
Bild

Betrifft: Natürlich bis Zeile 13:
von: Boris
Geschrieben am: 25.04.2005 12:08:18
Hi Chris,
{=ANZAHL2(WENN(A1:A13=2;C1:C13))}
Und die Matrix dazu:
{=ANZAHL2({"fsgdfg";"sdfg";FALSCH;"fg";FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;"sdf";FALSCH;FALSCH;FALSCH})}
Grüße Boris
Bild

Betrifft: AW: Natürlich bis Zeile 13:
von: chris b
Geschrieben am: 25.04.2005 12:11:33
Hi Boris,danke klappt wunderbar.
beste grüße Chris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Martix Formeln (anzahl2)"