Herbers Excel-Forum - das Archiv

Inkrementierung

Bild

Betrifft: Inkrementierung
von: seckes

Geschrieben am: 13.12.2006 11:26:42
Hi,
ich würde gerne inerhalb einer Wenn-Abfrage
eine Zahl hochzählen!
Hierzu habe ich - zugegeben inspiriert von Java -
folgende formel:
=wenn(B2="";1++;"")
Diese funktioniert natürlich nicht!
Kann mir hierbei jmd. weiterhelfen?
Gruß
Bild

Betrifft: AW: Inkrementierung
von: Andreas Emmert

Geschrieben am: 13.12.2006 11:38:48
Hi seckes,
so vielleicht?
Tabelle1
 AB
1BedingungInkrement
2erfüllt1
3 1
4 1
5 1
6erfüllt2
7 2
8erfüllt3
9 3
Formeln der Tabelle
B2 : =ZÄHLENWENN($A$2:$A2;"erfüllt")
B3 : =ZÄHLENWENN($A$2:$A3;"erfüllt")
B4 : =ZÄHLENWENN($A$2:$A4;"erfüllt")
B5 : =ZÄHLENWENN($A$2:$A5;"erfüllt")
B6 : =ZÄHLENWENN($A$2:$A6;"erfüllt")
B7 : =ZÄHLENWENN($A$2:$A7;"erfüllt")
B8 : =ZÄHLENWENN($A$2:$A8;"erfüllt")
B9 : =ZÄHLENWENN($A$2:$A9;"erfüllt")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Grüße
Andreas
Bild

Betrifft: AW: Inkrementierung
von: Reinhard

Geschrieben am: 13.12.2006 11:40:22
Hi Seckes,
so?:
Tabelle:
[Mappe2]!Tabelle1
│   A   │  B  │
───┼───────┼─────┤
1 │ ab23c │     │
2 │ ab23c │     │
3 │       │   1 │
4 │ ab23c │     │
5 │ ab23c │     │
6 │ ab23c │     │
7 │       │   2 │
8 │ ab23c │     │
9 │ ab23c │     │
10 │ ab23c │     │
11 │       │   3 │
12 │ ab23c │     │
13 │ ab23c │     │
14 │ ab23c │     │
15 │       │   4 │
16 │ ab23c │     │
17 │ ab23c │     │
18 │ ab23c │     │
───┴───────┴─────┘
Benutzte Formeln:
B1 :  =WENN(A1="";ANZAHLLEEREZELLEN($A$1:A1);"")
B2 :  =WENN(A2="";ANZAHLLEEREZELLEN($A$1:A2);"")
B3 :  =WENN(A3="";ANZAHLLEEREZELLEN($A$1:A3);"")
B4 :  =WENN(A4="";ANZAHLLEEREZELLEN($A$1:A4);"")
B5 :  =WENN(A5="";ANZAHLLEEREZELLEN($A$1:A5);"")
B6 :  =WENN(A6="";ANZAHLLEEREZELLEN($A$1:A6);"")
B7 :  =WENN(A7="";ANZAHLLEEREZELLEN($A$1:A7);"")
B8 :  =WENN(A8="";ANZAHLLEEREZELLEN($A$1:A8);"")
B9 :  =WENN(A9="";ANZAHLLEEREZELLEN($A$1:A9);"")
B10:  =WENN(A10="";ANZAHLLEEREZELLEN($A$1:A10);"")
B11:  =WENN(A11="";ANZAHLLEEREZELLEN($A$1:A11);"")
B12:  =WENN(A12="";ANZAHLLEEREZELLEN($A$1:A12);"")
B13:  =WENN(A13="";ANZAHLLEEREZELLEN($A$1:A13);"")
B14:  =WENN(A14="";ANZAHLLEEREZELLEN($A$1:A14);"")
B15:  =WENN(A15="";ANZAHLLEEREZELLEN($A$1:A15);"")
B16:  =WENN(A16="";ANZAHLLEEREZELLEN($A$1:A16);"")
B17:  =WENN(A17="";ANZAHLLEEREZELLEN($A$1:A17);"")
B18:  =WENN(A18="";ANZAHLLEEREZELLEN($A$1:A18);"")

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Inkrementierung
von: seckes
Geschrieben am: 14.12.2006 10:16:08
Hi,
vielen Dank, euch Beiden!
Beide Lösungen funktionieren!
Danke und Gruß!
 Bild