Herbers Excel-Forum - das Archiv

Wochenendmarkierungen

Bild

Betrifft: Wochenendmarkierungen
von: ottgunter@t-online.de

Geschrieben am: 13.12.2006 20:47:06
Hallo
wer kann helfen. Danke schon voraus
Ich möchte gerne Wochenende z.B rot markiert haben.
Bei eingabe Jahr z.B.2007 und eingabe Monat z.B. 1 werden Datum und Wochenenden
ordnungsgemäß eingetragen. Nun möchte ich 2 Schaltflächen anlegen. 1. Wochenenden markieren, 2. Wochenendmarkierung löschen.
Bild

Betrifft: AW: Wochenendmarkierungen
von: Uduuh
Geschrieben am: 13.12.2006 20:58:30
Hallo,
das kannst du mit bedingter Formatierung erledigen.
Gruß aus’m Pott
Udo

Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de
Geschrieben am: 13.12.2006 21:19:25
hallo Uduuh
kann mit deiner antwort nichts anfangen
Bild

Betrifft: AW: Wochenendmarkierungen
von: Reinhard

Geschrieben am: 13.12.2006 21:29:59
Hi Gunter,
dann stimmt der Level aber nich.
Tabelle:
[Mappe1]!Tabelle1
│      A     │  B │
──┼────────────┼────┤
1 │ 07.01.2006 │ Sa │
──┴────────────┴────┘
Benutzte Formeln:
B1:  =A1
Bedingte Formatierung von B1
Formel: =WOCHENTAG(B1)=7
Farbe Rot

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de
Geschrieben am: 13.12.2006 21:25:10
Hier ist meine exelbeispieltabelle

Die Datei https://www.herber.de/bbs/user/38968.xls wurde aus Datenschutzgründen gelöscht

Bild

Betrifft: AW: Wochenendmarkierungen
von: Peter Feustel

Geschrieben am: 13.12.2006 21:47:58
Hallo ottgunter,
mit Makros vielleicht so
https://www.herber.de/bbs/user/38969.xls
Viele Grüße Peter
Eine kurze Nachricht, ob es läuft, wäre nett - danke.
Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de

Geschrieben am: 13.12.2006 21:42:58
Hallo reinhard
danke für den hinweiß
habe aber in jeder zelle eine formel. und die wochenenden sind ja nicht nur
in z.B B1
hier die formel
=WENN(WOCHENTAG(A7;2)=1;"Mo";WENN(WOCHENTAG(A7;2)=2;"Di";WENN(WOCHENTAG(A7;2)=3;"Mi";WENN(WOCHENTAG(A7;2)=4;"Do";WENN(WOCHENTAG(A7;2)=5;"Fr";WENN(WOCHENTAG(A7;2)=6;"Sa";"So"))))))
zellenbereich geht von a7 bis a37
Bild

Betrifft: AW: Wochenendmarkierungen
von: Uduuh

Geschrieben am: 13.12.2006 22:00:44
Hallo,
entschuldige, aber das ist ja der totale Quatsch.
=Text(A7;"TTT")
reicht doch vollkommen aus.
Alternative:
=A7 und Zellformat auf TTT setzen.
Weiter kann ich keinen Zusammenhang zwischen deiner hochgeladenen Tabelle und der Frage feststellen.
Gruß aus’m Pott
Udo

Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de
Geschrieben am: 13.12.2006 22:01:30
Hallo Peter
Bedanke mich ganz recht herzlich, daß ist die lösung
auch danke nochmal an reinard.
bis zum nästen mal
Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de
Geschrieben am: 14.12.2006 11:21:56
Hallo
habe noch ein problem was ich nicht lösen kann
Ich habe in der Tabelle mein problem dargestellt
https://www.herber.de/bbs/user/38986.xls
Bild

Betrifft: AW: Wochenendmarkierungen
von: Rudi Maintaire
Geschrieben am: 14.12.2006 12:09:44
Hallo,
Bereich markieren, Format-Bedingte Formatierung
Formel ist: =ZÄHLENWENN(INDIREKT("Feiertage!$B$3:$B$27");$A7)>0
und Hintergrund auswählen.
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: Wochenendmarkierungen
von: ottgunter@t-online.de
Geschrieben am: 16.12.2006 14:03:35
Hallo
habt recht vielen dank für eure hilfe
es ist ja ein wahnsinn, was Excel alles so kann.
 Bild