Microsoft Excel

Herbers Excel/VBA-Archiv

Gewinnvortrag | Herbers Excel-Forum


Betrifft: Gewinnvortrag von: Ulf
Geschrieben am: 24.11.2009 16:38:55

Hallo,
eine etwas kniffelige Angelegenheit:

Folgende Daten müssen verknüpft werden:

ein Übertrag vom Vorjahr +
10% des diesjährigen Gewinns, aber nur wenn dieser positiv ist,
und der Übertrag aus dem Vorjahr kleiner ist als die Summe aller diesjährigen Ausgaben/2.
Anschließend darf der Wert jedoch auch nicht größer sein als die Summe aller Ausgaben/2.

Beispiel:
Beträgt der Übertrag z.B. 45.000 und die 10 % wären 10.000, die Summe aller Ausgaben/2 jedoch nur 50.000, darf Excel auch nur 5.000 hinzurechnen.

  

Betrifft: =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);0) von: NoNet
Geschrieben am: 24.11.2009 17:04:06

Hallo Ulf,

wenn ich es richtig verstanden habe, dann sollte das so funktionieren :

AB
1
2
3
4
5
6

Funktionen im Tabellenblatt :
Zelle Formel 
B3   =B2*10% 
B6   =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);0) 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: AW: =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);0) von: Ulf
Geschrieben am: 24.11.2009 17:24:09

Super das hat schon mal richtig geholfen! Habe die letzte Null noch durch B1 ersetzt, da die Rückstellungen sich ja nicht auflösen, wenn der Gewinn unter 45000 sinkt.
Was jetzt noch fehlt in der Formel ist die Berücksichtigung der Verminderung der Rückstellung wenn die Ausgaben sinken.

Sinken die Ausgaben/2 z.B. auf 40.000, müssen in B6 auch 10.000 abgezogen werden. Quasi eine Berichtigung der Rückstellungen aus dem Vorjahr.
Hast du da auch eine Idee?

Vielen Dank schon mal vorab.


  

Betrifft: =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);MIN(B1;B4)) von: NoNet
Geschrieben am: 24.11.2009 17:39:53

Hallo Ulf,

ich verstehe zu wenig von dieser Materie, kann daher nur Deinen Beschreibungen folgen.
Meinst Du das etwa so (Berechnung 2) :

AB
1
2
3
4
5
6
7

Funktionen im Tabellenblatt :
Zelle Formel 
B3   =B2*10% 
B6   =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);B1) 
B7   =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);MIN(B1;B4)

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: AW: =WENN(B1<B4;MIN(B1+B3*(B3>0);B4);MIN(B1;B4)) von: Ulf
Geschrieben am: 24.11.2009 18:05:06

Vielen Dank. Genau das wars.

Schöne Woche noch