Microsoft Excel

Herbers Excel/VBA-Archiv

Pivot | Herbers Excel-Forum


Betrifft: Pivot von: dirk0011
Geschrieben am: 11.01.2010 09:17:54

Hallo Zusammen,

habe eine normale Pivot Tabelle. Kann ich neben der Pivot Tabelle eine Spalte einfügen, bei dem mir eine Marge ausgerechnet wird? Wenn ich eine Normale Formel eingebe, die sich auf die Pivot bezieht, rechnet er nur den ersten Wert richtig, beim rest bezieht er sich dauernd auf den falschen wert
Auch wenn ich die Marge vorab in der Ursprungstabelle ausrechne, addiert er mir die Marge in der Pivot nur auf und gibt mir weder Prozentzahl noch ähnliches zurück.
Könnt ihr mir helfen, das ich in einer Pivot eigenständig Formeln einbringen kann oder in einer Spalte neben der Pivot normale Formeln anwenden kann?
Vielen Dank
Gruss
Dirk

  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 09:29:59

Hallo dirk

normalerweise kannst du in der Pivottabelle rechnen, aber dazu müsste man deine Daten(struktur) kennen. Eine Beispieltabelle wäre hier nützlich.

Gruß
David


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 09:59:32

Hallo
hier meine Beispiel Datei

https://www.herber.de/bbs/user/67122.xlsx

Kannst du mir dabei helfen?
Gruss
Dirk


  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 10:06:50

Da ich hier kein Excel 2007 habe, leider nicht.
Speichere die Datei in 2003er Format, falls nicht irgendwelche neuen Funktionen dem entgegenstehen.

Gruß
David


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 10:36:30

hier die Datei im xls Format

https://www.herber.de/bbs/user/67124.xls


  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 10:40:22

Hallo dirk,

sorry, aber ich sehe in deiner Beispieldatei keine Pivottabelle!?

Gruß
David


  

Betrifft: AW: Pivot von: Mike
Geschrieben am: 11.01.2010 11:05:02


Hey David,

so wärs z.B. machbar:

Tabelle1

 ABCDEFGHIJKLMN
1KundeUmsatz 2009Umsatz 2008Kosten 2009Kosten 2008Marge 2009Marge 09Marge 2008Marge 08         
2Gesamt3300107068%223-0    Daten   
3Gesamt5'0296'8142'7864'68845%224331%2126  KundeSumme von Umsatz 2009Summe von Kosten 2009Summe von Marge 09
4Gesamt1450108026%37-0  Gesamt 1'044'322.36 740'777.69 305'365.95
5Gesamt03830265-031%118  Gesamtergebnis 1'044'322.36 740'777.69 305'365.95
6Gesamt0020-0-0         
7Gesamt0004-0-0         

verwendete Formeln
Zelle Formel
G2 =WENN(B2=0; 0; B2*F2)
I2 =WENN(C2=0; 0; C2*H2)
G3 =WENN(B3=0; 0; B3*F3)
I3 =WENN(C3=0; 0; C3*H3)
G4 =WENN(B4=0; 0; B4*F4)
I4 =WENN(C4=0; 0; C4*H4)
G5 =WENN(B5=0; 0; B5*F5)
I5 =WENN(C5=0; 0; C5*H5)
G6 =WENN(B6=0; 0; B6*F6)
I6 =WENN(C6=0; 0; C6*H6)
G7 =WENN(B7=0; 0; B7*F7)
I7 =WENN(C7=0; 0; C7*H7)

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 11:10:55

Hallo Mike,

ich war nicht der Fragende!

Gruß
David


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 11:21:06

Hallo zusammen,

könnt ihr mir das auch als Datei senden, verstehe es aktuell noch nicht ganz. Möchte ja in meiner Pivot als Marge eine Prozentzahl haben und nicht eine absolute Zahl angezeigt'
Gruss und Danke
Dirk


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 11:44:34

Hier noch die Datei mit Pivot
https://www.herber.de/bbs/user/67126.xls


  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 11:57:21

Hallo Dirk,

meinst du das so?

https://www.herber.de/bbs/user/67127.xls


Gruß
David


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 13:07:56

ja total cool und wie hast du das gemacht


  

Betrifft: AW: Pivot von: Mike
Geschrieben am: 11.01.2010 13:12:19


Hey Dirk,

ist die Pivot mal erstellt, klickst Du nochmals rein und definierst über EINFUEGEN
- berechnetes Feld die Berechnung für die Marge.

Gruss
Mike


  

Betrifft: AW: Pivot von: David
Geschrieben am: 11.01.2010 13:15:15

Hallo Dirk

innerhalb der Pivottabelle lassen sich (einfache) Berechnungen anstellen. Die verwendeten Formeln sind in dem zusätzlichen Blatt aufgefügt. Am nachvollziehbarsten kommst du in die Dialoge, wenn du dir die Pivot-Symbolleiste einblendest, dort findest du auch die "berechneten Felder".

Gruß
David


  

Betrifft: AW: Pivot von: dirk0011
Geschrieben am: 11.01.2010 13:21:21

habe es hinbekommen..vielen Dank!!!!!


  

Betrifft: das berechnete Feld .. Pivot von: Mike
Geschrieben am: 11.01.2010 12:05:31


Hey Dirk,

hier als Version mit den Prozenten. Das berechnete Feld (für in %) wird wie folgt aufgesetzt
=Kosten09 / Umsatz 09


Tabelle1

 ABCDEFGHIJKLMN
1KundeUmsatz 2009Umsatz 2008Kosten 2009Kosten 2008Marge 2009Marge 09Marge 2008Marge 08         
2Gesamt3300107068%223-0    Daten   
3Gesamt5'0296'8142'7864'68845%224331%2126  KundeSumme von Umsatz 2009Summe von Kosten 2009Marge09%
4Gesamt1450108026%37-0  Gesamt 1'044'322.36 740'777.69 70.9%
5Gesamt03830265-031%118  Gesamtergebnis 1'044'322.36 740'777.69 70.9%
6Gesamt0020-0-0         
7Gesamt0004-0-0         

verwendete Formeln
Zelle Formel
G2 =WENN(B2=0; 0; B2*F2)
I2 =WENN(C2=0; 0; C2*H2)
G3 =WENN(B3=0; 0; B3*F3)
I3 =WENN(C3=0; 0; C3*H3)
G4 =WENN(B4=0; 0; B4*F4)
I4 =WENN(C4=0; 0; C4*H4)
G5 =WENN(B5=0; 0; B5*F5)
I5 =WENN(C5=0; 0; C5*H5)
G6 =WENN(B6=0; 0; B6*F6)
I6 =WENN(C6=0; 0; C6*H6)
G7 =WENN(B7=0; 0; B7*F7)
I7 =WENN(C7=0; 0; C7*H7)

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: das berechnete Feld .. Pivot von: Mike
Geschrieben am: 11.01.2010 12:19:53


... natürlich muss es heissten (Umsatz 09 - Kosten 09)/ Umsatz 09 .. ;-)

Gruss
Mike


  

Betrifft: stimmig .. Pivot von: Mike
Geschrieben am: 11.01.2010 12:23:42


... nun stimmig und mit Quercheck


Tabelle1

 ABCDEFGHIJKLMN
3  1'043'992963'365740'671677'799  29.05%  29.64%         
4                           
5KundeUmsatz 2009Umsatz 2008Kosten 2009Kosten 2008Marge 2009Marge 09Marge 2008Marge 08         
6Kunde A3300107068%223-0    Daten   
7Kunde B5'0296'8142'7864'68845%224331%2126  KundeSumme von Umsatz 2009Summe von Kosten 2009Marge09%
8Kunde C1450108026%37-0  Kunde A 32'399.60 22'419.99 31%
9Kunde B03830265-031%118  Kunde B 444'443.71 317'648.63 29%
10Kunde C0020-0-0  Kunde C 515'549.35 366'356.51 29%
11Kunde B0004-0-0  Kunde E 22'394.80 14'872.02 34%
12Kunde C02390106-056%133  Kunde D 19'808.25 14'720.85 26%
13Kunde B2720199027%73-0  Kunde F 9'726.65 4'759.69 51%
14Kunde C0020-0-0  Gesamtergebnis 1'044'322.36 740'777.69 29%

verwendete Formeln
Zelle Formel
B3 =TEILERGEBNIS(9; B7:B1000)
C3 =TEILERGEBNIS(9; C7:C1000)
D3 =TEILERGEBNIS(9; D7:D1000)
E3 =TEILERGEBNIS(9; E7:E1000)
G3 =(B3-D3)/B3
I3 =(C3-E3)/C3
G6 =WENN(B6=0; 0; B6*F6)
I6 =WENN(C6=0; 0; C6*H6)
G7 =WENN(B7=0; 0; B7*F7)
I7 =WENN(C7=0; 0; C7*H7)
G8 =WENN(B8=0; 0; B8*F8)
I8 =WENN(C8=0; 0; C8*H8)
G9 =WENN(B9=0; 0; B9*F9)
I9 =WENN(C9=0; 0; C9*H9)
G10 =WENN(B10=0; 0; B10*F10)
I10 =WENN(C10=0; 0; C10*H10)
G11 =WENN(B11=0; 0; B11*F11)
I11 =WENN(C11=0; 0; C11*H11)
G12 =WENN(B12=0; 0; B12*F12)
I12 =WENN(C12=0; 0; C12*H12)
G13 =WENN(B13=0; 0; B13*F13)
I13 =WENN(C13=0; 0; C13*H13)
G14 =WENN(B14=0; 0; B14*F14)
I14 =WENN(C14=0; 0; C14*H14)

Tabellendarstellung in Foren Version 4.28



Gruss
Mike