Knifflige Formel



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Knifflige Formel
von: Gregor
Geschrieben am: 25.05.2002 - 12:18:17

Hallo zusammen

Im Zusammenhang mit der Notenberechnung habe ich eine knifflige Rundungs-Frage.

In Spalten D und E stehen die Semesternoten, in den Spalten F und G die Maturanoten. In Spalte H der auf eine halbe Note gerundete Durchschnitt der Spalten D bis G.
Formel: =RUNDEN(MITTELWERT(D22;E22;F22;G22)/5;1)*5
(in den Spalten D bis G gibt es nur ganze und halbe Noten, 4.5)

Nun will ich in Spalte I die Note für das Maturazeugnis errechnen. Ergibt der Durchschnitt der Spalten D bis G XX.25 oder XX.75 wird es auf eine halbe oder ganze Note aufgerundet, wenn der Durchschnitt der Maturanoten F/G grösser ist als der Durchschnitt der Noten D/E. Im umgekehrten Fall wird er auf die nächste halbe oder ganze Note abgerundet.

Wer kann mir helfen?

Vielen dank und gruss
Gregor

nach oben   nach unten

Re: Knifflige Formel
von: Heinz Ulm
Geschrieben am: 25.05.2002 - 13:23:25

Hallo Gregor,
versuche es mal mit einer Wenn-Bedingung.
Ich habe folgende Bedingung für den Durchschnitt D:G aufgebaut.

=WENN(H4-GANZZAHL(G4)<=0,25;RUNDEN(H4;0);WENN(H4-GANZZAHL(G4)<0,75;GANZZAHL(H4)+0,5;GANZZAHL(H4)+1))

Schicke mir mal die Tabelle, ich weiß nicht wie ich den 2. Teil ausführen könnte. Vielleicht hilft Dir aber auch schon die obige Formel weiter.

Schönes Wochenende

Heinz

nach oben   nach unten

Re: Knifflige Formel
von: Heinz Ulm
Geschrieben am: 25.05.2002 - 14:05:33

Hallo Gregor,
in meiner Formel ist ein Fehler. Es muss immer lauten:
GANZZAHL(H4).
Sorry

Heinz

nach oben   nach unten

Re: Knifflige Formel
von: Arnim
Geschrieben am: 25.05.2002 - 16:46:38

Hallo Gregor,
also wenn ich das richtig durchschaue, könnte man folgende (lange) Formel nehmen:

=WENN(MITTELWERT(D22:E22)>MITTELWERT(F22:G22);ABRUNDEN(MITTELWERT(D22:G22)/5;1)*5;RUNDEN(MITTELWERT(D22:G22)/5;1)*5)

Dabei wird wohl der Notenschnitt der Semester-Leistung höher bewertet als die Abiturarbeit selbst!?
Sonst müßte man eben das > in ein < umwandeln.

Gruß Arnim

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Knifflige Formel"