Statistik



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Statistik
von: Martina
Geschrieben am: 28.05.2002 - 16:07:25

Ich möchte aus einer Spalte mit 205 verschiedenen Werten herausfinden, wieviel Werte dabei sind die zwischen 5 und 10 liegen. Ich komme einfach nicht dahinter wie es geht und wäre für Hilfe sehr dankbar.

Martina


nach oben   nach unten

Re: Statistik
von: andreas e
Geschrieben am: 28.05.2002 - 16:27:45

hallo Martina,

=SUMMENPRODUKT((F1:F100>=10)*(F1:F100<=5))

müsste funktionieren!

Etwas abgewandelt im Ursprung von Jürgen Recker !

gruß
andreas e

http://www.skripteundaufgaben.de

nach oben   nach unten

Re: Statistik
von: Daniel R.
Geschrieben am: 28.05.2002 - 17:18:06

Hallo andreas e
Ich war auch gerade am Austüfteln einer Lösung; ohne diese schon zu haben.
Bei Deiner Lösung ist mir allerdings nicht klar, weshalb die eigentlich funktioniert. Die Funktion in die einzelnen Elemente zerlegt, also =SUMMENPRODUKT(F1:F100<=10)= Null mal den zweiten Teil Deiner Funktion = nomals Null. Die Summe von Null plus Null müsste doch eigentlich ebenfalls Null ergeben. Da komme ich nicht dahinter.
PS, Wenn ich's richtig interpretiere, hast Du in Bezug auf die Frage von Martina die Zeichen "<>" verwechselt. Martina meint ">=5" oder "<=10".
Gruss Daniel R.
nach oben   nach unten

Re: Statistik
von: andreas e
Geschrieben am: 28.05.2002 - 17:38:55

hallo daniel,
zunächst mal danke für den Hinweis mit der Verwechslung.
Aber mit der Formel geht es mir genau so wie dir ! Daher auch mein Hinweis auf den Autor Jürgen.
Der hat diese auf www.excelformeln.de abgestellt. (Eine geniale Seite !!!). Ich kenne Jürgen zwar persönlich aber seine Denke werde ich wohl nie hin bekommen ! Grandios was er da teilweise zaubert - aber oft auch unverständlich für amateure wie mich !
gruß
andreas e

nach oben   nach unten

Re: Statistik
von: Martina
Geschrieben am: 29.05.2002 - 11:53:57

Danke für Eure Hilfe. Es funktioniert und irgendwann verstehe ich bestimmt warum :-)

Martina

nach oben   nach unten

Erklärung
von: Martin Beck
Geschrieben am: 29.05.2002 - 17:00:34

Hallo,

die Funktion SUMMENPRODUKT liefert als Ergebnis die Summe einer elementweisen Multiplikation von 2 oder mehr Matrizen. Beispiel: Wenn in A1:B3 folgende Zahlen stehen

3 4
2 5
5 3

dann liefert

=SUMMENPRODUKT(A1:A3;B1:B3) das Ergebnis 37

und

=SUMMENPRODUKT(A1:B1;A2:B2;A3:B3) das Ergebnis 90.

=SUMMENPRODUKT((F1:F100<=10)*(F1:F100>=5)) liefert das gleiche Ergebnis wie die Matrixformel

=SUMME((F1:F100<=10)*(F1:F100>=5))

Zuerst wird für F1 geprüft, ob der Wert kleiner oder gleich 10 ist. Falls ja, ist das Ergebnis der Wahrheitswert WAHR, der in einer Formel wie dieser als "1" verarbeitet wird. Falls nein, ist das Teilergebnis FALSCH oder "0". Im zweiten Schritt wird geprüft, ob F1 größer gleich 5 ist mit dem gleichen Ergebnis.

Es ergeben sich folgende denkbare Konstellationen für F1:

Wahr Wahr -- 1 * 1 = 1
Wahr Falsch -- 1 * 0 = 0
Falsch Wahr -- 0 * 1 = 0
Falsch Falsch -- 0 * 0 = 0

Nur dann, wenn beide Bedingungen für F1 erfüllt sind, ist das Ergebnis der elementweisen Mutiplikationgleich 1, sonst gleich 0. Das gleiche wird für F2:F100 durchgeführt und dann wird die Summe der Nullen und Einsen gebildet. Diese Summe entspricht dann genau der Anzahl der Zellen, für die beide Bedingungen erfüllt sind.

HTH

Gruß
Martin Beck


nach oben   nach unten

Re: Erklärung
von: Daniel R.
Geschrieben am: 30.05.2002 - 17:31:59

Hallo Martin
Jetzt ist alles klar. Die Funktionsweise der Formel ist so gut erklärt, dass selbst ich das kapiere. Spass bei Seite: ich habe Deine Erklärungen nochmals Schritt für Schritt nachvollzogen. Das ist ja eigentlich logisch, wie immer, wenn man etwas begriffen hat.
Besten Dank für Deine unerwartete Hilfe.
Gruss Daniel R.
 nach oben

Beiträge aus den Excel-Beispielen zum Thema "formel"