Summe bilden



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Summe bilden
von: Martina
Geschrieben am: 02.07.2002 - 21:23:50

Hallo, ich habe folgendes Problem:
Ich habe mehrere Tabellenblätter (Jan, Feb, Mrz ...) und möchte eine Summe auf einem weiteren Tabellenblatt (Gesamt) bilden.
Auf dem Tabellenblatt (Gesamt) steht unter H2 ein beliebiges Datum. In H3 habe ich folgende Formel eingetragen:
="'Jan:"&TEXT(H2; "MMM")&"'!A1"
Angezeigt wird: 'Jan:Apr'!A1
In H4 steht folgende Formel: =SUMME(INDIREKT(H3)).
Das klappt leider nicht. Wer kann mir einen Tipp geben?
nach oben   nach unten

Re: Summe bilden
von: Hans W. Herber
Geschrieben am: 03.07.2002 - 07:23:31

Hallo Martina,

die Indirekt-Formel läßt sich auf 3D-Bezüge nicht anwenden.

Die folgende benutzerdefinierte Funktion liefert die gewünschten Ergebnisse:


Function DreiDSum( _
   sWksA As String, _
   sWksB As String, _
   sRng As String) _
   As Double
   Dim wks As Worksheet
   Dim dValue As Double
   Dim bln As Boolean
   For Each wks In Worksheets
      If wks.Name = sWksA Then bln = True
      If bln Then
         dValue = dValue + WorksheetFunction.Sum(wks.Range(sRng))
      End If
      If wks.Name = sWksB Then bln = False
   Next wks
   DreiDSum = dValue
End Function

Eingabesyntax:
=dreidsum("Jan";TEXT(A1;"MMM");"A1")

hans

nach oben   nach unten

Re: Summe bilden
von: Martina
Geschrieben am: 03.07.2002 - 18:48:24

Hallo Hans,
danke für Ihre Hilfe. Leider klappt es nicht. Ich habe die Eingabesyntax im Tabellenblatt Gesamt unter
H4 eingefügt und die Funktion ebenfalls in diesem Tabellenblatt hinterlegt. Da das Datum in H2 eintragen ist, habe ich die Formel abgeändert: =dreidsum("Jan";TEXT(H2;"MMM");"A1"). Als Fehlermeldung erscheint: #Name?

Können Sie sich vorstellen, wo der Fehler liegt?

nach oben   nach unten

Re: Summe bilden
von: Rolf, Lgh.
Geschrieben am: 03.07.2002 - 19:23:27

Hallo Martina,
wechsle mit Alt+F11 in die Entwicklungsumgebung. Wähle dort Menü Einfügen / Modul
und kopiere dort den Code von Hans rein.
Wenn Du alles richtig gemacht hast, müßte es klappen.
Gruß Rolf

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden"