Microsoft Excel

Herbers Excel/VBA-Archiv

Kombinationsabfrage Zählenwenn in einem Intervall

Betrifft: Kombinationsabfrage Zählenwenn in einem Intervall von: Martin
Geschrieben am: 09.09.2014 22:27:00



Hallo zusammen,

ich sitze schon seit langem an einem Problem, für das ich auch noch keine Lösung im Internet gefunden habe bzw. ich nicht die richte Suchabfrage weiß.

Folgende Aufgabe:
Dazu bitte das Bild ansehen:


In der Spalte B sind gewisse „Erträge“ erreicht worden. Diese Erträge wurden unter Umständen nicht nur einmal sondern mehrmals (in konkretem Beispiel von 0 bis 4 Mal) erreicht. In einem ersten Schritt lege ich eine Grenze „Hoch“ und „Tief“ fest. Dabei möchte ich wissen wie viel „Erträge“ Gesamthaft in diesem Bereich vorhanden sind („Anzahl Soll“).

Nun zur Aufgabe die ich nicht lösen kann:
Wie lautet die Formel, wenn ich überprüfen möchte wie viel tatsächlich in diesem Intervall liegen („Anzahl Ist“). Ich möchte überprüfen wie viel bspw. im Intervall 3300 bis 3000 liegen unabhängig wie hoch die „Anzahl“ (wie oft dieser Ertrag erzielt wurde) ist. Das Ergebnis wäre in diesem Fall 6-Mal befindet sich eine „Anzahl“ im gewünschten Intervall. Zum Schluss wird dann das Delta mittels Differenz von „Anzahl Soll“ zu „Anzahl Ist“ ermittelt.

Ich hoffe es kann mir jemand weiter helfen!

Vielen lieben Dank!
Martin

  

Betrifft: AW: Kombinationsabfrage Zählenwenn in einem Intervall von: fcs
Geschrieben am: 10.09.2014 02:20:47

Hallo Martin,

hier kannst du mit der Funktion ZÄHLENWENNS oder SUMMENPRODUKT arbeiten.

Mit SUMMENPRODUKT solltest du arbeiten, wenn deine Lösung mit Versionen Excel 2003 und älter kompatibel sein soll.

Gruß
Franz

Tabelle4

 ABC
14HochTiefAnzahl Soll
15330030006
16299925001
17249919993
18   
19  6
20  1
21  3

Formeln der Tabelle
ZelleFormel
C15=ZÄHLENWENNS($B$2:$B$12;"<="&A15;$B$2:$B$12;">="&B15)
C16=ZÄHLENWENNS($B$2:$B$12;"<="&A16;$B$2:$B$12;">="&B16)
C17=ZÄHLENWENNS($B$2:$B$12;"<="&A17;$B$2:$B$12;">="&B17)
C19=SUMMENPRODUKT(($B$2:$B$12<=A15)*($B$2:$B$12>=B15)*1)
C20=SUMMENPRODUKT(($B$2:$B$12<=A16)*($B$2:$B$12>=B16)*1)
C21=SUMMENPRODUKT(($B$2:$B$12<=A17)*($B$2:$B$12>=B17)*1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: AW: Kombinationsabfrage Zählenwenn in einem Intervall von: Martin
Geschrieben am: 10.09.2014 06:50:16

Hallo Franz,

super vielen Dank für deine Antwort. Ich hab einen kleinen Fehler im Bild drinnen. Die Formel die ich angezeigt habe, liefert schon die "Sollwerte" für C15, C16 und C17.

Aber wie sieht die Formel für die "Istwerte" aus? Das Ergebnis für die Zelle "E15" müsste nämlich 4 sein (es kommen vier Werte in der Spalte C vor, welche im Intervall 3300 bis 3000 stehen).

LG
Martin


  

Betrifft: Summenprodukt einf. erweitern ... von: Matthias L
Geschrieben am: 10.09.2014 09:38:32

Hallo

 ABCD
1    
2 32990 
3 32880 
4 32772 
5 32121 
6 31002 
7 30994 
8 27001 
9 24330 
10 22001 
11 20011 
12 19981 
13    
14HochTiefSollIst
153300300064
162999250011
172499199932

Formeln der Tabelle
ZelleFormel
C15=SUMMENPRODUKT(($B$2:$B$12<=A15)*($B$2:$B$12>=B15)*1)
D15=SUMMENPRODUKT(($B$2:$B$12<=A15)*($B$2:$B$12>=B15)*($C$2:$C$12>0)*1)
C16=SUMMENPRODUKT(($B$2:$B$12<=A16)*($B$2:$B$12>=B16)*1)
D16=SUMMENPRODUKT(($B$2:$B$12<=A16)*($B$2:$B$12>=B16)*($C$2:$C$12>0)*1)
C17=SUMMENPRODUKT(($B$2:$B$12<=A17)*($B$2:$B$12>=B17)*1)
D17=SUMMENPRODUKT(($B$2:$B$12<=A17)*($B$2:$B$12>=B17)*($C$2:$C$12>0)*1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Summenprodukt einf. erweitern ... von: Martin
Geschrieben am: 12.09.2014 06:50:23

Genial! Vielen Dank für die Hilfe!!!

LG


  

Betrifft: AW: Kombinationsabfrage Zählenwenn in einem Intervall von: Martin
Geschrieben am: 10.09.2014 06:48:55

Hallo Franz,

super vielen Dank für deine Antwort. Ich hab einen kleinen Fehler im Bild drinnen. Die Formel die ich angezeigt habe, liefert schon die "Sollwerte" für C15, C16 und C17.

Aber wie sieht die Formel für die "Istwerte" aus? Das Ergebnis für die Zelle "E15" müsste nämlich 4 sein (es kommen vier Werte in der Spalte C vor, welche im Intervall 3300 bis 3000 stehen).

LG
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Kombinationsabfrage Zählenwenn in einem Intervall"